Closed Bug 1118152 Opened 6 years ago Closed 2 months ago

Enable/disable blackbox of source groups by context menu?

Categories

(DevTools :: Debugger, enhancement, P3)

enhancement

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: WeirdAl, Assigned: stepan)

References

(Blocks 2 open bugs)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

When I'm debugging files in resource://app, I really want to avoid debugging the rest of the source (components, resource://gre, chrome://global, etc.).

I'd love it if each source group had a context menu:
* Blackbox all files in this group
* Unblackbox all files in this group
* Blackbox all files outside this group
* Unblackbox all files outside this group

I'm having a little trouble figuring out the sources widget structure and SideMenuWidget.jsm.  If I could attach one debugger to inspect another debugger instance, that'd be great; then I might be able to figure this out and implement with Promise.all, based on the toggleBlackBoxing function in debugger-panes.js.
Product: Firefox → DevTools
Blocks: dbg-frontend
Type: defect → enhancement
Priority: -- → P3

I wouldn't mind working on this one @jlast.

  • "Blackbox/Unblackbox all files in this group" seem simple enough. You could get the contents of the directory that was right-clicked and apply blackbox to each item below them however many levels deep the file tree goes from there.

  • "Blackbox/Unblackbox all files outside this group" seems a little harder in that you'd have to take note of the files in the selected group (however many levels deep) and make sure to rule them out when blackboxing all the others.

Blocks: 1565711
Blocks: 1565713
No longer blocks: 1565711
No longer blocks: 1565713
Duplicate of this bug: 1570364

Hi there, I'd like to take this one.
I was wondering do you want to add a blackbox icon next to the folder icon if all files in the group are blackboxed as shown on this image?

Btw. I think Bug 1608312 is a duplicate of this one.

Flags: needinfo?(jlaster)

Adds 'Blackbox All' context menu item to the Sources Panel with a submenu with options for:

  • Blackbox all files in this group
  • Unblackbox all files in this group
  • Blackbox all files outside this group
  • Unblackbox all files outside this group
Assignee: nobody → obdelnik
Status: NEW → ASSIGNED
Flags: needinfo?(jlaster)
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe3297b857a5
Enable/disable blackbox of source groups by context menu? r=jlast
Regressions: 1625583
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

In documenting this, I discovered that blackboxing was covered only in Set event listener breakpoints, which is too limited in scope for this feature. So I documented all the file- and folder-level context menu options of the Source List pane in the Source List section of the Debugger UI Tour.

You need to log in before you can comment on or make changes to this bug.