[RTL][Settings] FxA login screens are left-aligned.

VERIFIED FIXED

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ychung, Assigned: ferjm)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

Posted image FxALeftAligned.png
Description:
Content on Firefox OS Account login screens are not aligned properly.

Repro Steps:
1) Update a Flame device to BuildID: 20150106010234.
2) Set the device language in Arabic under Settings > Language.
3) Go to Settings > Firefox Accounts.
4) Go through the login steps.
  
Actual:
Text is left-aligned.
  
Expected: 
Text is right-aligned.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150106010234
Gaia: b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko: 2a193b7f395c
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
redirect issue to FxA
No longer blocks: settings-rtl
Component: Gaia::Settings → FxA
Ok so Stephany, the thing I'm not sure about here is (according to the current spec version) :
Should we or should we not mirror the steps indicator? the one right under the header that moves a step forward when we go to the next page?
Should that be mirrored to start from the right and its steps become moving from the right to the left?

Thanks
Assignee: nobody → nefzaoui
Flags: needinfo?(swilkes)
The original bug, as filed, is correct: text should be aligned right and it is not. 

Ahmed, the steps indicator would be a separate bug as it's different from the original bug Description. We did not specify that it should change for 2.2 but I'm inclined to say we shouldn't change them, as the steps probably correspond to animation direction and that is not changing. This is something we may want to add to the post 2.2 pattern.
Flags: needinfo?(swilkes)
Comment on attachment 8559409 [details] [review]
[PullReq] anefzaoui:bug-1118437 to mozilla-b2g:master

Then this is ready for review.

Asking for ui-review over a patch instead of a screenshot because the PR affects many views.

It's preferably tested in v2.2, the misaligned Firefox logo in v3.0 is caused by bug 1121748.

Thanks!
Attachment #8559409 - Flags: ui-review?(swilkes)
Attachment #8559409 - Flags: review?(alive)
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #7)
> Comment on attachment 8559409 [details] [review]
> [PullReq] anefzaoui:bug-1118437 to mozilla-b2g:master
> 
> Then this is ready for review.
> 
> Asking for ui-review over a patch instead of a screenshot because the PR
> affects many views.
> 
> It's preferably tested in v2.2, the misaligned Firefox logo in v3.0 is
> caused by bug 1121748.
> 
> Thanks!

BTW, 1121748 fix should appear in tomorrow's 3.0 builds.
Comment on attachment 8559409 [details] [review]
[PullReq] anefzaoui:bug-1118437 to mozilla-b2g:master

css only change, r=me
Attachment #8559409 - Flags: review?(alive) → review+
Comment on attachment 8559409 [details] [review]
[PullReq] anefzaoui:bug-1118437 to mozilla-b2g:master

Reassigning ni? to Jacqueline for FTE/FxA. Jacqueline, please reassign as necessary. Thanks!
Attachment #8559409 - Flags: ui-review?(swilkes) → ui-review?(jsavory)
Jacqueline, please note that you should test this patch on 2.2 and not master, per comment #7.
Duplicate of this bug: 1036833
Update: please feel free to test on 3.0 also now as our gecko blocker has been happily resolved.
Hey Stephany,
Is Jacqueline around? I need this reviewed the soonest possible :)

Thanks!
Flags: needinfo?(swilkes)
Ahmed, I have a meeting with the Firefox Accounts team this afternoon. I am flagging John Gruen, UX on Firefox Accounts, in the meantime. Sorry for the back and forth.
Flags: needinfo?(swilkes) → needinfo?(jgruen)
Comment on attachment 8559409 [details] [review]
[PullReq] anefzaoui:bug-1118437 to mozilla-b2g:master

Assigning ui-review? to John.
Attachment #8559409 - Flags: ui-review?(jsavory) → ui-review?(jgruen)
Hey John,
Could you please see attachment 8559409 [details] [review] ? We need to get this merged ASAP.
Thanks!
CSS changes look good to me.
Flags: needinfo?(jgruen)
Attachment #8559409 - Flags: ui-review?(jgruen) → ui-review+
Thanks!
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Dear Ahmed,
Could you kindly provide ETA date (Target Milestone) for this issue? Thank you very much!
Blocks: settings-rtl
Status: NEW → ASSIGNED
Flags: needinfo?(nefzaoui)
Ahmed - we can manually land this one, but could you rebase against master first? It can't be merged. Thanks!
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15738/
Flags: in-moztrap+
This is assigned to :nefzaoui but he's not working on 2.2 anymore. Can someone else please pick-up this bug?
Unassigning so someone else can grab this.
Assignee: nefzaoui → nobody
Flags: needinfo?(nefzaoui)
Status: ASSIGNED → NEW
Not sure if this should get a fix from someone in FxA or Settings, so adding both Engineering Managers here. Sorry in advance for the possible noise.
We are one week away from FC and this bug should get a fix. Can an EM please assign this to someone? thanks!
Flags: needinfo?(timdream)
Flags: needinfo?(ianb)
Ian, this is in the FxA screen I think.
Flags: needinfo?(timdream)
Are we just looking for someone who can resolve the conflicts on https://github.com/mozilla-b2g/gaia/pull/27941 ?  I otherwise get the impression from these comments that the it was a fix and reviewed, it just never quite landed.
Ian, yes I believe that's what we need.
Assignee: nobody → ferjmoreno
https://github.com/mozilla-b2g/gaia/commit/5f85b2592fb75aebc3d3fefeec38000143919bb2
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(ianb)
Resolution: --- → FIXED
This issue has been verified successfully on latest build of Flame 3.0 with the same steps in comment 0.
See attachment:log_in_firefox_account.png
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150413010203
Gaia Revision          3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gaia Date              2015-04-10 14:38:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a46652bd992
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150413.043544
Firmware Date          Mon Apr 13 04:35:55 EDT 2015
Bootloader             L1TC000118D0

------------------------------------------
This issue do not exist on latest build of Flame 2.2 with the same steps in comment 0.
Rate:0/5

Device: Flame 2.2 (unaffected)
Build ID               20150413162504
Gaia Revision          73645b097720f3ca594a14d288b87d3885d7fc9d
Gaia Date              2015-04-13 19:30:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/85ea1be9ac7d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150413.202157
Firmware Date          Mon Apr 13 20:22:08 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.