Closed Bug 1118467 Opened 6 years ago Closed 5 years ago

Keyboard doesn't stay open when trying to input text on mobile.jetblue.com site

Categories

(Web Compatibility :: Mobile, defect)

Firefox 37
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

()

Details

(Keywords: reproducible, Whiteboard: [needscontact] [js] [lib-ufx])

Nexus 6 running 5.0.1 on the latest Firefox beta.

STR:
1. Open jetblue.com site
2. Select Flight Status | Check Flight Status
3. Attempt to type a flight number in the Flight number box

Expected: The keyboard would stay up until I finish typing the flight number
Actual: The keyboard closes abruptly before I finish typing.

On the same device, the site works fine using the Chrome browser.
Possibly a site issue with event handling on the input, cc'ing Mike.
tracking-fennec: --- → ?
Keywords: reproducible
OS: Mac OS X → Android
Hardware: x86 → ARM
Flags: needinfo?(miket)
Hmm, this doesn't reproduce for me on my phone or Nexus 7 (nightly or stable). One thing that is a bit weird is I have to scroll down after the keyboard pops up to see the input. 

Marcia, would you mind testing again?
I should note that I'm running 4.4.4 on both... unsure if 5.0.1 is the difference.
Mike: I attached a video which shows the behavior on the mostly currently nightly on my device: http://youtu.be/FQRFOGRTEI8

Note that eventually you can get the keyboard to stay up, but as the video shows the experience is not that great. I tested on the most recent FF Beta and the same thing happens.
Flags: needinfo?(mozillamarcia.knous)
Thanks for the video, Marcia. Maybe I can try to upgrade my Nexus 7 to lollipop and see if that makes a difference.
Assignee: nobody → esawin
tracking-fennec: ? → 38+
Duplicate of this bug: 1123405
This issue is caused by a site script [1], which blurs the input element on focus for certain screen dimensions.

It reproduces on Nexus 5 in portrait orientation, but not on Nexus 5 in landscape orientation or Nexus 7 (any orientation).
Turning your device into landscape mode should be a workaround until the site/script owner fixes the issue.

Also, see bug 961460 for the same issue on a different site with the same offending script. 

[1] http://mobile.jetblue.com/ufx/1.1rc7/ufx.js
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 961460
> Turning your device into landscape mode should be a workaround until the site/script owner fixes the issue.

Let's re-open and move back to TE so we can advocate for this fix.
Status: RESOLVED → REOPENED
Component: Keyboards and IME → Mobile
Product: Firefox for Android → Tech Evangelism
Resolution: DUPLICATE → ---
Whiteboard: [contactready] [js] [lib-ufx]
Status: REOPENED → NEW
tracking-fennec: 38+ → ---
Assignee: esawin → nobody
Whiteboard: [contactready] [js] [lib-ufx] → [needscontact] [js] [lib-ufx]
I take it that this hasn't been fixed yet? I have just encountered what I think may be the same bug, although the symptom was slightly different. The keyboard doesn't open at all when I touch the input area using Firefox as my browser. Switching to landscape mode fixes the problem! I encountered the problem trying to login to my AdSense account; then, the same problem when I tried to login to my Amazon Associates account! I doubt it's the code (both of them?), although Amazon certainly sets no records of perfection with their Associates system code.

I did not have a problem on my Nexus 4 with KitKat; just switched to a (hand me down) Nexus 5 with Lollipop. And, there is no problem with Chrome on either phone.

If you have a potential fix and need someone to test, I'd be happy to.
Interesting, would you mind posting the URLs to the other sites you mentioned that have the same problem? I'm curious to see if there's a common pattern in the way it's blurring the input on focus.
Flags: needinfo?(vlmagee)
(If there's a common pattern, it's probably going to be: blur action happens in response to something the site does on window resize. My best guess is that we'll have to find a way to *not* resize windows when we open on-screen keyboards.. Or at least avoid sending a resize event for that specific case. It might be a good idea to just open a core bug on that and hear what the devs think.)
Amazon: http://amazon.com/associates (Sign-in is at top of screen)

Google AdSense: http://adsense.google.com (Link for Sign-in is at top of screen. You should be signed into Google when you do this to get to the same place)

A couple of additional comments/corrections. I just tried again on the Nexus 5 and it no longer fails!  I'll play around with it later and see if I can reproduce it (it may be because the userid is now cached for both sites). Also, the Nexus 4 is on 5.0.1 Lollipop; the Nexus 5 is on 6.0 Marshmallow.
Flags: needinfo?(vlmagee)
Further note: I still can't reproduce it(!) I tried a private window and a guest user, but now it stubbornly works.  FYI, this happened on first use of Firefox on the Nexus 5. (I assure you I wasn't imagining it; my husband, who is the strong techie here, saw it himself. But he is not a Firefox user, so he didn't pursue it).
I can't reproduce it either at first use. I propose we close it as worksforme and if it happens again we can still reopen it. 

Thanks everyone.
Status: NEW → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.