Closed Bug 1118545 Opened 6 years ago Closed 6 years ago

[FFOS2.0][Woodduck][Network][data connection]can't enable data conection through shortcut.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P1)

defect

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 unaffected)

VERIFIED FIXED
2.2 S4 (23jan)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- unaffected

People

(Reporter: sync-1, Assigned: GaryChen)

References

Details

Attachments

(4 files)

my tel:13502294315
 
 DEFECT DESCRIPTION:
  can't enable data conection through shortcut.
 
  REPRODUCING PROCEDURES:
  1.download SW and data connection must be first open before test, insert CU SIM card to MS, then power on
  2.go to settings>cellular&data>network operator and type search networks
  3.wait for network list dsiplay. then slide down the screen and enable the data conection.--KO
 >data connection can not be enabled
 
 note:when go to setting, there will be an alert message of turn data conection. it user enable it, the data conection on. but if user not go to settings, he cann't set data connection on all the time.
 
  
  EXPECTED BEHAVIOUR:
  data connection can be set to on through shortcut.
  
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
  tel:0752-2639245
Hi Gary:
 Could you please help check this issue?

I also can repo. this bug on pure Mozilla Build.

STR:
1. Settings -> Cellular & Data -> Network operator -> un-check "Automatic selection"
2. Press Home button
3. drag down status bar, click "data" icon

Sympton:
Nothing happened, but if we click setting icon, there will be a warning page for user to indicate "Turn ON data connection?"

Expected result:
Should dismiss statusbar, and show "Turn ON data connection" page to user.
Flags: needinfo?(gchen)
blocking-b2g: --- → 2.0M?
Assignee: nobody → gchen
Hi EJ,
   Could you help to review this patch?
   Thanks.
Attachment #8545104 - Flags: review?(ejchen)
Component: Gaia::First Time Experience → Gaia::Settings
Flags: in-moztrap?
Dear all,
    verify ok,thanks
Comment on attachment 8545104 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/27187

Thanks Gary, r+ with few nits waiting to be addressed !
Attachment #8545104 - Flags: review?(ejchen) → review+
blocking-b2g: 2.0M? → 2.0M+
Status: NEW → ASSIGNED
Dear dengwei,
    this pr have fixed,please close it
land in v2.0m:
https://github.com/mozilla-b2g/gaia/commit/41aff992540fbf34ac005415712f85c32f5460dd
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attached file PR for v2.1
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined:
User can not enable data connection from utility tray. 
[Testing completed]:
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=e6ae936119dd
[Risk to taking this patch] (and alternatives if risky):
low
[String changes made]: N/A
Attachment #8549414 - Flags: approval-gaia-v2.1?
This bug has been successfully verified on Woodduck v2.0.
See attachment: verified_v2.0m.mp4.
Reproduce rate: 0/5

STR:
1. Insert a CU SIM card and power on device.
2. Go to Settings -> Cellular & Data -> Network operator -> disable "Automatic selection".
3. Press Home button
4. Drag down from the status bar, click "Data" icon
**Data connection can be set via the utility tray.

Woodduck 2.0 build:
Gaia-Rev        22e3b7855281aa7b6190e01b4bd50c79880a1e6a
Gecko-Rev       20943fe7b54c63a375952fbd8dd396a22ee893e7
Build-ID        20150116050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1421355897
FW-Date         Fri Jan 16 05:05:17 CST 2015
Attachment #8549414 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
This bug has been successfully verified on Flame v2.1.
See attachment: verified_v2.1.mp4.
Reproduce rate: 0/5.

Flame 2.1 build:
Gaia-Rev        2119de79b6edfbcd4f112b2f797dbd7dba17ea69
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/804697da948c
Build-ID        20150122161216
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150122.193955
FW-Date         Thu Jan 22 19:40:06 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
Flags: in-moztrap?
You need to log in before you can comment on or make changes to this bug.