[Messages][SMS] Keyboard Lingers in thread list after Group Message, breaks UI when used

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: steveck)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-Daily-Testing][sms-sprint-2.2S4], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8545476 [details]
logcat_20150107_1351.txt

Description:
When a user sends an SMS message to more than one contact (group message), they will observe that their UI is shifted to the landing page for Messages, the thread list. The keyboard follows the user through this transition where  it does not provide functionality, and tapping on this keyboard will break the edge of the phone by dragging the Group Message UI from right towards center screen. 
This appears to be occurring because SMS messages do not have a home thread, and when sent to multiple contacts all spawn their own individual thread. The native behavior of SMS as of bug 1033334 [1] is to retain focus of keyboard after sending a message, so with the current thread being "killed" because a group message does not hold it's participants for text messages, the keyboard is made to remain in an improper UI context.

[1]https://bugzilla.mozilla.org/show_bug.cgi?id=1033334

   
Repro Steps:
1) Update a Flame device to BuildID: 20150107010216
2) Open 'Messages' app.
3) Compose a new message.
4) Add 2+ numbers/contacts to the message.
5) Type a message. [Do not add subject or picture, must be SMS]
6) Send the message.
7) Observe UI: present keyboard in Messages Landing.
8) Use keyboard, observe UI breaking from the right edge.
  
Actual:
Keyboard is retained at Messages Landing after sending a group message. Breaks UI when used
  
Expected: 
Keyboard is dismissed when user leaves current thread.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150107010216
Gaia: 69ac77cfa938fae2763ac426a80ca6e5feb6ad25
Gecko: 33781a3a5201
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
  
Repro frequency: 6/6
See attached: 
logcat
video- http://youtu.be/qxG0X3tXnpg
(Reporter)

Comment 1

4 years ago
Issue DOES NOT REPRO on flame 2.1 devices:
Results: Keyboard is dismissed when user leaves current thread.
Repro frequency: 3/3

Environmental Variables:
----------------------------------------------
Device: Flame 2.1
BuildID: 20150107001244
Gaia: b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko: 99cea2c818f6
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware: V18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------------------
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.2-Daily-Testing]
Definitely a regression of bug 1033334.
Blocks: 1033334
blocking-b2g: --- → 2.2?
Triage: Regression.
blocking-b2g: 2.2? → 2.2+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
(Assignee)

Comment 4

4 years ago
Will take a look first.
Assignee: nobody → schung
(Assignee)

Comment 5

4 years ago
Created attachment 8548695 [details] [review]
Link to github

Hi Oleg, it's a tiny fix for 2.2 about the bug 1033334 regression. We have another bug 1116978 for complete fixing in the future.
Attachment #8548695 - Flags: review?(azasypkin)
Comment on attachment 8548695 [details] [review]
Link to github

Thanks for the quick fix!
Attachment #8548695 - Flags: review?(azasypkin) → review+
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing][sms-sprint-2.2S4]
(Assignee)

Comment 7

4 years ago
Thanks!

In master: 48a42366a89bcda06ef22a9e53344176fef453cb
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this when you get a chance :)
status-b2g-master: --- → fixed
Flags: needinfo?(schung)
Target Milestone: --- → 2.2 S4 (23jan)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8548695 [details] [review]
Link to github

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1033334
[User impact] if declined: Inappropriate keyboard display after sending multi recipient sms
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Flags: needinfo?(schung)
Attachment #8548695 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8548695 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: The keyboard disappears properly when the user selects the send button.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Gaia: e768af6558957ddb0f6a9ce579ea41c3e3d0b203
Gecko: fec90cbfbaad
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150410002502
Gaia: df0e04acad7c8c993f6ffe07b0ccb0ec20ee50bb
Gecko: 091b1cc1240b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.