Ability to drag and drop tab site icon

RESOLVED FIXED

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: xyzzy, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Site icons can already be dragged and dropped from the URL bar.  It would be
nice to do the same with the site icons in the tabs.

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Updated

16 years ago
OS: Windows 98 → All
Hardware: PC → All

Comment 1

16 years ago
Reassigning to new component owner.
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW

Comment 2

16 years ago
This bug is a duplicate of bug 110546.  (I just finished marking my own bug
156235 as a duplicate.)

Unable to mark as duplicate (or mark on status whiteboard) since I have
insufficient privileges.  Somebody?

Comment 3

16 years ago
*** Bug 110546 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Actually, why would we restrict it to just the site icon? Why not be able to
drag the whole tab, and when it's dropped in the bookmarks manager, sidebar
panel, or personal toolbar, extract the relevant bookmark information? This
gives a much larger area to drag and fits in nicely with proposals for the
ability to rearrange tabs, drag them out to create a new window, and drag them
over to a new window.

Comment 5

16 years ago
Comment 4 (dragging the whole tab sounds) like a great idea to me, especially
since there are some bugs floating around that want to do away with the tab site
icon in one fashion or another.  Adding D&D for this function would, indeed,
help in the codebase for other D&D functions.

Updated

16 years ago
Blocks: 120352
QA Contact: sairuh → pmac
Summary: [RFE] Ability to drag and drop tab site icon → Ability to drag and drop tab site icon
This bug should block bug 126299 too !

Reply to comment 4 (and 5):
See bug 126299 for bugs about your other suggestions.

Comment 7

15 years ago
*** Bug 156235 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 210477 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future

Comment 10

14 years ago
I like the extract relevent info idea. But basically, tabs must first become
drag and droppable, which means bug 105885 needs to be dealt with first. After
that, this bug should be used to move relevent information in (comment 4) and as
such would also deal with part of bug 102132 (dropping a tab to the tab bar of a
new window would move the tab etc). But those two bugs are relevent to this one.
If this bug is headed where comment 4 wants it to, the subject line should be
changed to something like "Make tabs drag and drop able, paste relevent info".
Unfortunately, such a bug would likely not be implemented in the near future, so
maybe we should just stick with the reporter's idea.

Comment 11

14 years ago
*** Bug 254197 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
I don't believe this bug belongs in "Core" since everything comment #4 asks is
currently implemented in Firefox 1.5b1.

If this is still an desired enhancement for the Seamonkey project, then either
this bug's product field should be changed accordingly or it should be resolved
as WORKSFORME/FIXED and a new bug report against Seamonkey filed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rev:1.8b5) Gecko/20050928
Firefox/1.4

Comment 13

12 years ago
The movement of tabs themselves is being handled by bug 105885 (see comment 10).
 (I made a stupid comment 3 three years ago when I didn't know better - it
confused the issue.  Comments 4 and 5 are somewhat of a red herring to this bug,
even if related.)

This is specifically about the tab site *icon* being being dragged and dropped
from a tab to the tab bar - just like the icon can be dragged and dropped from
the URL to the tab bar.  Not moving it, but copying it.

Even if this can be considered to be partially fixed (by Firefox -> Core) it's
not fully fixed (Seamonkey -> Core).  Bugs that are filed under Core and then
only fixed under one product are normally not reassigned based on that.
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser
Target Milestone: Future → ---

Comment 14

7 years ago
I think this bug needs to get closed, as it is fixed long ago, I think. You can drag the tab itself to the bookmarks/bookmarks panel.
This is a SeaMonkey bug.

Comment 16

7 years ago
(In reply to comment #15)
> This is a SeaMonkey bug.

Oops, didn't notice that.

Comment 17

3 years ago
(In reply to Joe Wilson from comment #14)
> I think this bug needs to get closed, as it is fixed long ago, I think. You
> can drag the tab itself to the bookmarks/bookmarks panel.

Correct.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.