Closed Bug 1119168 Opened 5 years ago Closed 4 years ago

[Homescreen][v2.0] Screen stays in smart collection, and then locks the device. Status bar shows wallpaper's color after user unlocks device.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 fixed, b2g-v2.2 unaffected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- fixed
b2g-v2.2 --- unaffected

People

(Reporter: whsu, Unassigned)

References

Details

(Keywords: polish, regression)

Attachments

(1 file)

Attached image 2015-01-08-18-03-56.png
+++ This bug was initially created as a follow-up of Bug 1030923 +++

@ Description:
  I can reproduce this bug on latest v2.0, but I cannot reproduce this bug on latest v2.1 build.
  Screen stays in smart collection, and then locks the device. Status bar shows wallpaper's color after user unlocks device.

@ Prerequisite:
  Connect to WIFI network

@ Reproduction steps:
 1. Tap on a smart collections (Music, Social, or Games...)
 2. Press power key to lock the device
 3. Press power key again to unlock device
 4. Check the status bar

@ Detailed Symptom:
  Status bar shows wallpaper's color.
  As attachment. (2015-01-08-18-03-56.png)

@ Expected :
  The status bar shows black color

@ Build information:
  - Gaia-Rev        f76014fd2c7528493b90d759c68ec3070233d094
  - Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/53ff92e647a0
  - Build-ID        20150107000201
  - Version         32.0
  - Device-Name     flame
  - FW-Release      4.4.2
  - FW-Incremental  eng.cltbld.20150107.033038
  - FW-Date         Wed Jan  7 03:30:49 EST 2015
  - Bootloader      L1TC00011880
The original bug (Bug 1030923) tagged "blocking-b2g:2.0+".
I nominate it again to see if 2.0 or 2.0M need to fix this problem.

Thanks.
blocking-b2g: --- → 2.0M?
See Also: → 1030923
Hi Kevin,
Can you help to check this issue? It should be fix with bug 1030923 but seems still exist in 2.0/2.0M but not in 2.1.
Blocks: Woodduck
Flags: needinfo?(kgrandon)
Keywords: regression
Hi, Josh and Kevin,

Thanks for your help.
I saw Kai-Zhen merged a v2.0+v2.0m patch (Bug 1030923) just now.
So, I would like to verify it firstly, and then see if we need further action.

Thanks.
(In reply to William Hsu [:whsu] from comment #3)
> Hi, Josh and Kevin,
> 
> Thanks for your help.
> I saw Kai-Zhen merged a v2.0+v2.0m patch (Bug 1030923) just now.
> So, I would like to verify it firstly, and then see if we need further
> action.
> 
> Thanks.

Hi, Josh and Kevin,

After verify the patch that Kai-Zhen merged, it fixed bug 1030923.
So, I think this is a legacy bug that we are not yet fixed because the reproduction steps are different.
Also, modifying the subject.
Summary: Follow-up of Bug 1030923. [Homescreen][v2.0] Screen stays in smart collection, and then locks the device. Status bar shows wallpaper's color after user unlocks device. → [Homescreen][v2.0] Screen stays in smart collection, and then locks the device. Status bar shows wallpaper's color after user unlocks device.
Is the branch status accurate here? Perhaps we should consider doing branch checks again, and finding what fixed it with a reverse regression window?
Flags: needinfo?(kgrandon)
Not blocking but polish.

Hi William,
Can you repo this in 2.1/2.1 with step to lock/unclock device?
Thanks!
blocking-b2g: 2.0M? → ---
Flags: needinfo?(whsu)
Keywords: polish
(In reply to Josh Cheng [:josh] from comment #6)
> Not blocking but polish.
> 
> Hi William,
> Can you repo this in 2.1/2.1 with step to lock/unclock device?
> Thanks!

As shally mentioned, this bug cannot be reproduced on v2.1 & v2.2.
https://bugzilla.mozilla.org/show_bug.cgi?id=1030923#c10

Many thanks. :)
Flags: needinfo?(whsu)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.