[Contacts] When adding a “New Contact” The Fax office, Fax home and zip code words are truncated

RESOLVED DUPLICATE of bug 1157172

Status

RESOLVED DUPLICATE of bug 1157172
4 years ago
4 years ago

People

(Reporter: patryksowa0, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: LocRun2.2, )

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8545919 [details]
contacts-pl.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

1) Have the device language set to “Polski”  
2) Open the "Contacts" app 
3) Select (+) to add a new contact



Actual results:

The Words "Fax office", "Fax home" and "zip code" are truncated in Polish.


Expected results:

The Words "Fax office", "Fax home" and "zip code" are truncated in Polish.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Delphine, do you think the truncation here is correctly displayed here?
Flags: needinfo?(lebedel.delphine)
Zip code truncation looks strange indeed but the real issue is that we can't find short enough translations to fit the current design.
Hi. I've created again a tracking bug for truncation, this time for 2.2: Bug 1118864
I'll add this one there. If you find further similar issues, please attach to that meta as well.

That said, I'll flag UX to see if they can advise about this. I agree it looks bad, and there's only so much you can shorten. In this particular case, I don't see how we could shorten more, as mentions also Polish localizers Stefan in comment 2.
This probably happens with many more locales, so asking for UX help on this one! thanks all
Blocks: 1118864
Flags: needinfo?(lebedel.delphine) → needinfo?(firefoxos-ux-bugzilla)

Comment 4

4 years ago
I agree that there isn't much we can do here if we can't shorten the string past a certain point. Flagging Eric while I'm on PTO in Mexico in the hope that he can triage this out to someone on our team and see if they have suggestions that might work. If not, we'll have to ship this as-is for now.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(epang)
(In reply to Stephany Wilkes from comment #4)
> I agree that there isn't much we can do here if we can't shorten the string
> past a certain point. Flagging Eric while I'm on PTO in Mexico in the hope
> that he can triage this out to someone on our team and see if they have
> suggestions that might work. If not, we'll have to ship this as-is for now.

Thanks Steph, (why are you working while you're on PTO!  Go enjoy the sun!).
I'm going to hand this off to Fang Shih since she worked on the redesign of the contact details screen.

Fang is there anything that can help with truncation here?
Flags: needinfo?(epang) → needinfo?(fshih)

Comment 6

4 years ago
Created attachment 8551622 [details]
Contacts_detail.png

Thanks Eric! 
I've discussed with the UX designer. The only thing we can do about this right now is to extend the width of both value selectors. I've attached the screenshot with the look of wider width value selector. If this is going to take too much effort to adjust the box, I agree we'll have to leave this as is for now. Let me know if you need anything else. Thanks!
Flags: needinfo?(fshih)

Comment 7

4 years ago
Change system language to Rassiuan,this issue exist in Flame 2.2&2.1:
Description:Enter add new contact view,the hint text of"Zip code" "fax home" "Fax office" "Fax other" on value selector button should be displayed completely. 
Attchment:2015-04-22-05-48-19.png and 2015-04-22-05-48-37.png

[2.Testing Steps]: 
1.Launch contact
2.Tap + to enter Add contact view

[5.Reproduction build]: 
Device: Flame 2.2 user build (Affected)
Build ID               20150422002505
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a87a05e7d0ef
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.040316
Firmware Date          Wed Apr 22 04:03:27 EDT 2015
Bootloader             L1TC000118D0

Device Flame 2.1 user build (Affected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10
QA Whiteboard: [MGSEI-Triage+]
Whiteboard: MGSEI-l10n-1F-Russian

Comment 8

4 years ago
Created attachment 8599080 [details]
Serbian Cyrillic_Fax office.png

Set system language as Serbian Cyrillic, this issue can be repro on latest build of Flame 2.1/2.2 with the same steps in comment 7. The "Fax office" "Fax other" on value selector button are truncated. 
See attachment:Serbian Cyrillic_Fax office.png & Serbian Cyrillic_Fax other.png
Rate:5/5

Device: Flame 2.2 user (affected)
Build ID               20150428002500
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.042314
Firmware Date          Tue Apr 28 04:23:26 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user (affected)
Build ID               20150428001200
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/5f2c57b580ff
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.035731
Firmware Date          Tue Apr 28 03:57:42 EDT 2015
Bootloader             L1TC000118D0

Comment 9

4 years ago
Created attachment 8599081 [details]
Serbian Cyrillic_Fax other.png

Updated

4 years ago
Whiteboard: MGSEI-l10n-1F-Russian → LocRun2.2, MGSEI-l10n-1F-Russian, MGSEI-l10n-1F-Serbian Cyrillic
Created attachment 8601087 [details]
Arabic_Fax_Office.png

This issue also reproduces in Arabic. The string "Fax Office" is truncated.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150504010202
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: dc5f85980a82
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Flags: needinfo?(ktucker)
QA Whiteboard: [MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Russian, MGSEI-l10n-1F-Serbian Cyrillic → LocRun2.2,
[Blocking Requested - why for this release]:

Seems like this was dropped. Since we're past CC for 2.2, nominating this for 3.0 - in the case that this is still relevant in the upcoming release that we still don't know much about
blocking-b2g: --- → 3.0?
Status: NEW → RESOLVED
blocking-b2g: 3.0? → ---
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157172
You need to log in before you can comment on or make changes to this bug.