If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RTL][[Utility Tray] Notifications appear when the user pulls down the utility tray but then they disappear

RESOLVED DUPLICATE of bug 1121748

Status

Firefox OS
Gaia::System::Window Mgmt
P1
normal
RESOLVED DUPLICATE of bug 1121748
3 years ago
3 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

Description:
New notifications appear at first when the user pulls down the utility tray but then they disappear completely.
   
Repro Steps:
1) Update a Flame device to BuildID: 20150108010221.
2) Pull down the utility tray and pay close attention to the notifications.

Actual:
Notifications appear at first but then they disappear.
  
Expected: 
Notifications remain in the utility tray until the user clears them.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150108010221
Gaia: d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko: 70de2960aa87
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
Created attachment 8546051 [details]
NotificationsDisappear.JPG
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Depends on: 1121748
blocking-b2g: --- → 2.2?
Priority: -- → P1
Blocking per RTL triage for 2.2
blocking-b2g: 2.2? → 2.2+
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2+ → ---
feature-b2g: --- → 2.2+
Ahmed, per bug 1058799 comment 14 is this a dupe of bug  1121748?
Flags: needinfo?(nefzaoui)

Comment 5

3 years ago
Created attachment 8556860 [details]
Notifications.png

This issue do not exist on latest build of Flame 2.2, the notifications shown as right-aligned.
See attachment:Notifications.png

Flame 2.2 build:
Gaia-Rev        6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Build-ID        20150129003432
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.042943
FW-Date         Thu Jan 29 04:29:53 EST 2015
Bootloader      L1TC000118D0

Updated

3 years ago
Whiteboard: [systemsfe]
(In reply to Michael Henretty [:mhenretty] from comment #4)
> Ahmed, per bug 1058799 comment 14 is this a dupe of bug  1121748?

Hey Michael, sorry for late.
We made this one and its sisters dependencies rather than dupes to keep an eye on them all before and after the gecko bug is addressed.
Flags: needinfo?(nefzaoui)
(In reply to Sue from comment #5)
> Created attachment 8556860 [details]
> Notifications.png
> 
> This issue do not exist on latest build of Flame 2.2, the notifications
> shown as right-aligned.
> See attachment:Notifications.png

Looks like the regression was backed out of 2.2 but not master (3.0).
https://bugzilla.mozilla.org/show_bug.cgi?id=1121748#c27
Let's leave this open until bug 1121748 is fixed on master.
Duplicate of this bug: 1126630
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15678/
(In reply to Alissa from comment #10)
> Test case has been added in moztrap:
> https://moztrap.mozilla.org/manage/case/15678/

It should be https://moztrap.mozilla.org/manage/case/15676/
Flags: in-moztrap+

Comment 12

3 years ago
Dear Candice,
Can you help to find someone help on this bug?
Thanks!
Flags: needinfo?(cserran)

Comment 13

3 years ago
Looks like it's fixed on latest nightly.
ni'ing Michael for update and assignment
Flags: needinfo?(cserran) → needinfo?(mhenretty)
Ok, looks like this was indeed a dupe of bug 1121748. Let's get this verified on master to make sure.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mhenretty)
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1121748

Comment 16

3 years ago
(In reply to Michael Henretty [:mhenretty] from comment #15)
> Ok, looks like this was indeed a dupe of bug 1121748. Let's get this
> verified on master to make sure.
> 

Yes, please. B2G2.2 was fixed with a backout patch. Mozilla-Central was fixed with new code. Please help verify that these bugs are also fixed in trunk.
Target Milestone: --- → 2.2 S5 (6feb)
(In reply to Alissa from comment #11)
> (In reply to Alissa from comment #10)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15680/

Comment 18

3 years ago
This bug  has been verified successfully on master.
Attachment:Verify_RTL_Notification.png

Flame master build:

Build ID               20150214160203
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.194226
Firmware Date          Sat Feb 14 19:42:36 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Keywords: verifyme

Comment 19

3 years ago
Created attachment 8564672 [details]
Verify_RTL_Notification.png
You need to log in before you can comment on or make changes to this bug.