If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RTL][Settings] List items disappear from the menu.

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: kaze)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8546075 [details]
TextOffScreen.png

Description:
When the device language is changed to an RTL language, some of the list items on the main settings menu disappear (possibly shifted off the screen to the right).

Repro Steps:
1) Update a Flame device to BuildID: 20150108010221.
2) Set the device language in Arabic under Settings > Language.
3) Return to the main menu on Settings, and scroll down the page.

Actual:
List items are randomly missing.
  
Expected: 
All list items appear properly.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150108010221
Gaia: d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko: 70de2960aa87
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Having this tested on base v188, it does not occur. Could you please test it on v188 in case you're using a newer one?
(Reporter)

Comment 2

3 years ago
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #1)
> Having this tested on base v188, it does not occur. Could you please test it
> on v188 in case you're using a newer one?

This issue also reproduces on v188. The menu is blank, and the text on the menu shows up later, ~20s.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150109010206
Gaia: 5f0dd37917c4a6d8fa8724715d4d3797419f9013
Gecko: b3f84cf78dc2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
(Reporter)

Comment 3

3 years ago
Sorry, I was looking at another area.

> This issue also reproduces on v188. The menu is blank, and the text on the
> menu shows up later, ~20s.

The menu remains blank, and the text does NOT show up after 20s.

Also, I reproduced this issue with Developer > ADB and DevTools enabled.
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
(Assignee)

Comment 4

3 years ago
Confirmed on my Keon. This is related to the font-ligature hack that is used to display item icons.

For instance, the “Homescreen” and “Themes” items are hidden in RTL mode, but when the `data-icon' attribute is removed or changed to `languages', the item appears again.

Vivien, can you please tell me who we should ping for that? This is a rather serious issue for RTL support, and I’d be glad to help fixing it if I had a couple pointers.
Flags: needinfo?(21)
Duplicate of this bug: 1120287
(Assignee)

Comment 6

3 years ago
Wilson, can you share some light?
Flags: needinfo?(21) → needinfo?(wilsonpage)
(Assignee)

Comment 7

3 years ago
Created attachment 8548523 [details] [review]
patch proposal

As we just discussed on IRC, here’s the workaround I had in mind: basically, I just force « direction:ltr » on the ::before pseudo-element that displays the ligature icon.

Surprisingly, it works fine — see the before/after screenshots below.

I have no idea why some ligature icons work fine, and some other don’t. In the screenshots below, the 'storage', 'keyboard' and 'themes' icons broke the whole item display in RTL mode (there are a few other other ligature icons like that in the Settings app main panel).
Assignee: nobody → fabien.cazenave
Status: NEW → ASSIGNED
Attachment #8548523 - Flags: review?(wilsonpage)
(Assignee)

Comment 8

3 years ago
Created attachment 8548524 [details]
main panel, before patch
(Assignee)

Comment 9

3 years ago
Created attachment 8548525 [details]
main panel, after patch
(Assignee)

Comment 10

3 years ago
Comment on attachment 8548523 [details] [review]
patch proposal

Removing the r? and ni? flags: the simplistic patch I proposed won’t be enough. Investigating.

Wilson, I’ll get back to you when I have a better clue of what’s going on. Sorry for the noise.
Attachment #8548523 - Flags: review?(wilsonpage)
kaze: If any patches are needed for gaia-icons, can you submit them to the gaia-icons repo [1].

[1] http://github.com/gaia-component/gaia-icons
Flags: needinfo?(wilsonpage)
(Assignee)

Updated

3 years ago
Depends on: 1121748
(Assignee)

Updated

3 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Comment 12

3 years ago
This seems to be caused by bug 1121748.

Whenever these elements are redrawn (e.g. by changing a CSS property in the WebIDE panel), they get displayed properly. This is not related to the Gaia-icons.
Created attachment 8551287 [details]
pictuer of firefox accounts page

This problem also is occurring in the firefox account tab of settings.
also just noticed that for the device information problem or it being way off set. If you had just had it set to a rtl already when it was booting it miss aligns but if you switch it back to a ltr and back to a rtl again a lot of the stuff is aligned properly again. Any ideas on why?
Priority: -- → P1
Blocking per RTL triage for 2.2
blocking-b2g: 2.2? → 2.2+
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2+ → ---
feature-b2g: --- → 2.2+

Updated

3 years ago
Duplicate of this bug: 1126612

Updated

3 years ago
Duplicate of this bug: 1126595

Updated

3 years ago
Duplicate of this bug: 1126606
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15558/
Flags: in-moztrap+

Comment 21

3 years ago
bug 1121748 is resolved fixed. Is this bug still valid?
Keywords: qawanted
(Reporter)

Comment 22

3 years ago
This issue is verified fixed on Flame 2.2 and Master.

Result: The list items appear properly on Settings.

Device: Flame 2.2 (319mb, full flash)
Build ID: 20150206002505
Gaia: a52999ce7f783177deb17e267bf003a53e6fde06
Gecko: 01446d5231ef
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37

Device: Flame Master (319mb, full flash)
Build ID: 20150206010204
Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko: 7c5f187b65bf
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
status-b2g-v2.2: affected → verified
status-b2g-master: --- → verified
Flags: needinfo?(ktucker)
Keywords: qawanted
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ktucker)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
You need to log in before you can comment on or make changes to this bug.