"Never remember history" disables clearing history, leaves lingering history

RESOLVED DUPLICATE of bug 463607

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 463607
3 years ago
3 years ago

People

(Reporter: mmcc, Unassigned)

Tracking

34 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20100101

Steps to reproduce:

I'm using Xubuntu 14.10 with the current Firefox release (34.0) from apt-get.

I decided to change my privacy setting to "Never remember history". As far as I could tell, this worked fine.


Actual results:

However, I realized that there was some residual history from before I made the change, which was bothersome in address bar suggestions. Upon trying to remove it, I found that the "Clear recent history..." item in the "History" dropdown menu was disabled.


Expected results:

This seems to be a regression, as no one else has mentioned it in bug reports to my knowledge.

The user should still be able to clear history if history exists, as "Never remember history" grandfathers in all the history that existed when it was set. Alternately, if history clearing is disabled, all existing history should be cleared when "Never remember history is set.

Granted, switching back to "Remember history", clearing everything, and switching back isn't that big of a deal. I just found it a little confusing and bothersome at first that I had history but couldn't clear it. Identifying the issue took a few minutes, as I had changed the privacy setting hours before. I can also imagine a less experience user being very perplexed and frustrated by this.
(Reporter)

Comment 1

3 years ago
Note that the user agent automatically listed in the bug report header is inaccurate.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Menus
Ever confirmed: true

Updated

3 years ago
Component: Menus → Bookmarks & History
This is a dupe of bug 802550, which was duped to bug 463607.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463607
You need to log in before you can comment on or make changes to this bug.