Closed Bug 1119726 Opened 6 years ago Closed 6 years ago

[Contacts][FFOS7715 v2.1]Contacts Settings screen, click Import Contacts interface displays misplaced

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected, b2g-master unaffected)

RESOLVED DUPLICATE of bug 1137203
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected
b2g-master --- unaffected

People

(Reporter: ffos_st, Assigned: BenWa)

References

Details

(Whiteboard: sprd392742)

Attachments

(2 files)

Description:
Contacts Settings screen, click Import Contacts interface displays misplaced

Device:
SPRD 7715ea

Build Identifier:
20150109174440

Steps to Reproduce:
1)Open the Contacts, click on the top right corner of the gear into the Setting screen, select Import Contacts observable phenomena
2)Repeat steps 1-2 several times

Actual Result: 
Click Import Contacts, the screen will display the dislocation half display interface, hollowed-out effect, after entering ImportContacts screen back to normal display

Expected Result:
Click Import Contacts, the interface does not show dislocation

Repro frequency:
10/10,100%
Whiteboard: sprd392742
Can you provide a video of the issue?
Flags: needinfo?(ffos_st)
Attached video VID_20120108_092222.mp4
Attached is my recorded video, please note the phenomenon when switching video page
Flags: needinfo?(ffos_st)
I was able to repro on: 
Gaia-Rev        64db236bea9a0510567ab7ced2f2b4688737123c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/273f24a1d1fe
Build-ID        20150111161203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141120.194707
FW-Date         Thu Nov 20 19:47:17 EST 2014
Bootloader      L1TC00011880

QA wanted for a branch check.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
QA Contact: bzumwalt
Issue DOES occur on Flame 2.1

Half the screen is distorted/missing when transitioning from Contacts Settings screen to Import Contacts screen after a few attempts.

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20150112001215
Gaia: 1975241ac29f723479e6c60b2bf74ebed54da91a
Gecko: 0863fe4b75c3
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Issue does NOT occur on Flame 2.0 and 2.2

Transition between Contacts Settings screen and Import Contacts screen occurs as expected after several attempts.

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20150112000204
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: a05a5378cb1f
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20150112010228
Gaia: f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko: bb8d6034f5f2
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Let's go ahead and get a reverse regression window for this issue.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Mozilla-Inbound Reverse Regression Window:

Half the screen is distorted/missing when transitioning from Contacts Settings screen to Import Contacts screen within a few attempts of running comment 0 STR.

Last Broken Mozilla-Inbound Build:
Device: Flame 2.2 Mozilla-Inbound
BuildID: 20141021185932
Gaia: 82174cee5ede9f23aedad8a39f8b8cdc1ae710c4
Gecko: e4679c01892b
Version: 36.0a1 (2.2 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


First Working Mozilla-Inbound Build:
Device: Flame 2.2 Mozilla-Inbound
BuildID: 20141021190835
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: 65149bbf96eb
Version: 36.0a1 (2.2 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Working Gaia Broken Gecko DOES reproduce:
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: e4679c01892b

Working Gecko Broken Gaia does NOT reproduce:
Gaia: 82174cee5ede9f23aedad8a39f8b8cdc1ae710c4
Gecko: 65149bbf96eb

Gecko Mozilla-Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e4679c01892b&tochange=65149bbf96eb
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This looks like it might have been caused by the uplift for bug 961871. Benoit, can you please take a look at this issue?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bgirard)
That wasn't an uplift, just a regular landing. I'll take a look at this tomorrow.
I can't reproduce this on master.

Is it possible to find the Gecko changeset that fixes the behavior while I look into this? It might be able to tell us what change we need to make to fix this.
Flags: needinfo?(bzumwalt)
This issue was fixed by the changes in 961871 for master.  Can this issue can be uplifted to 2.1 as well?
Flags: needinfo?(bzumwalt)
Blocks: 1123554
We can't uplift 961871. We should just disable the will-change on the contact app that is causing the problem.
Assignee: nobody → bgirard
Attachment #8547389 - Attachment is obsolete: true
Status: NEW → ASSIGNED
:JMercado can you  or :BroganZ are you able to reproduce the issue with this patch applied to the gaia repo?

It's less risky to disable this will-change usage then to uplift a big patch queue for it.
Flags: needinfo?(jmercado)
Setting this as a qawanted request for our next task.
Flags: needinfo?(jmercado)
Keywords: qawanted
Benoit,

We aren't really setup to do patches that aren't on github, but am I correct in seeing that if I wanted to make this change manually I just have to remove the 'will-change: transform;' lines from the two functions in that file?
Yes, you could make the change on the files themselves or from devtools if that's easier for you. I'm not sure if the files are easily accessible on the device (i.e. not in a hard to access bundle or minified).
Flags: needinfo?(bgirard)
Issue still occurs with modified contacts.css in Gaia repository


Half the screen is distorted/missing when transitioning from Contacts Settings screen to Import Contacts screen.

Device: Flame 2.1
BuildID: 20150120001202
Gaia: 77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko: f05d0a2d2378
Version: 34.0 (2.1)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Thanks for the help.

I can get the problem to go away by disabling low res painting. We have some patches on master that fix low res painting. Lets see which one we need to solve this issue.
Depends on: 1112332
blocking-b2g: --- → 2.1+
HI Beniot -

Since this is a blocking issue, just want to check with you if you are still working on this one
Flags: needinfo?(bgirard)
Yes I am, bug 1113435 might fix this.
Flags: needinfo?(bgirard)
I can't reproduce this on trunk. Can anyone reproduce this issue on trunk?
Keywords: qawanted
Issue does not occur in Flame 3.0, as expected since issue is unaffected in 2.2

Transition between Contacts Settings screen and Import Contacts screen occurs as expected after several attempts.

Device: Flame 3.0 Master
Build ID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(ktucker)
Keywords: qawanted
Flags: needinfo?(ktucker)
This needs to be retested on 2.1 using the branch patch for bug 1134762 and bug 1137203 since this might also have OMTA.
Attachment #8547389 - Attachment is obsolete: false
This looks like a dupe of bug 1137203; once that gets uplifted we can retest this on the branches.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137203
You need to log in before you can comment on or make changes to this bug.