"make mochitest-remote" busted on Android with adb > 1.0.29

RESOLVED FIXED in Firefox 39

Status

()

Firefox for Android
Testing
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: gbrown, Assigned: snorp)

Tracking

unspecified
Firefox 39
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I can run mochitests on an Android device with "make mochitest-remote" via sut, but not via adb. With adb, the browser is never launched. I don't see any activity in logcat. I don't see any errors reported on stdout.

I thought bug 1099475 (quoting url) might be an issue, but reverting that change did not seem to help.

Comment 1

4 years ago
I think this is probably a dupe of bug 1107906
(Reporter)

Comment 2

4 years ago
If I substitute "http://mochi.test:8888/tests/?a" for the uri, the browser is launched; if I substitute "http://mochi.test:8888/tests/?a&b", the browser is not launched.

Comment 3

4 years ago
Geoff, is that the case even with bug 1099475 reverted?
(Reporter)

Comment 4

4 years ago
(In reply to Bob Clary [:bc:] from comment #3)
> Geoff, is that the case even with bug 1099475 reverted?

Yes. I think the issue may be a change in adb itself. I upgraded my sdk recently.

http://code.google.com/p/android/issues/detail?id=76026

$ adb -version
Android Debug Bridge version 1.0.32
(Reporter)

Comment 5

4 years ago
"make mochitest-remote" works for me if I both downgrade my sdk and revert bug 1099475.

$ adb -version
Android Debug Bridge version 1.0.29

Either change on its own is ineffective.

Comment 6

4 years ago
My intentions are to move away from devicemanagerADB and move to adb.py. If you want to revert bug 1099475 and WONTFIX it, I'm ok with that.
(Reporter)

Comment 7

4 years ago
(In reply to Bob Clary [:bc:] from comment #6)
> My intentions are to move away from devicemanagerADB and move to adb.py. If
> you want to revert bug 1099475 and WONTFIX it, I'm ok with that.

OK, I think that's what I'll do then.
(Reporter)

Updated

4 years ago
Blocks: 1120727
(Reporter)

Updated

3 years ago
Summary: "make mochitest-remote" busted on Android with adb → "make mochitest-remote" busted on Android with adb > 1.0.29
Created attachment 8572210 [details] [diff] [review]
Work around 'adb shell' bustedness in newer Android tools

This seems to work for me, at least. Will push to Try when that's available again.
Attachment #8572210 - Flags: review?(gbrown)
(Reporter)

Comment 9

3 years ago
Comment on attachment 8572210 [details] [diff] [review]
Work around 'adb shell' bustedness in newer Android tools

Review of attachment 8572210 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

I tested {"make mochitest-remote" with TEST_PATH=intl/uconv} and {"make mochitest-robocop" with TEST_PATH=testLoad} with adb 1.0.29, 1.0.31, and 1.0.32 -- all worked fine.
Attachment #8572210 - Flags: review?(gbrown) → review+
(Reporter)

Updated

3 years ago
Assignee: gbrown → snorp
https://hg.mozilla.org/mozilla-central/rev/b9b9157e713c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
You need to log in before you can comment on or make changes to this bug.