form.dev-engagement-event: disabled accounts causes invalid/incomplete bugs to be created

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Custom Bug Entry Forms
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: openjck, Assigned: glob)

Tracking

Production
x86
Mac OS X

Details

(Reporter)

Description

3 years ago
In bug 1063818, form.dev-engagement-event was updated to add new features. The changes matched the requirements on the Bugzilla development server, but there are some discrepancies between the requirements document and what was launched on the Bugzilla production server.

1. The request bug doesn't link to the discussion bug
2. The discussion bug isn't using the default NEEDINFOs
3. The discussion bug doesn't block the request bug

I also made a mistake in the comments section of bug 1063818. I asked for the wrong question to be removed in comment 28. Can we please instead remove this question:

    Will this event include a session about developing
    with HTML, CSS, or JavaScript?

and restore this question:

    Who is the primary audience for this event?


Thanks so much!
(Reporter)

Comment 1

3 years ago
If it helps, I highlighted and numbered the related sections of the specification here:

https://docs.google.com/a/mozilla.com/document/d/1jTNreCelyYk2Bi31L18dUzikr3yGeBdTwrWAqnbOR6o/edit#
(Assignee)

Comment 2

3 years ago
(In reply to John Karahalis [:openjck] from comment #0)
> 1. The request bug doesn't link to the discussion bug
> 2. The discussion bug isn't using the default NEEDINFOs
> 3. The discussion bug doesn't block the request bug

i'm unable to reproduce any of these issues locally.
can you please provide a bug number which demonstrates this issue?
Flags: needinfo?(jkarahalis)
(Reporter)

Comment 3

3 years ago
(In reply to Byron Jones ‹:glob› from comment #2)
> i'm unable to reproduce any of these issues locally.
> can you please provide a bug number which demonstrates this issue?

Interesting. Very recent bugs (within the last week or so) look good, but older bugs have the issues described.

For example: Bug 1117309 (issue #1) and bug 1117310 (issues #2 and #3)

The new form was launched in mid-December. Strange.
Flags: needinfo?(jkarahalis)
(Assignee)

Comment 4

3 years ago
(In reply to John Karahalis [:openjck] from comment #3)
> Interesting. Very recent bugs (within the last week or so) look good, but
> older bugs have the issues described.
> 
> For example: Bug 1117309 (issue #1)

[Fri Jan 02 23:31:49 2015] [warn] Failed to create additional dev-engagement bug: You can't ask Angelina Fabbro (:angelina) <afabbro@mozilla.com> because that account is disabled.

this was fixed recently in bug 1119977.

> and bug 1117310 (issues #2 and #3)

that's probably a side-effect of the first issue -- if any of the needinfo's fail, then a batch of changes are rolled back.



we need to be more defensive and automatically skip disabled accounts when needinfo'ing.
Summary: form.dev-engagement-event: Changes and corrections to new features → form.dev-engagement-event: disabled accounts causes invalid/incomplete bugs to be created
(Assignee)

Comment 5

3 years ago
the fix for this was trivial..

To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   0ded1f3..81b2c31  master -> master
Assignee: nobody → glob
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
Looks great, thanks Bryon.

One more point from comment 0:

(In reply to John Karahalis [:openjck] from comment #0)
> I also made a mistake in the comments section of bug 1063818. I asked for
> the wrong question to be removed in comment 28. Can we please instead remove
> this question:
> 
>     Will this event include a session about developing
>     with HTML, CSS, or JavaScript?
> 
> and restore this question:
> 
>     Who is the primary audience for this event?

The second question was used in the past, so it should be in revision history.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to John Karahalis [:openjck] from comment #6)
> Looks great, thanks Bryon.
> 
> One more point from comment 0:
> 
> (In reply to John Karahalis [:openjck] from comment #0)
> > I also made a mistake in the comments section of bug 1063818. I asked for
> > the wrong question to be removed in comment 28. Can we please instead remove
> > this question:
> > 
> >     Will this event include a session about developing
> >     with HTML, CSS, or JavaScript?
> > 
> > and restore this question:
> > 
> >     Who is the primary audience for this event?
> 
> The second question was used in the past, so it should be in revision
> history.

Tracking this change (with others) in bug 1125320.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.