Closed Bug 1120421 Opened 8 years ago Closed 8 years ago

Bug 1100399 inverted the meaning of the label of the "always ask this" checkbox but forgot to update the logic

Categories

(Firefox :: General, defect)

defect
Not set
normal
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 38
Iteration:
38.1 - 26 Jan
Tracking Status
firefox35 --- unaffected
firefox36 --- unaffected
firefox37 --- verified
firefox38 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1100399 +++

Normally, I'd just back out, but this will merge to aurora today and because of the string changes, that's not feasible.

I guess it goes to show nobody reads prompts (including the people who change them or review them). :-(
Ugh. Sorry for missing that. :/
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #1)
> Ugh. Sorry for missing that. :/

Not your fault, I should have written a better patch. :-(
Points: 2 → 1
This matches the previous dialog's checkbox's behaviour (checked by default, uncheck to stop the prompts
Attachment #8547610 - Flags: review?(mconley)
Comment on attachment 8547610 [details] [diff] [review]
checkbox value should match checkbox text,

Review of attachment 8547610 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch, Gijs.
Comment on attachment 8547610 [details] [diff] [review]
checkbox value should match checkbox text,

Review of attachment 8547610 [details] [diff] [review]:
-----------------------------------------------------------------

Er, that should have been an r+.
Attachment #8547610 - Flags: review?(mconley) → review+
Flags: qe-verify?
Flags: firefox-backlog+
Flags: qe-verify? → qe-verify+
Iteration: 37.3 - 12 Jan → 38.1 - 26 Jan
https://hg.mozilla.org/mozilla-central/rev/005a7c3f0fac
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
QA Contact: camelia.badau
Duplicate of this bug: 1121418
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using latest Nightly 38.0a1, buildID: 20150115030228 (builds: en-US, pl).
Status: RESOLVED → VERIFIED
Comment on attachment 8547610 [details] [diff] [review]
checkbox value should match checkbox text,

Approval Request Comment
[Feature/regressing bug #]: bug 1086958
[User impact if declined]: Impacts default browser dialog on startup with the checkbox value and label not matching up
[Describe test coverage new/current, TBPL]: nope
[Risks and why]: low
[String/UUID change made/needed]: no
Attachment #8547610 - Flags: approval-mozilla-aurora?
Comment on attachment 8547610 [details] [diff] [review]
checkbox value should match checkbox text,

Aurora+

Bug 1086958 landed in 34. Should we consider this fix for Beta 36 as well?
Flags: needinfo?(gijskruitbosch+bugs)
Attachment #8547610 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #11)
> Comment on attachment 8547610 [details] [diff] [review]
> checkbox value should match checkbox text,
> 
> Aurora+
> 
> Bug 1086958 landed in 34. Should we consider this fix for Beta 36 as well?

Sorry, I copy/pasted the wrong regressing bug. This should have been bug 1100399, which only landed in 37.
Flags: needinfo?(gijskruitbosch+bugs)
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using latest Aurora 37.0a2, buildID: 20150121004011 (builds: en-US, pl).
You need to log in before you can comment on or make changes to this bug.