[Windows Management][Homescreen][ Returning to the homescreen from an app in landscape mode causes the bottom row of homescreen icons to be slightly cut-off on the bottom

VERIFIED FIXED in 2.2 S4 (23jan)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: etienne)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-Daily-Testing] [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8547823 [details]
logcat_20150112_1509.txt

Description:
When you are in an app in landscape mode and press the homescreen button you will be taken to the homescreen (in portrait) but the bottom row of icons are slightly cut-off. This is not permanent and there are a few ways to 'fix' it such as long pressing home to go to the task manager and then pressing home again to return to the homescreen. This occurs in 3 and 4 column homescreen.

Repro Steps: 
1) Update a Flame to 20150112010228
2) Launch an app that can be viewed in landscape mode (Video, Browser)
3) Turn device to view app in landscape mode
4) Tap homescreen button to return to homescreen
5) Scroll down to the bottom

Actual:
Bottom row of icons is cut-off

Expected:
Homescreen will maintain it's normal appearance and spacing. Icons and names will be easily readable.

Environmental Variables:
Device: Flame Master
Build ID: 20150112010228
Gaia: f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko: bb8d6034f5f2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (Master)
Firmware Version: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 4/4
See attached: logcat, screenshot

--------------------------------------------------------------------

This issue also repros on 2.2 (V188-1), 

Device: Flame Master (KK - nightly - full flash)
Build ID: 20150112010228
Gaia: f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko: bb8d6034f5f2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

---------------------------------------------------------------------------
This issue does NOT repro on 2.1 and 2.0

Device: Flame 2.1 (KK - nightly - full flash)
Build ID: 20150112001215
Gaia: 1975241ac29f723479e6c60b2bf74ebed54da91a
Gecko: 0863fe4b75c3
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware Version: V18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (KK - nightly - full flash)
Build ID: 20150112000204
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: a05a5378cb1f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 32.0 (2.0)
Firmware Version: V18D
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Comment 1

4 years ago
Created attachment 8547825 [details]
HomescreenBottom.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
regression of core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20150106010241
Gaia: f2c5dcef558f747e525220f1dfb2da6b07325235
Gecko: 080bf51ff425
Version: 37.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20150106023745
Gaia: 9f400639489276a01eda2f7c1536b2429e98a247
Gecko: c6251e0f5230
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 37.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working Gaia First Broken Gecko: Issue NOT reproduce 
Gaia: f2c5dcef558f747e525220f1dfb2da6b07325235
Gecko: c6251e0f5230

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 9f400639489276a01eda2f7c1536b2429e98a247
Gecko: 080bf51ff425

https://github.com/mozilla-b2g/gaia/compare/f2c5dcef558f747e525220f1dfb2da6b07325235...9f400639489276a01eda2f7c1536b2429e98a247

caused by bug 1114800
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Etienne, could you please take a look at this issue? Looks like the landing for bug 1114800 may have caused this to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(etienne)

Updated

4 years ago
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing] [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Created attachment 8551840 [details] [review]
[PullReq] etiennesegonzac:bug-1120704 to mozilla-b2g:master
(Assignee)

Comment 6

4 years ago
Comment on attachment 8551840 [details] [review]
[PullReq] etiennesegonzac:bug-1120704 to mozilla-b2g:master

Glad we found that bug :)

Here's the deal, since the homescreen doesn't have an overlay we were never removing the homescreen's iframe inlined size.

*But* the real issue was that this size was incorrect (didn't take the statusbar into account). So I started by fixing this.
*But* I realized that if the sizing was incorrect we must have been reflowing stuff all along (since the inlined size was different from the original size).

Did some more investigation and turns out there's no way to prevent the reflow (since inlining the size will trigger one anyway), so yay code removal!
Attachment #8551840 - Flags: review?(alive)
incorrect ux, definitely a blocker
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8551840 [details] [review]
[PullReq] etiennesegonzac:bug-1120704 to mozilla-b2g:master

I like the *but*s!

FWIW after all these bugs I realized for 'orientationchange' we have no way but to change everyone's layout no matter it is background or foreground otherwise something bad may happen during transition or after the transition.
Attachment #8551840 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request v2.2 approval on this when you get a chance.
status-b2g-master: --- → fixed
Flags: needinfo?(etienne)
Target Milestone: --- → 2.2 S4 (23jan)
(Assignee)

Comment 11

4 years ago
Comment on attachment 8551840 [details] [review]
[PullReq] etiennesegonzac:bug-1120704 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): the original edge gesture support (old)

[User impact] if declined: in some cases the bottom 20px of an app can be outside of the viewport, inaccessible to the user.

[Testing completed]: the STR from the bug + general orientation change scenarios

[Risk to taking this patch] (and alternatives if risky): low (no new code)

[String changes made]: none
Flags: needinfo?(etienne)
Attachment #8551840 - Flags: approval-gaia-v2.2?
Attachment #8551840 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been verified as fixed on Flame 3.0

After viewing a video or web page in landscape mode and returning home, the user can scroll to the bottom of the homescreen without issue. No icons appear to be cut off.

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
status-b2g-master: fixed → verified
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.