All users were logged out of Bugzilla on October 13th, 2018

[Flame][Settings]Fail to set "Passcode Lock".

RESOLVED DUPLICATE of bug 1121891

Status

--
major
RESOLVED DUPLICATE of bug 1121891
4 years ago
4 years ago

People

(Reporter: wangxin, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

Attachments

(4 attachments, 2 obsolete attachments)

4.09 MB, video/mp4
Details
132.29 KB, text/plain
Details
181.19 KB, text/plain
Details
2.55 MB, video/mp4
Details
(Reporter)

Description

4 years ago
Created attachment 8547945 [details]
Bug log: 2025.MP4

[1.Description]:
[Flame][v2.2][Settings]The passcode can't be set successfully in "Settings"->"Screen Lock"->"Passcode Lock" page.
Found Time:20:25
See video:"2025.MP4"
See log:"logcat_2025.txt"

[2.Testing Steps]: 
1. Launch "Settings".
2. Tap  "Screen Lock" item.
3. Enable "Passcode Lock".
4. Input passcode.
5. Tap "Create" in top-right position.

[3.Expected Result]: 
5. The passcode should be set successfully.

[4.Actual Result]: 
5. The "Create" word will be gray, and the passcode can not be set successfully.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.194842
FW-Date         Mon Jan 12 19:48:52 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8547946 [details]
Bug log: logcat_2025.txt

Comment 2

4 years ago
Created attachment 8547966 [details]
logcat_0937.txt

Hi Eric,
I have found in many apps, when the keyboard is invoked, some button can't be used. Such like: Change the Bluetooth name of device, the OK and Cancel button is unuseful when keyboard is invoked.
Could you help with it? Thanks!
STR:
1. Launch Settings app -> Bluetooth.
2. Enable Bluetooth.
3. Tap "Rename my device".
4. Invoke keyboard and input some words.
5. Tap OK/Cancel button.
**OK and Cancel button have no use.
6. Long press at space key to hide the keyboard.
7. Tap OK/Cancel button.
**Tap OK will change the name and back to Bluetooth page, tap Cancel will back to Bluetooth page.
Found time:09:37
See attachment:logcat_0937.txt and video.MP4

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.194842
FW-Date         Mon Jan 12 19:48:52 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(echang)

Comment 3

4 years ago
Created attachment 8547969 [details]
video.MP4

Comment 4

4 years ago
Created attachment 8547981 [details]
logcat_2029.txt

Comment 5

4 years ago
Hi Eric,
I have found another question about keyboard.The card view will display as being elongated with invoking keyboard(Email,Message,Contacts).
Could you help with it? Thanks!

STR:
1. Launch Contacts.
2. Tap "+" to create a new contact.
3. Tap in text field.
**The keyboard pops up.
4. Long tap Home key to switch to card view.
**The Contacts displays as being elongated.

Attachments:logcat_2029.txt,Cardview_Elongated.MP4
Foundtime:20:29

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2

Comment 6

4 years ago
Created attachment 8547982 [details]
Cardview_Elongated.MP4

Comment 7

4 years ago
(In reply to Coler from comment #5)
> Hi Eric,
> I have found another question about keyboard.The card view will display as
> being elongated with invoking keyboard(Email,Message,Contacts).
> Could you help with it? Thanks!
> 
> STR:
> 1. Launch Contacts.
> 2. Tap "+" to create a new contact.
> 3. Tap in text field.
> **The keyboard pops up.
> 4. Long tap Home key to switch to card view.
> **The Contacts displays as being elongated.
> 
> Attachments:logcat_2029.txt,Cardview_Elongated.MP4
> Foundtime:20:29
> 
> Flame 2.2 build:
> Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
> Gecko-Rev      
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
> Build-ID        20150112153951
> Version         37.0a2

Please ignore this comment.Thanks.

Updated

4 years ago
Attachment #8547982 - Attachment is obsolete: true

Updated

4 years ago
Attachment #8547981 - Attachment is obsolete: true
Actually I cannot reproduce cases from c0 and c2, is there any step needs to be performed before we can reproduce this? Do they happening right after flashing or reset? 
https://bugzilla.mozilla.org/show_bug.cgi?id=1120792#c0
https://bugzilla.mozilla.org/show_bug.cgi?id=1120792#c2

But I saw something weird from c5
https://bugzilla.mozilla.org/show_bug.cgi?id=1120792#c5

And please create another bug for different issue or attach to a case that is with the same symptom or root cause, that will makes the process more efficient.
Flags: needinfo?(echang)

Comment 9

4 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #8)
> Actually I cannot reproduce cases from c0 and c2, is there any step needs to
> be performed before we can reproduce this? Do they happening right after
> flashing or reset? 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1120792#c0
> https://bugzilla.mozilla.org/show_bug.cgi?id=1120792#c2
> 

Hi Eric, there is no any step needs to be performed before we can reproduce this, after flashing the build of "20150112153951" and "20150113162504", this issue can be reproduced. The key is keyboard is invoked.

> But I saw something weird from c5
> https://bugzilla.mozilla.org/show_bug.cgi?id=1120792#c5
> 
> And please create another bug for different issue or attach to a case that
> is with the same symptom or root cause, that will makes the process more
> efficient.

I had created a bug of comment 5, see Bug 1118679
Flags: needinfo?(echang)
See Also: → bug 1121891
To make the bug infor more clear, file another bug for tracking.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121891
Flags: needinfo?(echang)
You need to log in before you can comment on or make changes to this bug.