Closed Bug 1121143 Opened 5 years ago Closed 5 years ago

onFolderRemovedFromQ "canceled" undefined (wrong scope)

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(thunderbird37 fixed)

RESOLVED FIXED
Thunderbird 38.0
Tracking Status
thunderbird37 --- fixed

People

(Reporter: mkmelin, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file)

I started getting "autosyncActivities	ERROR	onFolderRemovedFromQ: ReferenceError: canceled is not defined" in the console.

From bug 1119911. the "let" makes it the wrong scope...
Attachment #8548410 - Flags: review?(kent)
Comment on attachment 8548410 [details] [diff] [review]
bugXXX_autosync_canceled_undefined.patch

Review of attachment 8548410 [details] [diff] [review]:
-----------------------------------------------------------------

Right, my bad. Looks good.
Attachment #8548410 - Flags: review?(kent) → review+
I noticed this error today after upgrading to Thunderbird 37.0a2 (20150114004002), i.e. the error exists on comm-aurora too.
We really need someone to take the role of release manager for the aurora (and beta) channels. It would be really easy to land this bug in aurora, but nobody is really paying attention to that.
https://hg.mozilla.org/comm-central/rev/700399c45071 -> FIXED
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
Comment on attachment 8548410 [details] [diff] [review]
bugXXX_autosync_canceled_undefined.patch

[Approval Request Comment]
Regression caused by (bug #): bug 1119911
User impact if declined: "Error: autosyncActivities ERROR onFolderRemovedFromQ: ReferenceError: canceled is not defined" is reported often in console. Don't know what is the effect on Thunderbird behavior or data.
Testing completed (on c-c, etc.): patch landed on c-c week ago
Risk to taking this patch (and alternatives if risky): risk seems low looking at the patch
Attachment #8548410 - Flags: approval-comm-aurora?
Comment on attachment 8548410 [details] [diff] [review]
bugXXX_autosync_canceled_undefined.patch

[Triage Comment] Might as well take this in beta 37
Attachment #8548410 - Flags: approval-comm-aurora? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.