Firefox crash in PR_DestroyCondVar | mozilla::CondVar::~CondVar()

RESOLVED FIXED

Status

()

Core
Graphics: Layers
--
critical
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: marcia, Assigned: nical)

Tracking

({crash, reproducible})

unspecified
All
Windows 7
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox37 unaffected, firefox38- affected)

Details

(Whiteboard: [gfx-noted], crash signature, URL)

This bug was filed from the Socorro interface and is 
report bp-1e23e2ef-352c-48af-9a2b-63c8f2150114.
=============================================================

Seen while running Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150114030202 CSet: 63006936ab99

STR:
1. Open the page in the URL bar
2. Scroll down the page and click on the second video on the page

Crash occurs after a pop up is launched.

Frame 	Module 	Signature 	Source
0 	nss3.dll 	PR_DestroyCondVar 	nsprpub/pr/src/threads/combined/prucv.c
1 	xul.dll 	mozilla::CondVar::~CondVar() 	xpcom/glue/CondVar.h
2 	xul.dll 	mozilla::Monitor::~Monitor() 	xpcom/glue/Monitor.h
3 	xul.dll 	mozilla::layers::CompositorParent::~CompositorParent() 	gfx/layers/ipc/CompositorParent.cpp
4 	xul.dll 	mozilla::layers::CompositorParent::`scalar deleting destructor'(unsigned int) 	
5 	xul.dll 	mozilla::layers::DeleteOnMainThreadTask<mozilla::layers::CompositorParent>::Run() 	gfx/layers/ipc/ThreadSafeRefcountingWithMainThreadDestruction.h
6 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
7 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
8 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
9 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
10 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
11 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
12 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
13 	xul.dll 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp
14 	xul.dll 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
15 	xul.dll 	XREMain::XRE_main(int, char** const, nsXREAppData const*) 	toolkit/xre/nsAppRunner.cpp
16 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp
17 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp
18 	firefox.exe 	NS_internal_main(int, char**) 	browser/app/nsBrowserApp.cpp
19 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
20 	firefox.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c:255
21 	kernel32.dll 	BaseThreadInitThunk 	
22 	ntdll.dll 	RtlUserThreadStart 	
23 	kernel32.dll 	BasepReportFault 	
24 	kernel32.dll 	BasepReportFault
This seems similar to bug 1115144 except cset 63006936ab99 which this was seen on includes the backout that RyanVM landed.
See Also: → bug 1115144
However as this has STR nical or Bas should probably look into it. CC'ing them.
Whiteboard: [gfx-noted]
Assignee: nobody → nical.bugzilla

Updated

3 years ago
Duplicate of this bug: 1123551
(Copied from the duplicate)

The CondVar's |mCvar| is null. Kinda spiked on 20150109030224 but really spiked on 20150114030202. Almost all Win7. 

[Tracking Requested - why for this release]: Nightly topcrash, many of them near startup
status-firefox37: --- → unaffected
status-firefox38: --- → affected
tracking-firefox38: --- → ?
tracking-firefox38: ? → +
(Assignee)

Comment 5

3 years ago
I can't reproduce with the STR in comment 0 on my win 8 laptop, but I notice that this page throws a swarm of popup ads at the user. Wondering if there could be an extension that kills them asap like adblock or something alike, and the rapid creation-then-destruction of the widget would help make this crash more frequent. There are two extensions in the bug report but I don't know where to match the extension id with a human-readable name.
(Assignee)

Comment 6

3 years ago
Tried with adblock but it doesn't repro either.
> I can't reproduce with the STR in comment 0 on my win 8 laptop

You'll probably need a Win7 machine to repro this.
I think that the site changed since the date that I filed the bug - the other day when I tried to reproduce it on the same machine and I was not able to.

There is actually only one extension installed on my profile - Nightly Tester Tools.
This appears to be dropping fast on nightly crash volume (-82%) and without reproducibility anymore I'm not currently worried enough to track this.
tracking-firefox38: + → -

Updated

3 years ago
Crash Signature: [@ PR_DestroyCondVar | mozilla::CondVar::~CondVar()] → [@ PR_DestroyCondVar | mozilla::CondVar::~CondVar()] [@ PR_DestroyCondVar | mozilla::CondVar::~CondVar]
(Assignee)

Comment 10

2 years ago
Lots of shutdown work landed lately and no recent report of this crash from a quick look at crash-starts. Closing.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.