crash in PR_DestroyCondVar | mozilla::CondVar::~CondVar()

RESOLVED DUPLICATE of bug 1121751

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 1121751
4 years ago
4 years ago

People

(Reporter: dmajor, Unassigned)

Tracking

({crash})

unspecified
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(firefox37 unaffected, firefox38-)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-dfa20b3b-a0cf-4563-949f-cad992150113.
=============================================================

The CondVar's |mCvar| is null. Not entirely clear how we got here from ~CompositorParent -- does it have a CondVar member?

PR_DestroyCondVar
mozilla::CondVar::~CondVar()
mozilla::layers::CompositorParent::~CompositorParent()
mozilla::layers::CompositorParent::`scalar deleting destructor'(unsigned int)
mozilla::layers::DeleteOnMainThreadTask<mozilla::layers::CompositorParent>::Run()

Kinda spiked on 20150109030224 but really spiked on 20150114030202. Almost all Win7. Not sure who should own this, Kats can you route to someone?
Flags: needinfo?(bugmail.mozilla)
(Reporter)

Comment 1

4 years ago
[Tracking Requested - why for this release]: Nightly topcrash, many of them near startup
status-firefox37: --- → unaffected
status-firefox38: --- → affected
tracking-firefox38: --- → ?
(In reply to David Major [:dmajor] (UTC+13) from comment #0)
> The CondVar's |mCvar| is null. Not entirely clear how we got here from
> ~CompositorParent -- does it have a CondVar member?

It has Monitor members [1], and Monitor has a CondVar member [2]. The stack probably comes from an optimized build where the Monitor destructor was inlined.

[1] http://mxr.mozilla.org/mozilla-central/source/gfx/layers/ipc/CompositorParent.h?rev=5680121a4909#383
[2] http://mxr.mozilla.org/mozilla-central/source/xpcom/glue/Monitor.h?rev=ea62f34c430d#62
Looks like a dupe of bug 1121751, which is assigned to :nical.
Flags: needinfo?(bugmail.mozilla)
(Reporter)

Comment 4

4 years ago
Agreed - sorry. I wonder why it didn't get linked to the crash signature.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121751

Updated

4 years ago
status-firefox38: affected → ---
tracking-firefox38: ? → -
You need to log in before you can comment on or make changes to this bug.