[Flame][First Time Experience]After importing some contacts from facebook in FTE, the prompt message "xx friends imported (out of xx)" cannot be shown under the facebook item.

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: sfoster)

Tracking

({late-l10n, regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(7 attachments)

Posted file logcat.txt
[1.Description]:
[Flame][v2.2][First Time Experience]Import some contacts from facebook in FTE, the prompt message "xx friends imported (out of xx)" cannot be shown under the facebook item.
Attach video:Video.mp4.
Attach logcat:logcat.txt.
Attach screenshot:Issue_Flame2.2.png & Correct_Flame2.1.png.
Occurrence time:00:53

[2.Testing Steps]: 
1.Launch FTE via Flash Rom or from Developer.
2.Connect network and enter "Import contacts" page.
3.Import some contatcs from facebook.

[3.Expected Result]: 
3.The prompt message of "xx friends imported (out of xx)" should be shown under the facebook item.

[4.Actual Result]: 
3.After import Facebook account. the prompt message of "xx friends imported (out of xx)" cannot be shown under the facebook item.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6600eba54256
Build-ID        20150114001300
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.035135
FW-Date         Wed Jan 14 03:51:46 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150114002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.040029
FW-Date         Wed Jan 14 04:00:40 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,3/3

[7.TCID]: 
Free Test
Posted image Correct_Flame2.1.png
Posted image Issue_Flame2.2.png
Posted video Video.MP4
Would someone in Contacts be able to look at this Francisco?
Flags: needinfo?(francisco)
Jose is this issue familiar to you?

We recently reworked the strings number of friends imported and could be related.
Flags: needinfo?(francisco) → needinfo?(jmcf)
there is no such a bug. The message which appears is 'updated xx friends'.

Closing
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jmcf)
Resolution: --- → FIXED
Moving to worksforme. From the video, the message is visible but the placement is arguably off.
Resolution: FIXED → WORKSFORME
Hi Sam,
This bug still exists on the latest Flame 2.2. And I think this is a problem about very bad user experience. So please help to check whether I should reopen it or open a new issue.

Flame 2.2 build:
Build ID               20150226162510
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1be266320634
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.195624
Firmware Date          Thu Feb 26 19:56:35 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(sfoster)
Yeah lets re-open. Something is definitely missing or wrong there. We do get a confirmation toast when the import finishes, but import from gmail shows a summary of contacts imported - I assume Facebook should do the same and that's what the space is there for.
Status: RESOLVED → REOPENED
Flags: needinfo?(sfoster)
Resolution: WORKSFORME → ---
Do we want to block on this based on attachment #8570329 [details]
blocking-b2g: --- → 2.2?
Duplicate of this bug: 1138844
QA Contact: bzumwalt
Last working B2G-Inbound build:
Device: Flame 2.2
Build ID: 20141128054740
Gaia: 7d3f9852e84f7da61245e97bd01519c66086873a
Gecko: 75e84fed4b99
Version: 36.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken B2G-Inbound build: 
Device: Flame 2.2
Build ID: 20141128080522
Gaia: d3c3e86db4563cfc5c1e4b0409f52a23471030b9
Gecko: 1ffafc7c6ab5
Version: 36.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Working Gaia with Broken Gecko issue does NOT reproduce:
Gaia: 7d3f9852e84f7da61245e97bd01519c66086873a
Gecko: 1ffafc7c6ab5

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: d3c3e86db4563cfc5c1e4b0409f52a23471030b9
Gecko: 75e84fed4b99


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/7d3f9852e84f7da61245e97bd01519c66086873a...d3c3e86db4563cfc5c1e4b0409f52a23471030b9


Issue appears to occur due to changes made in bug 1078174
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Pavel, can you take a look at this please? This might have been caused by the work done on bug 1078174.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(pivanov)
Hey Jose,
I can't reproduce this one ... can you take a look at this?
Flags: needinfo?(pivanov) → needinfo?(jmcf)
as per comment #6 this bug should be closed
Flags: needinfo?(jmcf)
as per comment #6 this bug should be closed
This bug still occurs on todays Flame 3.0 nightly

While the black banner reading 'updated xx friends' appears at bottom of screen as expected, the text 'xx/xx friends imported" is missing from the space directly under the string "Facebook" where the 'Import from Facebook' button was placed before importing. This causes an odd empty space that vertically offsets the 'Facebook' string. I hope this clears up what issue is actually occurring.

If not, please see: https://bugzilla.mozilla.org/attachment.cgi?id=8572760 which shows a comparison between 2.1, 2.2, and 3.0. Note that 2.1 is unaffected and the expected string is placed beneath the 'Facebook' string.

Device: Flame 3.0
Build ID: 20150306010207
Gaia: 7a91c16bfa348be8b25e09719178efa051512988
Gecko: 0189941a3fd5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
(In reply to Jose Manuel Cantera from comment #15)
> as per comment #6 this bug should be closed

I am not sure what you mean here, its clear the the bug is reproducible. Ar you having a hard time reproduce it. 

Pavel, given this is a regression from 1078174 we need to address this.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(pivanov)
Whiteboard: [systemsfe]
 I'll take a look into this
Assignee: nobody → sfoster
Thanks Sam :)
Flags: needinfo?(pivanov)
With some logging in ftu/js/import_services.js I see: 

"L10nError: "facebook-import-msg" not found in en-US in app://ftu.gaiamobile.org/index.html" "
    at reportMissingEntity (app://ftu.gaiamobile.org/shared/js/l10n.js:1570:8)"

Looks like the data is getting returned ok, but this string is missing. The only instance of it I can find is in the apps/communications properties files, looking like this: 

{
    "facebook-import-msg": {
        "_": "{[ plural(imported) ]}",
        "_[few]": "{{imported}}/{{total}} friends imported",
        "_[many]": "{{imported}}/{{total}} friends imported",
        "_[one]": "One friend imported (out of {{total}})",
        "_[other]": "{{imported}}/{{total}} friends imported",
        "_[two]": "{{imported}}/{{total}} friends imported",
        "_[zero]": "No friends imported (out of {{total}})"
    }
}

UX-wise, that's what we want, question is can we add this string at this stage? Will do a build to confirm this fixes the issue in the meantime.
Flags: needinfo?(gandalf)
Yup looks good, will create a PR
Comment on attachment 8576886 [details] [review]
[gaia] sfoster:ftu-fb-import-strings-bug-1121880 > mozilla-b2g:master

Turns out the bug was a missing string. This exists already for the contacts app, but we also need it in the FTU.
Flags: needinfo?(gandalf)
Attachment #8576886 - Flags: review?(stas)
Keywords: late-l10n
Comment on attachment 8576886 [details] [review]
[gaia] sfoster:ftu-fb-import-strings-bug-1121880 > mozilla-b2g:master

r=me with a comment in the pull request.  BTW landing new strings on master doesn't require reviews from the l10n team, but thanks for looping me in.  We're always happy to help!
Attachment #8576886 - Flags: review?(stas) → review+
(In reply to Staś Małolepszy :stas from comment #25)
> r=me with a comment in the pull request.  BTW landing new strings on master
> doesn't require reviews from the l10n team, but thanks for looping me in. 
> We're always happy to help!

Oh good catch with that stray }. I figured you would be a good reviewer in this case :)
Will land once that latest rebase/push shows up green.
Keywords: checkin-needed
Merged to master: https://github.com/mozilla-b2g/gaia/commit/a1e2f2bdcafc814afdcba0c2258ca69f65b2a869
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Please request Gaia v2.2 on this when you get a chance.
Flags: needinfo?(sfoster)
Target Milestone: --- → 2.2 S8 (20mar)
Comment on attachment 8576886 [details] [review]
[gaia] sfoster:ftu-fb-import-strings-bug-1121880 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Missing strings in FTU
[User impact] if declined: No summary of number of Facebook contacts imported visible, but a space is left for it
[Testing completed]: Tested on device, Gaia-Try green
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: New strings (copied from Contacts) for FTU
Flags: needinfo?(sfoster)
Attachment #8576886 - Flags: approval-gaia-v2.2?
Attachment #8576886 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Issue verified fixed on Flame 3.0

Importing contacts from Facebook in FTE, shows both banner at bottom of screen and status message beneath "Facebook" text on page show number of imported contacts. No unexpected empty spaces or missing elements on screen.

Leaving verifyme keyword awaiting 2.2 uplift.

Device: Flame 3.0
Build ID: 20150317073344
Gaia: 738987bd80b0ddb4ccf853855388c2627e19dcc1
Gecko: 008b3f65a7e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This issue verified successfully on Flame 2.2
Flame 2.2:
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate 0/5
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.