[Nexus 5][Flame v2.2 & v3.0][First Time Experience]The facebook button will change after you import facebook contacts completely.

RESOLVED DUPLICATE of bug 1121880

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1121880
3 years ago
3 years ago

People

(Reporter: Lance(leave from Mozilla), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8571854 [details]
logcat_1339.txt

[1.Description]:
[Nexus 5 v2.2][Flame v2.2 & v3.0][First Time Experience]The facebook button will change after you import facebook contacts completely.
Found time:13:39
See attachment:facebook.png and logcat_1339.txt

[2.Testing Steps]: 
1.Flash device to latest build.
2.When you come to contacts screen, tap "Facebook".
3.Log in an account, then import some contacts.
4.Back to contacts screen.

[3.Expected Result]: 
4.The button should not change.

[4.Actual Result]: 
4.The facebook button will change.

[5.Reproduction build]: 
Nexus-5 version:
Build ID               20150302162504
Gaia Revision          062d395273e70b8688a91b5a2b34c0cc7afc679f
Gaia Date              2015-03-02 22:12:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5a7cb3b9f78e
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150302.194900
Firmware Date          Mon Mar  2 19:49:17 EST 2015
Bootloader             HHZ12d

Flame 2.2 version:
Build ID               20150302002504
Gaia Revision          77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gaia Date              2015-02-27 16:35:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/27ab8aa34201
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.042723
Firmware Date          Mon Mar  2 04:27:34 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150302010223
Gaia Revision          f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gaia Date              2015-02-27 15:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.043726
Firmware Date          Mon Mar  2 04:37:37 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8571855 [details]
facebook.png
(Reporter)

Updated

3 years ago
Summary: [Nexus][Flame][First Time Experience]The facebook button will change after you import facebook contacts completely. → [Nexus 5]][Flame v2.2 & v3.0][First Time Experience]The facebook button will change after you import facebook contacts completely.
(Reporter)

Updated

3 years ago
Summary: [Nexus 5]][Flame v2.2 & v3.0][First Time Experience]The facebook button will change after you import facebook contacts completely. → [Nexus 5][Flame v2.2 & v3.0][First Time Experience]The facebook button will change after you import facebook contacts completely.
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
I believe this page was made by the comms team.
Component: Gaia::First Time Experience → Gaia::Contacts
Flags: needinfo?(felash)
Yep, this is for the Contacts team.

Francisco, is it a potential blocker ?
Flags: needinfo?(felash) → needinfo?(francisco)
This looks like a regression to me. QA wanted to check 2.1 and, if 2.1 is impacted, 2.0.
Keywords: qawanted
QA Contact: bzumwalt
Created attachment 8572760 [details]
fbIcon_Compare.png

Unable to reproduce issue on Flame 2.1, 2.2, and 3.0

The icon size and type remains the same both before and after importing Facebook contacts in FTU. The only difference being that the import button for Facebook is gone after initial import in FTU.

Attached screenshot comparison across these three versions.

I did notice that I didn't get contact imported number below icon in 2.2 and 3.0.

Device: Flame 2.1
Build ID: 20150304002212
Gaia: 7370d456a330882aa6c29cd5a6470b876038a622
Gecko: 81bbb1143b88
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2
Build ID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
Build ID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Flags: needinfo?(ktucker)
As per xchat discussion with Johan, the issue here is not the icon size, but the missing "#/# friends imported" text in 2.2 and 3.0 that is causing text to be apparently misplaced.

Using the same environmental variables in comment 5:

Flame 2.1 is unaffected as text position appears logical due to visible imported friends count below "Facebook" text

Flame 2.2 and 3.0 are affected as imported friends count is not visible after importing Facebook contacts, but space for that string is still allocated below "Facebook" text
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
Keywords: qawanted → regression
Nominating this 2.2? since this is a regression. The user should see how many contacts that they imported.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121880
blocking-b2g: 2.2? → ---
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
Whiteboard: [2.2-nexus-5-l]
Flags: needinfo?(francisco)
You need to log in before you can comment on or make changes to this bug.