[Windows Management][Notification][OTA] - Calendar event notifications received prior to OTA do not take the user to the relevant area when selected from the notification menu after OTA.

RESOLVED DUPLICATE of bug 1120857

Status

RESOLVED DUPLICATE of bug 1120857
4 years ago
4 years ago

People

(Reporter: jmitchell, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8549925 [details]
logcat_20150115_1332.txt

Description:
Some types of notifications become broken through the OTA process. After a successful OTA any (prior to OTA) screenshot saved notification do not take users to that screenshot. Calendar Event notifications do not take the user to the Calendar app. Clicking on these events also do not clear them from the notification menu. Manually going to these areas also do not clear them from the notifications menu. You CAN swipe the event from the notification menu to remove it or use the 'clear all' function. 

Repro Steps:
1) Update a Flame to not the latest build
2) Take a screenshot
3) Set a calendar event to give a notification "very soon"
4) Once the Notification menu has been propagated with these notifications, perform OTA
5) After OTA is compete select those notifications from the notification menu

Actual:
Notifications do not take user to appropriate areas relevant to notification, notification menu simply closes and notification remains in menu. 

Expected:
Notifications will continue to function as they would prior to OTA

Environmental Variables:  (OTA'd from build 20150114001300)
Device: Flame Master
Build ID: 20150115010229
Gaia: bcc76f93f5659ac1eb8a769167109fd2d7ca4fbd
Gecko: c1f6345f2803
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (Master)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 4/4
See attached: logcat (logcat is of me pressing on the notifications in the notification menu after OTA)

------------------------------------------------------------------------------------
This issue repros' on 2.2 (v18d-1) and 2.2 (v18d)

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150109010206
Gaia: 5f0dd37917c4a6d8fa8724715d4d3797419f9013
Gecko: b3f84cf78dc2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (Master)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
 - OTA -
Device: Flame Master
Build ID: 20150115010229
Gaia: bcc76f93f5659ac1eb8a769167109fd2d7ca4fbd
Gecko: c1f6345f2803
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (Master)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150112010228
Gaia: f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko: bb8d6034f5f2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (Master)
Firmware Version: V18d
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
 - OTA -
Device: Flame Master
Build ID: 20150115010229
Gaia: bcc76f93f5659ac1eb8a769167109fd2d7ca4fbd
Gecko: c1f6345f2803
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (Master)
Firmware Version: V18d
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

This issue partially repro's in 2.1, and 2.0 - The Calender app notification is not present after OTA but the screenshot notifications behave the same. 

Device: Flame 2.1 (KK - Nightly - Full-Flashed)
Build ID: 20150113001255
Gaia: 836e6d74cb8b7016df555f85445893b3ff9aac12
Gecko: 074f79a929d2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
 - OTA -
TO Device: Flame 2.1 (KK - Nightly - OTA'd)
Build ID: 20150115001207
Gaia: 8d4846d7bec777046dc5e3d2b8005adb1370f1f7
Gecko: 8eb9bc3a945a
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (KK - Nightly - Full-Flashed)
Build ID: 20150113000203
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: c6fd5db59e0e
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 32.0 (2.0)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
 - OTA -
Device: Flame 2.0 (KK - Nightly - OTA'd)
Build ID: 20150115000203
Gaia: 736933b25ded904f0cb935a0d48f1f3cf91d33ad
Gecko: 8ff0d933175c
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 32.0 (2.0)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component QA owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
I also found that not all notifications received will have this issue. Usage and voicemail works normally.
Need developer's help to investigate more about this.
Flags: needinfo?(gchang) → needinfo?(alive)
Notification stuff, transfer ni.
Flags: needinfo?(alive) → needinfo?(mhenretty)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
cc'ing Alex, and leaving ni? for now. I'll take a look next week.
That's just because we have no proper system message notification, at least for the screenshot.
Depends on: 1103560
(In reply to Alexandre LISSY :gerard-majax from comment #5)
> That's just because we have no proper system message notification, at least
> for the screenshot.

This comment applies to system message notifications in the system app. We still need to figure out why the system message isn't working for calendar.
You are mixing two different apps notification: it's a known issue for System app-related notifications, hence the dupe. I'm a bit surprised for the Calendar one.

Please make sure that it is indeed broken, because dogfooding matching master builds on my Nexus S, I had no issue with Calendar app. If you still reproduce the issue with Calendar, then file a new bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jmitchell)
Resolution: --- → DUPLICATE
Duplicate of bug: 1084247
Clearing my ni? Looks like Alex couldn't reproduce the calendar OTA notification issue. Joshua please re-open or file a new bug if you come up with STR for the calendar notification.
Flags: needinfo?(mhenretty)
(Reporter)

Comment 9

4 years ago
Hi Michael - 

Alex stated that he could not repro on Nexus S but makes no mention of attempting a repro on Flame (which was what was bugged here). The repro steps still apply and the bug is still present today. If a calendar (offline calendar was used) notification was received prior to OTA it will have no reaction when tapped on after OTA. 
I'll update the Bug Title to ignore the Screenshot notification aspect which he indicates is already covered somewhere else. 


Device: Flame 3.0 (KK - OTA)
Build ID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → REOPENED
Flags: needinfo?(jmitchell) → needinfo?(mhenretty)
Resolution: DUPLICATE → ---
Summary: [Windows Management][Notification][OTA] - Calendar event and Screenshot saved notifications received prior to OTA do not take the user to the relevant area when selected from the notification menu after OTA. → [Windows Management][Notification][OTA] - Calendar event notifications received prior to OTA do not take the user to the relevant area when selected from the notification menu after OTA.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1084247
Resolution: DUPLICATE → WORKSFORME
Resolution: WORKSFORME → INVALID
Created attachment 8561535 [details]
Logcat when tapping a resent Calendar notification

Joshua, tapping a calendar resent notification does properly trigger the Calendar app. Errors are popping inside the app itself. Please file a bug against the proper component.
Flags: needinfo?(jmitchell)
The problems with Calendar notifications not working during reboot are being tracked here now: bug 1120857.
Flags: needinfo?(mhenretty)
Flags: needinfo?(jmitchell)
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1120857
You need to log in before you can comment on or make changes to this bug.