[Calendar] On lockscreen, tap the "Open" button beside event, it enter Homescreen instead of event‘s detail view.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: mmedeiros)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

Reporter

Description

5 years ago
Posted file logcat
[1.Description]:
[Flame][v2.2][Lock Screen]Create a future event and set a reminder time, reboot device and the event displays on lock screen. Tap "Open" button beside the event, it can't enter event‘s detail view, it enters Homescreen.
See attachment: logcat_1600.txt & Video1.mp4
Found time: 16:00

[2.Testing Steps]: 
1. Launch Calendar.
2. Create a future event and set a reminder time.
3. Reboot device.
4. Tap the created event on lock screen.
5. Tap "Open" button.

[3.Expected Result]: 
5. It could enter event‘s detail view.

[4.Actual Result]: 
5. It enters Homescreen instead of event‘s detail view.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.194842
FW-Date         Mon Jan 12 19:48:52 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free test
Reporter

Comment 1

5 years ago
Posted video Video
Base functionality is broken
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Gaia::Calendar]
Flags: needinfo?(yue.xia)
remove ni
Flags: needinfo?(yue.xia)
Whiteboard: [systemsfe]
Is this a regression?
Keywords: qawanted
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → ktucker
Assignee: ktucker → nobody
QA Contact: ktucker
This issue does not occur on the Flame 2.1 

When the user taps "open" on the calendar event, the user is taken to the event details.

Environmental Variables:
Device: Flame 2.1 (Full Flash)(319mb)(Kitkat)
Build ID: 20150127001307
Gaia: d98bbe9d2bfdb53e80dc1ab1572bd05938a85526
Gecko: c255879afaf5
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Adding regressionwindow-wanted.
This issue does not occur on the Flame 3.0

The user is taken to the event details page when tapping open on the notification.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150127010228
Gaia: b02ec9713e6de8d96c6954d2c0dfd0442b0656ac
Gecko: 38e4719e71af
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

I'm going to get a reverse regression window here.
This appears to be a bug caused by bug 1061797. When I reproduced the issue, and this is demonstrated in reporter's video as well, that the lockscreen time is incorrect after reboot, and as user unlocks phone by tapping on the notification, the time corrects itself. This 'time change' messes up with the transition of the notification.

I'm removing branch checking results and window wanted tag because the underlying problem is Flame showing incorrect time after reboot.
QA Whiteboard: [COM=Gaia::Calendar] → [COM=Gaia::Calendar][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ktucker → pcheng
QA Whiteboard: [COM=Gaia::Calendar][QAnalyst-Triage?] → [COM=Gaia::Calendar][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee: nobody → mhenretty
I believe this is a calendar issue. When I click the notification after the reboot, I see the system message firing and launching the calendar app in the background. However, when I load calendar into webIDE, I don't see the 'js/message_handler.js' file being included. This file is what sets the notification system message handler, which presumably brings the app to the foreground and closes the notification. Perhaps it's a loading issue?

Note: I also see this happening reliably on master.
Assignee: mhenretty → nobody
Component: Gaia::Homescreen → Gaia::Calendar
Whiteboard: [systemsfe]
?ni gaye since he did most of the notification work on calendar
Flags: needinfo?(gaye)
Duplicate of this bug: 1122282
I saw errors in logcat on optimized files. Could it be a Gaia build issue?
Assignee: nobody → mmedeiros
the bug is caused because "notification.js" tries to call `exports.router.go()` and `exports.router` is `null` (race condition)

I believe the best solution is to remove the router methods from the "app.js" and convert the router into a singleton, that way we avoid the weird race condition and move towards our goal of killing the "app" namespace (Bug 1096518)

I'll submit a patch soon - already have it working locally.
Blocks: 1096518
while investigating this I found another bug related to notifications - Bug 1132336: notifications fired while app is closed aren't "cleared" after tapping. - I'm working on it as well.
Blocks: 1042939, 1132336
Summary: [Flame][Lock Screen]On lockscreen, tap the "Open" button beside event, it enter Homescreen instead of event‘s detail view. → [Calendar] On lockscreen, tap the "Open" button beside event, it enter Homescreen instead of event‘s detail view.
Comment on attachment 8562843 [details] [review]
[gaia] millermedeiros:1120857-lockscreen-notification > mozilla-b2g:master

r=me thanks miller!
Flags: needinfo?(gaye)
Attachment #8562843 - Flags: review+
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/28150

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Blocks: 1129411
Duplicate of this bug: 1129411
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8562843 [details] [review]
[gaia] millermedeiros:1120857-lockscreen-notification > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1042939
[User impact] if declined: tapping a notification won't open the event details inside the calendar app, which is a regression and bad UX
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: none
Attachment #8562843 - Flags: approval-gaia-v2.2?
Attachment #8562843 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 21

4 years ago
Posted video verify_video.MP4
This issue has been verified successfully on Flame 2.2/3.0
STR:
[2.Testing Steps]: 
1. Launch Calendar.
2. Create a future event and set a reminder time.
3. Reboot device.
4. Tap the created event on lock screen.
5. Tap "Open" button.
**It will enter event's detail view after about 2~3 sec.
See attachment:verify_video.MP4
Rate:0/5

Flame 2.2 build:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150225010244
Gaia Revision          f6bfd854fe4746f21bc006eac145365e85f98808
Gaia Date              2015-02-24 21:10:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a8b3b67715a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.043702
Firmware Date          Wed Feb 25 04:37:14 EST 2015
Bootloader             L1TC00011880

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::Calendar][QAnalyst-Triage+] → [COM=Gaia::Calendar][QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.