Remove [Pure] for MozNFCTag.id

RESOLVED FIXED in Firefox 38, Firefox OS v2.2

Status

Firefox OS
NFC
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: allstars, Unassigned)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

Pure is not required for MozNFCTag.id

See https://bugzilla.mozilla.org/show_bug.cgi?id=1115465#c11
(Assignee)

Updated

4 years ago
Depends on: 1115465
Created attachment 8550040 [details] [diff] [review]
Patch.
Attachment #8550040 - Flags: review?(bugs)
https://hg.mozilla.org/mozilla-central/rev/0640a60fdba5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8550040 [details] [diff] [review]
Patch.



[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1115465

User impact if declined: 
Wrong usage of WebIDL bindings, could possibly affect JS Engine performance.
And given that we discovered this problem quite early, I'd like to uplift this to avoid future problems.

Testing completed: 
Manually.

Risk to taking this patch (and alternatives if risky): 
No.

String or UUID changes made by this patch:
No.
Attachment #8550040 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8550040 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54e1067836db
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
status-firefox36: --- → wontfix
status-firefox37: --- → wontfix
status-firefox38: --- → fixed
Target Milestone: --- → 2.2 S4 (23jan)
You need to log in before you can comment on or make changes to this bug.