Closed Bug 1122438 Opened 5 years ago Closed 5 years ago

[Flame][Contacts]The animation of facebook contacts list displays in a mess for a short while.

Categories

(Core :: Graphics: Layers, defect)

37 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 1113435
mozilla37
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- unaffected

People

(Reporter: lixia, Unassigned)

References

Details

(Keywords: regression)

Attachments

(9 files)

[1.Description]:
[Flame][v2.2][Contacts]The animation of facebook contacts list displays in a mess for a short while after you open a contact and tap Link contacts.
Attch:logcat_1216.txt and linkcontact.MP4.
Test file:addison_frances.vcf.
Found time:12:16

[2.Testing Steps]: 
1.Launch Contacts.
2.Enable Facebook Sync friends and import Facebook contacts.
3.Tap on the contact with phone numbers and email.
4.Tap on Link contact.


[3.Expected Result]: 
4.The animation of facebook contacts list should not display in a mess for a short while.

[4.Actual Result]: 
4.The animation of facebook contacts list displays in a mess for a short while.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ce27f2692382
Build-ID        20150115002505
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150115.035734
FW-Date         Thu Jan 15 03:57:45 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,5/8

[7.TCID]: 
Free Test

[8.Note]:
Not all of contacts can link to facebook friends to repro this bug.
Attached file logcat_1216.txt
Attached video linkcontact.mp4
A regression bug.
This is likely a Gecko bug.

Let's do a branch check to help to locate the regression before.
QA Contact: bzumwalt
Tested with locally created contact as well as attachment 8550204 [details]

Issue DOES reproduce on Flame 2.2 and 3.0

Animation issues appear when trying to link Facebook contact to local contact. Important to note that only local contacts with pictures experience this issue.

Device:  2.2
BuildID: 20150116002502
Gaia: 2f916cdba7305b51a72482b6bfe860c5b8924f9c
Gecko: b4c7c83a44a5
Version: 37.0a2 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device:  3.0
BuildID: 20150116010205
Gaia: 401e981f51cf047292d101c785be8ec48bf75e8c
Gecko: cac6192956ab
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Issue does NOT reproduce on Flame 2.1 

No animation issues appear when attempting to link Facebook contact to local contact.

Device: Flame 2.1
BuildID: 20150116001340
Gaia: 230a9c5303e2113f7dbcaf431441ae2138853141
Gecko: e43e97795f5d
Version: 34.0 (2.1)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]: Regression caught in 2.2 which can affect a large part of our Facebook users.
blocking-b2g: --- → 2.2?
I cannot reproduce it today with Gecko-3e13a1e Gaia-e0cc056
triage: blocking

Hi Peter, Milan,
Looks like a graphic relevant bug. could you take a look?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(pchang)
I think it maybe related to the following commit which is related to APZ.

https://hg.mozilla.org/mozilla-central/rev/380b784bf8ec
Shelly, can you verify the 3.0 before above commit?
Flags: needinfo?(pchang) → needinfo?(lixia)
(In reply to Jose Manuel Cantera from comment #8)
> I cannot reproduce it today with Gecko-3e13a1e Gaia-e0cc056

Me neither with the same environmental variables:

Device: Flame 3.0
Gecko: 3e13a1e
Gaia: e0cc056
Platform: 38.0a1
BuildId: 20150119064600
By Comment 11,clear NI.
Flags: needinfo?(lixia)
Issue still reproduces on todays Flame 3.0

Following steps in comment 0, it is important to note my comments in comment 6 that "only local contacts with pictures experience this issue." If the contact does not have a picture associated I have found the bug not to occur. This local contact was created before Facebook importing step.

Device: Flame 3.0 Master
BuildID: 20150120010227
Gaia: a5c5ac093814a80b0627514c3bd5f9e96c096a4b
Gecko: c1c6840d9255
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to Brogan Zumwalt [:BroganZ] from comment #13)
> Issue still reproduces on todays Flame 3.0
> 
> Following steps in comment 0, it is important to note my comments in comment
> 6 that "only local contacts with pictures experience this issue." If the
> contact does not have a picture associated I have found the bug not to
> occur. This local contact was created before Facebook importing step.
> 
> Device: Flame 3.0 Master
> BuildID: 20150120010227
> Gaia: a5c5ac093814a80b0627514c3bd5f9e96c096a4b
> Gecko: c1c6840d9255
> Version: 38.0a1 (3.0 Master)
> Firmware: V18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Hi,

I've tried with today's (1/21) master build and taking into account your comments above (local contact with picture attached and local contact already created before importing FB contacts) and I'm not able to reproduce it so it must be something else (maybe we make some step in a different way or there is a difference in the environments). Please see below the STRs followed by me:
*Open Contacts app
*Create a local contact with Name, Last Name, Number and image
*Go to Contacts->Settings->Sync friends and import all the friends (19 in my case)
*Go to local contact-> Link Contact (no matches found so all the FB contacts are shown)


Environmental variables:
Flame v3.0 device
Gecko: dc6b716
Gaia: 1c91c05
BuildId:20150121064527
Platform version: 38.0a1
Attached image Contact Photo
Issue still occurs for me on today's Master following the exact repo steps listed above. Animation issue occurs on transition to Facebook contact list immediately after pressing "Link Contact" button in local contact details

Name: First
Last Name: Last
Phone: 1234567891
Picture: Attached

Imported all 16 Facebook contacts

Device: Flame 3.0 Master
BuildID: 20150121010204
Gaia: 5e98dc164b17fd6decb48a9eaddef0e55b82e249
Gecko: 540077a30866
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I can't reproduce on today's master build after following the steps in comment 11 and 12.

William, do you have luck to reproduce this issue?
Flags: needinfo?(whsu)
(In reply to peter chang[:pchang][:peter] from comment #16)
> I can't reproduce on today's master build after following the steps in
> comment 11 and 12.
> 
> William, do you have luck to reproduce this issue?

Hi, Peter,

Thanks for your information.
As I tested, I can reproduce this bug on 20150115002505 (v2.2) but I also cannot reproduce this bug on latest v3.0.
I would like to request reporter to reconfirm this bug.

--- -- - --- -- - --- -- - --- -- - --- -- -
Hi, Shally,

May I have your help again?
Please reconfirm this bug on latest v3.0 and v2.2 to see if you still can reproduce it.
If you cannot reproduce it, please mark this bug as "WORKFORME"
Many thanks. :)
Flags: needinfo?(whsu) → needinfo?(lixia)
(In reply to William Hsu [:whsu] from comment #17)
> Hi, Shally,
> 
> May I have your help again?
> Please reconfirm this bug on latest v3.0 and v2.2 to see if you still can
> reproduce it.

Hi William,

    I can repro this bug on today's Flame v2.2. And I have no Flame v3.0,so I can't verify it on Flame v3.0.
    Please see attachments: new_logcat_1434.txt and new_video_v2.2.MP4
    Reproduce rate: 5/5.

Repro STR:
1.Launch Contacts.
2.Enable Facebook Sync friends and import Facebook contacts.
3.Tap on a contact with picture(Important) to view.
4.Tap on "Link contact".
**The animation of facebook contacts list displays in a mess for a short while. --KO

Flame 2.2 build: 
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/75a462a58d7a
Build-ID        20150121002607
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150121.040751
FW-Date         Wed Jan 21 04:08:02 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(lixia) → needinfo?(whsu)
Attached video new_video_v2.2.mp4
(In reply to Shally from comment #18)
> (In reply to William Hsu [:whsu] from comment #17)
> > Hi, Shally,
> > 
> > May I have your help again?
> > Please reconfirm this bug on latest v3.0 and v2.2 to see if you still can
> > reproduce it.
> 
> Hi William,
> 
>     I can repro this bug on today's Flame v2.2. And I have no Flame v3.0,so
> I can't verify it on Flame v3.0.
>     Please see attachments: new_logcat_1434.txt and new_video_v2.2.MP4
>     Reproduce rate: 5/5.
> 

Good Job! :)

Oh! My bad.
I forgot to inform you.
You can pull Mozilla-central to do the test because it will be the v3.0 build.
Can you give it a try?
Thanks.
Flags: needinfo?(whsu) → needinfo?(lixia)
Hi William,
 
I can't repro this bug on latest Flame v3.0.

Flame v3.0 build:
Gaia-Rev        917b6c36717fddc6e71ffc1ec249633c8044c93c
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/34e2d2bd7ec4
Build-ID        20150121160202
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150121.192948
FW-Date         Wed Jan 21 19:29:59 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(lixia) → needinfo?(whsu)
(In reply to Shally from comment #22)
> Hi William,
>  
> I can't repro this bug on latest Flame v3.0.
> 
> Flame v3.0 build:
> Gaia-Rev        917b6c36717fddc6e71ffc1ec249633c8044c93c
> Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/34e2d2bd7ec4
> Build-ID        20150121160202
> Version         38.0a1
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  eng.cltbld.20150121.192948
> FW-Date         Wed Jan 21 19:29:59 EST 2015
> Bootloader      L1TC000118D0

Thanks Shally,
A v2.2 regression.
Bad user experience. Nominate it.
Flags: needinfo?(whsu)
(In reply to William Hsu [:whsu] from comment #23)
> (In reply to Shally from comment #22)
> > Hi William,
> >  
> > I can't repro this bug on latest Flame v3.0.
> > 
> > Flame v3.0 build:
> > Gaia-Rev        917b6c36717fddc6e71ffc1ec249633c8044c93c
> > Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/34e2d2bd7ec4
> > Build-ID        20150121160202
> > Version         38.0a1
> > Device-Name     flame
> > FW-Release      4.4.2
> > FW-Incremental  eng.cltbld.20150121.192948
> > FW-Date         Wed Jan 21 19:29:59 EST 2015
> > Bootloader      L1TC000118D0
> 
> Thanks Shally,
> A v2.2 regression.
> Bad user experience. Nominate it.

My bad. It has been nominated.
Sorry for any inconvenience.
Johan, looks to me this bug is related to graphics, isnt?
Flags: needinfo?(jlorenzo)
That was my guess in comment 5. Requesting a regression window to make sure of it. If it is, please move this bug to Core => Panning and Zooming.
Flags: needinfo?(jlorenzo)
Gecko Regression Window:

Last working Mozilla-Inbound build:
Device: Flame 2.2
BuildID: 20141020171137
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: 223e2f4b0d47
Version: 36.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken Mozilla-Inbound build:
Device:  2.2
BuildID: 20141020172632
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: fa9c6845338e
Version: 36.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: fa9c6845338e

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: 223e2f4b0d47

Mozilla-Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=223e2f4b0d47&tochange=fa9c6845338e

Issue appears to occur due to bug 1085223
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Matt, can you take a look at this please? This might have been caused by the work done on bug 1085223.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(matt.woodrow)
This is likely to be the same as bug 1113435, which BenWa is looking at.
Flags: needinfo?(matt.woodrow)
Verifyme once bug 1113435 lands. If it doesn't fix the issue, please reopen this current bug.
Status: NEW → RESOLVED
Closed: 5 years ago
Component: Gaia::Contacts → Graphics: Layers
Keywords: verifyme
Product: Firefox OS → Core
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla37
Version: unspecified → 37 Branch
Duplicate of bug: 1113435
Attached video Verify_video.mp4
The problem is verified not happen on latest Flame 2.2 build.

Steps:
Repro STR:
1.Launch Contacts.
2.Enable Facebook Sync friends and import Facebook contacts.
3.Tap on a contact with picture(Important) to view.
4.Tap on "Link contact".
Actual Result
The animation of facebook contacts list display normally.
 
Fail rate:0/5
See attachment:Verify_video.MP4
Flame 2.2 version:
Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f7414413e3a5
Build-ID        20150201002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.043120
FW-Date         Sun Feb  1 04:31:31 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: regression, verifyme
Keywords: regression
You need to log in before you can comment on or make changes to this bug.