Show keyboard shortcuts from the toolbox

RESOLVED DUPLICATE of bug 892188

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 892188
4 years ago
a year ago

People

(Reporter: bgrins, Assigned: jdescottes)

Tracking

(Depends on 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-backlog][difficulty=medium])

Reporter

Description

4 years ago
It'd be nice if we had a way to show common keyboard shortcuts from the toolbox.  A couple of ideas:

1) Have a link that opens up https://developer.mozilla.org/en-US/docs/Tools/Keyboard_shortcuts
2) Open up a dialog when the user presses "?".  You can see an example of this on github.com.

The benefit of 2 is that we know what platform they are on, so they wouldn't have to see a table including platforms irrelevant to them.  Also, there may be some flexibility to show context-specific shortcuts more prevalently (if you are on the inspector tab, maybe those could show up near the top).

If we went with something like 2, it'd be nice to somehow share the list of shortcuts between the MDN documentation and this dialog so we didn't have to maintain two separate lists.  Not sure how that would best work, especially as new shortcuts are added to the toolbox.
Depends on: 821359
Whiteboard: [devedition-40]
Assigning P1 priority for some devedition-40 bugs. 

Filter on '148DD49E-D162-440B-AE28-E22632FC20AC'
Priority: -- → P1
Whiteboard: [devedition-40] → [devedition-40][difficulty=medium]
Assignee: nobody → jryans
Status: NEW → ASSIGNED
I won't focus on this for the current week, unassigning for now.  Free feel to grab if you wish.
Assignee: jryans → nobody
Status: ASSIGNED → NEW
Assignee: nobody → jryans
Whiteboard: [devedition-40][difficulty=medium] → [polish-backlog][difficulty=medium]
Assignee: jryans → nobody
Assignee

Updated

3 years ago
Assignee: nobody → jdescottes
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 892188

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.