JavaScript Error: "invalid value for aNodeOrItemId" from PlacesUIUtils.jsm

RESOLVED FIXED in seamonkey2.35

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

({regression})

Trunk
seamonkey2.35
regression

SeaMonkey Tracking Flags

(seamonkey2.32 unaffected, seamonkey2.33+ fixed, seamonkey2.34+ fixed, seamonkey2.35+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Regression from Bug 1084203[1]
Bug 1084203 ported Bug 1068671[2] but not the regression fix from Bug 1095069[3]

[1] Fix totally empty bookmark manager.
[2] folderReadOnly doesn't pertain to bookmarks or results
[3] Cannot copy or delete bookmarks from search results in library
(Assignee)

Comment 1

3 years ago
Created attachment 8550475 [details] [diff] [review]
Patch v1.0 copy and paste Bug 1095069

While testing your patch from Bug 1121678 I got a lot of error console spew:

> Sat Jan 17 2015 01:08:59
> Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "invalid value for aNodeOrItemId" {file: "resource://gre/modules/PlacesUIUtils.jsm" line: 835}]'[JavaScript Error: "invalid value for aNodeOrItemId" {file: "resource://gre/modules/PlacesUIUtils.jsm" line: 835}]' when calling method: [nsIController::isCommandEnabled]
> Source file: chrome://communicator/content/places/controller.js
> Line: 1554
>  ----------
> Sat Jan 17 2015 01:08:59
> Error: Error: invalid value for aNodeOrItemId
> Source file: resource://gre/modules/PlacesUIUtils.jsm
> Line: 835
>  ----------
> Sat Jan 17 2015 01:08:59
> Error: An error occurred updating the cmd_delete command: [Exception... "[JavaScript Error: "invalid value for aNodeOrItemId" {file: "resource://gre/modules/PlacesUIUtils.jsm" line: 835}]'[JavaScript Error: "invalid value for aNodeOrItemId" {file: "resource://gre/modules/PlacesUIUtils.jsm" line: 835}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 78"  data: yes]
> Source file: chrome://global/content/globalOverlay.js
> Line: 83
>  ----------
> Sat Jan 17 2015 01:08:59
> Error: An error occurred updating the cmd_cut command: [Exception... "[JavaScript Error: "invalid value for aNodeOrItemId" {file: "resource://gre/modules/PlacesUIUtils.jsm" line: 835}]'[JavaScript Error: "invalid value for aNodeOrItemId" {file: "resource://gre/modules/PlacesUIUtils.jsm" line: 835}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 78"  data: yes]
> Source file: chrome://global/content/globalOverlay.js
> Line: 83
Attachment #8550475 - Flags: review?(neil)

Updated

3 years ago
Attachment #8550475 - Flags: review?(neil) → review+
(Assignee)

Comment 2

3 years ago
Comment on attachment 8550475 [details] [diff] [review]
Patch v1.0 copy and paste Bug 1095069

[Approval Request Comment]
Regression caused by (bug #): Bug 1084203
User impact if declined: Users cannot copy or delete bookmarks from search results in library
Testing completed (on m-c, etc.): Firefox equivalent Bug 1095069 landed on Firefox 36 (so we need to land this on 2.33 and 2.34) 
Risk to taking this patch (and alternatives if risky): none bustage fix.
String changes made by this patch: None,
Attachment #8550475 - Flags: approval-comm-beta?
Attachment #8550475 - Flags: approval-comm-aurora?
(Assignee)

Comment 3

3 years ago
http://hg.mozilla.org/comm-central/rev/d86c8591cd92

Comment 4

3 years ago
Comment on attachment 8550475 [details] [diff] [review]
Patch v1.0 copy and paste Bug 1095069

a=me
Attachment #8550475 - Flags: approval-comm-beta?
Attachment #8550475 - Flags: approval-comm-beta+
Attachment #8550475 - Flags: approval-comm-aurora?
Attachment #8550475 - Flags: approval-comm-aurora+
(Assignee)

Comment 5

3 years ago
Pushed to branches:
http://hg.mozilla.org/releases/comm-aurora/rev/ce25f6b1662d
http://hg.mozilla.org/releases/comm-beta/rev/0ae204c89a72
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-seamonkey2.32: --- → affected
status-seamonkey2.33: --- → fixed
status-seamonkey2.34: --- → fixed
status-seamonkey2.35: --- → fixed
tracking-seamonkey2.33: --- → +
tracking-seamonkey2.34: --- → +
tracking-seamonkey2.35: --- → +
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.35
(Assignee)

Updated

3 years ago
status-seamonkey2.32: affected → unaffected
You need to log in before you can comment on or make changes to this bug.