Can't drag or move Firefox window when a third-party theme is installed

VERIFIED FIXED in Firefox 35

Status

()

defect
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: glenn1441, Assigned: mstange)

Tracking

35 Branch
mozilla38
x86
macOS
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox35 verified, firefox36+ verified, firefox37+ verified, firefox38+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

Full quit on Firefox browser. Relaunched Finder, fully rebooted laptop, verified OS X operating system, and repaired permissions -- all to no avail.


Actual results:

Updated Firefox for OS X to 35.0. Installation successful. When attempting to drag browser window across Desktop, it was immediately clear I was no longer able to do so as in the past. All other files, as well as Chrome and Safari browsers can be dragged across desktop.


Expected results:

Firefox 35.0 should drag using three finger motion as it always has. My OS X operating system is working fine.
(Reporter)

Updated

4 years ago
Severity: normal → major
Component: Untriaged → General
Priority: -- → P1
(Assignee)

Comment 1

4 years ago
This is probably a regression from bug 944836. But I don't understand what's happening.
Blocks: 944836
Status: UNCONFIRMED → NEW
Component: General → Widget: Cocoa
Ever confirmed: true
Priority: P1 → --
Product: Firefox → Core
(Reporter)

Comment 2

4 years ago
I'm not a technician, but I do know that immediately after updating Firefox for OS X, the Firefox browser/window could no longer be repositioned on the desktop by dragging -- or by any other means. OS X Yosemite 10.10.1 is running flawlessly otherwise, as are other browsers, apps and files.
(Assignee)

Comment 3

4 years ago
Sorry, by "what's happening" I meant "what's happening behind the scenes in the Firefox internals that's responsible for the bug".

Can you attach a screenshot of your Firefox window? Have you tried creating a new Firefox profile to see whether the bug could be triggered by a Firefox addon you have installed?

Comment 4

4 years ago
Same here on late 2013 Imac,Firefox 35.0, Mac OSX 10.10.1,about:config change makes no difference.

"So when you click-and-hold on the titlebar and move the mouse, the browser window doesn't move?"

Yes, that is exactly what is going on.

moved from wrong post as per Markus Strange request.

Have changed nothing, add ons and such, from 34.0, all worked normal in 34, after 35.0 update, can no longer move firefox (MAIN) browser window, all pop up windows (i.e. preffs) move as normal. Even creating a NEW Window does not help, new window stuck also.

Need anymore info just let me know.
(Reporter)

Comment 5

4 years ago
Haven't added new add-ons or plugins... checked extensions. All normal. A screenshot would not be helpful as the window does not move at all. I was able to center the window to fit my monitor in the manner I prefer, but that's it. Perhaps browser theme, latest version of Walnut 2.30.0 is responsible, but then, that update occurred early winter of 2014 and no problem since this, Firefox's latest update.

Comment 6

4 years ago
Just started in Safe mode, and I can move the window like normal. So I am thinking it must be an Add on issue. All worked fine before 35 update, but I seem to remember a few add ons have updated since.

Comment 7

4 years ago
Ok manually disabled all Extensions and plug ins and still could not move the window.

Turned all back on and just disabled the Noia Fox 3.0.9 appearance add on and can move the window again.

Glenn, try just disabling your Walnut 2.30.0.

Looks like a theme issue maybe.
(Reporter)

Comment 8

4 years ago
Yup -- that's the issue... E-mailed the Walnut developer, but seems more than one theme creates this issue... Shame -- I've been using Walnut for years and as we all know, changes in browser appearance can be disorienting at first. But, I'd rather have the ability to drag my window along my Desktop... Perhaps developers of affected themes can identify and fix the problem. Thanks to all.
(Assignee)

Comment 9

4 years ago
Ohh, right, themes! How could I forget about that... sorry.

Dão, I suspect I should move most of the theme-specific CSS rules to xul.css?

Comment 10

4 years ago
I tried a bunch of different themes, and they all locked the window so far, so I do not think it is the themes' themselves. But for sure that is the cause. seems only the "Default" lets the window move as normal.
(Reporter)

Comment 11

4 years ago
Well, wherever or however the problem originated, the FF 35.0 OS X update and browser themes are not jiving, and as a result, the browser window can not be dragged or moved along the desktop as is normally the case. Curious as to whether or not Windows users are affected. Themes are a popular Firefox feature, regardless of user and OS, and I hope this issue is on the table for resolution.
(Assignee)

Comment 12

4 years ago
Just a heads up: Over in bug 1104036 we're preparing to back out the change that caused this bug on the release branch. If something urgent comes up that would require a dot release (e.g. 35.1), this bug would then be fixed in that release.
(Assignee)

Updated

4 years ago
Summary: Firefox for OS X 35.0 Can't drag or move Firefox window on desktop. → Can't drag or move Firefox window when a third-party theme is installed
(Assignee)

Comment 13

4 years ago
Posted patch patchSplinter Review
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #8552750 - Flags: review?(dao)
Attachment #8552750 - Flags: review?(dao) → review+
(Assignee)

Comment 15

4 years ago
[Tracking Requested - why for this release]: bad regression for users of a non-default theme

Bug 944836 has now been backed out on release (this happened in bug 1104036), so this bug will be fixed in Firefox 35.0.1.
https://hg.mozilla.org/mozilla-central/rev/04078ce3dab9
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Given that we fixed this bug in 35.0.1, we're going to want to uplift to 36 and 37 as well. Can you please submit approval requests when you have patches ready for these branches?
Flags: needinfo?(mstange)
(Assignee)

Comment 19

4 years ago
Comment on attachment 8552750 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 944836
[User impact if declined]: users of third-party "complete" themes can't move the window on the screen
[Describe test coverage new/current, TreeHerder]: none
[Risks and why]: fairly low
[String/UUID change made/needed]: none
Flags: needinfo?(mstange)
Attachment #8552750 - Flags: approval-mozilla-beta?
Attachment #8552750 - Flags: approval-mozilla-aurora?
Comment on attachment 8552750 [details] [diff] [review]
patch

Beta+ Aurora+
Attachment #8552750 - Flags: approval-mozilla-beta?
Attachment #8552750 - Flags: approval-mozilla-beta+
Attachment #8552750 - Flags: approval-mozilla-aurora?
Attachment #8552750 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
Reproduced with Firefox 35.0RC3 under Mac OS X 10.9.5.
Verified as fixed using Firefox 35.0.1 latest Developer Edition 37.0a2 and latest Nightly 38.0a1 2015-01-27.

The fix didn't reach Firefox 36 beta 4, so it will be verified on beta 5.
Verified as fixed using Firefox 36 beta 7 under Mac OSX 10.9.5.
You need to log in before you can comment on or make changes to this bug.