Firefox 35 breaks tab completion in search box

RESOLVED DUPLICATE of bug 1102948

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1102948
4 years ago
4 years ago

People

(Reporter: Josh, Unassigned)

Tracking

35 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

To get to the search box, I press control-k.
I then enter my search phrase.
Firefox auto completes using an API.
I press tab to move down the list of auto completions.


Actual results:

Pressing tab exits the search box rather than moves down the list of auto completions.


Expected results:

My selection should have moved down the list of auto completions one line for each press of the tab key.

Updated

4 years ago
Component: Untriaged → Search

Updated

4 years ago
Blocks: 1088660
(In reply to hostelmarketing from comment #0)

> Actual results:
> 
> Pressing tab exits the search box rather than moves down the list of auto
> completions.

Pressing tab is expected to select the first search engine icon in the bottom part of the search panel. Have you hidden all the one-off engine icons from the preferences?

Apart from this, this bug looks a lot like bug 1102948.
Comment hidden (typo)
(Reporter)

Comment 3

4 years ago
Yes, I've hidden all the search engines exactly for that reason. It is important that the tab key moves down the list like it does in the URL box. Using the down arrow or mouse is a painfully slow way to use a browser.

Having the tab key change search engines is a bad user interface idea. That task is not used as often as moving down the list of suggestions, therefore the motion that is most time-consuming (using the mouse or down arrow) should be assigned to the least frequently used task (changing search engines).
(In reply to hostelmarketing from comment #3)

As far as I'm concerned, this works as designed, and is a duplicate of bug 1102948.

I'm cc'ing Philipp who designed the keyboard navigation for the searchbox so that he has an opportunity to read your feedback, but I don't really expect your comment to change his mind.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102948
(Reporter)

Comment 5

4 years ago
I realize that Firefox needs income and wants users to switch away from Google, but making the user interface worse is not a reasonable solution. Is a very bad idea to have two separate behaviors for similar boxes -- the search box should work exactly the same as the URL box, or at least have an about:config setting for advanced users to toggle. I've been using Firefox since it was Mozilla Suite, and I've always been a huge supporter (even starting a Firefox extension Meetup group in the Bay Area).

Power users do not want to lift their hands off the keyboard to press the down arrow or click the mouse. I don't want two separate behaviors for two similar windows, because I alternately press ctrl-k or ctrl-l to do a search depending on whether I want the browser history or not. This is one of FF's strong points over Chrome.

I removed all the search engines, and it still worked in the last version of Firefox, but now when I press tab, the cursor completely leaves the search box and doesn't do anything. At least make it so that when there are no other search engines one can still press tab.

If Firefox does things like this, you are going to alienate your strongest supporters.
You need to log in before you can comment on or make changes to this bug.