Closed Bug 1123086 Opened 5 years ago Closed 5 years ago

VoiceOver cursor does not move to appropriate element after loading a page

Categories

(Firefox for iOS :: Browser, defect)

All
iOS 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dusek, Unassigned)

References

Details

After loading a new page (regardless whether by entering and confirming a URL, or using the back or forward button), VoiceOver user expects the VoiceOver cursor to automatically move to the correct element. The "correct element" is (because this way it behaves in Safari, and seems reasonable as it saves the user from navigating VoiceOver cursor manually):

- the element that has focus
- if there is no such focused element:
  - if the page was loaded by entering a URL / following a link, it is the first element on the webpage accessible to VoiceOver
  - if the page was loaded by using back/forward button, it is the element where VoiceOver cursor was last present on the page
This can be closed as fixed because it has been fixed by https://github.com/mozilla/firefox-ios/pull/95
Thanks!
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.