Closed Bug 1123132 Opened 5 years ago Closed 5 years ago

Hello/Loop - Cannot join conversation if in private mode (Failed to open a chat window in Chat.jsm)

Categories

(Hello (Loop) :: Client, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1108187

People

(Reporter: chris, Assigned: standard8)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150112203352

Steps to reproduce:

1. Start a conversation
2. Send the link to a friend
3. Friend opens the link and your "Hello" Icon turns blue
4. Try to join the conversation (click on the conversation link in the hello menu)

I'm using Firefox 35 on Lubuntu 14.04.



Actual results:

Nothing happens and Firefox browser console says:
"Failed to open a chat window - no host window could be found. - Chat.jsm:113"


Expected results:

Conversation should start/open.
Component: Untriaged → Client
Product: Firefox → Loop
Version: 35 Branch → unspecified
Christoph, thanks for the report.

Are you in private browsing mode? Or somehow not have a main (non-private) browser window open?
Flags: needinfo?(chris)
(In reply to Mark Banner (:standard8) from comment #1)
> Christoph, thanks for the report.
> 
> Are you in private browsing mode? Or somehow not have a main (non-private)
> browser window open?

Perfect!

I had "Always use private browsing mode" set. After I disabled it Loop/Hello works great.
Is there a better solution than disable the private mode permanently?
Maybe ask the user if he wants to quit the private mode instead of a silent failure?

Thanks for your help.
Flags: needinfo?(chris)
Summary: Hello - Cannot join conversation (Failed to open a chat window) → Hello/Loop - Cannot join conversation if in private mode (Failed to open a chat window in Chat.jsm)
[Tracking Requested - why for this release]: This happens in the latest release version, Fx36. 

A friend of mine said Hello wasn't working for him, and after some troubleshooting, it turned out to be the browser was starting up in private browsing mode. I was able to confirm as well, at least on Mac.

Starting up in PB mode might not be a common occurrence, but there's also no indication you are in PB mode, so troubleshooting this took a little bit of time.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I don't think this is the common case but it's concerning that Hello completely fails in this supported scenario.

ni Maire to assess impact and help find an owner.
Gavin is now the engineering manager for the front-end of Hello (basically since early January).  I'm still the platform manager for WebRTC/Hello, but this is a front-end issue. So I'm transferring the needinfo to Gavin.
Flags: needinfo?(mreavy) → needinfo?(gavin.sharp)
Mark has a patch to disable Hello in Private Browsing windows (perhaps in another bug, dupe as needed).
Assignee: nobody → standard8
Flags: needinfo?(gavin.sharp)
Yep, bug 1108187 is disabling Hello in private browsing windows so we can remove the confusion. There's a future looking bug 1005019 for considering if we want to support private browsing mode to some extent (if it makes sense to etc).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1108187
You need to log in before you can comment on or make changes to this bug.