Closed Bug 1108187 Opened 5 years ago Closed 5 years ago

Temporarily remove Hello button from private browsing windows whilst we decide how to handle private browsing mode

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
1

Tracking

(firefox36 wontfix, firefox37+ verified, firefox38+ verified, firefox39 verified)

VERIFIED FIXED
mozilla39
Iteration:
39.1 - 9 Mar
Tracking Status
firefox36 --- wontfix
firefox37 + verified
firefox38 + verified
firefox39 --- verified
Blocking Flags:
backlog backlog+

People

(Reporter: antispam, Assigned: standard8)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

1. open a Private Browsing window and close all your other firefox windows

2. use Firefox Hello widget to send someone a link to call you

3. they call you

4. you hear a ringing sound but see no way to answer their call

(I was in private browsing mode by accident and this was my first time trying Firefox Hello, so it was particularly confusing for me!  Tested on Linux.)



Expected results:

Considering https://bugzilla.mozilla.org/show_bug.cgi?id=1005019 , I don't know what *should* happen exactly.  Either you should be able to answer the call, or Firefox should tell you at some point in this process that you screwed up.
actual user agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Thanks for the bug report. I think we'll need a resolution to bug 1005019 before evaluating this report. If you have any specific thoughts on how Hello should work in Private Browsing, please add a comment to bug 1005019.
Depends on: 1005019
I just tested this locally, to clarify: The incoming window is displayed in a non-private browsing window - its just not the one that's the focus, as you'd expect from the STRs in comment 0.

As already commented, bug 1005019 is likely needed before we can resolve this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Can't answer when placing Hello call while in Private Browsing → Receiving a call whilst in private browsing mode goes to a non-private browsing window
Mark Banner: Correct... if you *have* any non-private browsing windows!
backlog for PM discussion pending bug 1005019
backlog: --- → backlog
(In reply to antispam from comment #4)
> Mark Banner: Correct... if you *have* any non-private browsing windows!
Nothing shows up if you don't have a non-private window open.
Console log: "Failed to open a chat window - no host window could be found."
(In reply to Paul Silaghi, QA [:pauly] from comment #6)
> (In reply to antispam from comment #4)
> > Mark Banner: Correct... if you *have* any non-private browsing windows!
> Nothing shows up if you don't have a non-private window open.
> Console log: "Failed to open a chat window - no host window could be found."

This brings to mind -- the handling here should take Bug 1031439 into account: there will almost certainly be some commonality between handling when all windows are closed and handling when all non-private windows are closed.
backlog: backlog+ → backlog-
We discussed this a bit yesterday, and decided that we should - for now at least - hide the Loop button in private browsing mode. This is because it doesn't work properly, i.e. it doesn't open the chat window.

Whilst we could open a chat window in a private browsing window/mode, there's concerns about how Loop and private browsing relate which we haven't resolved yet - bug 1005019 will take a look at resolving those.

In the meantime, users are hitting this, and for other bugs I need to make adjustments to how the chat window opening works, so disabling the button is the best intermediate thing I think we can do.

Here's a simple patch to do that along with a test.
Attachment #8572525 - Flags: review?(mdeboer)
Assignee: nobody → standard8
Blocks: 1005019
backlog: backlog- → backlog+
Iteration: --- → 39.1 - 9 Mar
Points: --- → 1
No longer depends on: 1005019
Comment on attachment 8572525 [details] [diff] [review]
Hide Loop's toolbar button in private browsing mode as Loop doesn't work fully in it yet.

Review of attachment 8572525 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the unit test removed.

Since you're only using the `showInPrivateBrowsing` flag, we can rely on the CustomizableUI test coverage here. I'm sorry for 'nullifying' your effort here :/
Attachment #8572525 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/mozilla-central/rev/7d5778f86884
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: qe-verify+
[Tracking Requested - why for this release]: Moving tracking from bug 1123132 as that's just about to be duped here.

This is a confusing issue for users and we haven't fully resolved what to do in private browsing mode, so we're disabling it for now in private browsing to remove the confusion.
Duplicate of this bug: 1123132
Comment on attachment 8572525 [details] [diff] [review]
Hide Loop's toolbar button in private browsing mode as Loop doesn't work fully in it yet.

Approval Request Comment
[Feature/regressing bug #]: Firefox Hello
[User impact if declined]: Users are getting confused as to why the Hello button is available in private browsing mode, but then it doesn't work.
[Describe test coverage new/current, TreeHerder]: Using existing flag for the button that's already tested and has been used.
[Risks and why]: Low, see user impact
[String/UUID change made/needed]: None
Attachment #8572525 - Flags: approval-mozilla-beta?
Attachment #8572525 - Flags: approval-mozilla-aurora?
Comment on attachment 8572525 [details] [diff] [review]
Hide Loop's toolbar button in private browsing mode as Loop doesn't work fully in it yet.

Approving this for aurora and beta. We are planning to ship 37 with the button disabled.
Attachment #8572525 - Flags: approval-mozilla-beta?
Attachment #8572525 - Flags: approval-mozilla-beta+
Attachment #8572525 - Flags: approval-mozilla-aurora?
Attachment #8572525 - Flags: approval-mozilla-aurora+
Note that this bug missed 37 Beta 3. IT will be included in 37 Beta 4.
Tracking as this is a poor UX and want to be alerted if this bug is reopened for any reason.
No longer depends on: 1144722
See Also: → 1144722
I understand from the above comments that the purpose of this bug is to remove the Hello Button out of Private Window toolbar. 

I verified this and the Hello Button is not displayed in Private Window on Firefox 40.0a1 (2015-04-02), Firefox 39.0a2 (2015-04-03), Firefox 38 Beta 1 (20150330154247) and Firefox 37.0.1 (20150402191859) using Windows 8.1 32-bit and Ubuntu 14.04 32-bit.

If I am right, Mark, can you please update the summary in order to reflect the purpose of this bug?
Flags: needinfo?(standard8)
Yep, updated.
Flags: needinfo?(standard8)
Summary: Receiving a call whilst in private browsing mode goes to a non-private browsing window → Temporarily remove Hello button from private browsing windows whilst we decide how to handle private browsing mode
Thanks Mark!

Marking this bug as Verified based on the above mentioned and on a recent testing on Firefox 40.0a1 (2015-04-20), Firefox 39.0a2 (2015-04-20), Firefox 38 Beta 6 (20150420134330) and Firefox 37.0.2 (20150415140819) using Windows 7 64-bit.
You need to log in before you can comment on or make changes to this bug.