[Settings]There is no SIM settings icons when you insert SIM2 only in Settings -> Cellular & Data.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Settings
--
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ericcc, Assigned: GaryChen)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1094129 +++

[1.Description]:
There is no SIM settings icons when you insert SIM2 only in Settings -> Cellular & Data. 
Attch:logcat_1334.txt,SIM1.png and SIM2_1334.png.
Found time:13:34

[2.Testing Steps]: 
1. Insert a SIM card into SIM 1 slot. 
2. Go to Settings -> Cellular & Data. 
3. Select SIM 1 and go to Network operator. 
4. Toggle "automatic selection" off. 
5. Select one of the operators. 
6. Power off device and switch SIM card to SIM 2 slot and power on device. 
7. Go to Settings -> Cellular & Data. 
8. Select SIM 2 and go to Network operator.

[3.Expected Result]: 
8. Only SIM2 is available and SIM1 is grey in SIM setings page. 

[4.Actual Result]: 
8.There is no "SIM settings" icons. 

[5.Reproduction build]: 
Serial: e47cd843 (State: device)
Build ID               20150118002501
Gaia Revision          f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gaia Date              2015-01-17 00:16:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150118.035516
Firmware Date          Sun Jan 18 03:55:27 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
(Reporter)

Comment 1

3 years ago
Hi Gary, We have a regression, same as this https://bugzilla.mozilla.org/show_bug.cgi?id=1094129, could you also check on this, thanks.

Set blocking-b2g=2.2? for regression.
blocking-b2g: --- → 2.2?
Flags: needinfo?(gchen)
Summary: [Woodduck v2.0m][Flame v2.1][Settings]There is no SIM settings icons when you insert SIM2 only in Settings -> Cellular & Data. → [Settings]There is no SIM settings icons when you insert SIM2 only in Settings -> Cellular & Data.
Created attachment 8551204 [details] [review]
Proposed patch

Arthur could you review the patch when you get a chance?

Thank you!
Assignee: nobody → b.mcb
Attachment #8551204 - Flags: review?(arthur.chen)
Created attachment 8551641 [details] [review]
PR  https://github.com/mozilla-b2g/gaia/pull/27515

Hi arthur, 
   Per offline discussion, here is my WIP patch, could you help to take a look?
   Thanks.
Flags: needinfo?(gchen)
Attachment #8551641 - Flags: feedback?(arthur.chen)
Hi Mancas,
   Sorry, I didn't notice you are working on this issue too.
   We found the root cause is 'dsds_settings' not ready before user tap 'carrier' item, and this issue also case 'call' item doesn't navigate to right panel.

   My patch can fix these two issues, so would you mind take a look my patch? Maybe we can integrate these two patches into one.
   Thanks.
Flags: needinfo?(b.mcb)

Comment 5

3 years ago
Triage: regression, blocking
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8551204 [details] [review]
Proposed patch

Manuel, thanks for the patch! It does solve part of the problem. However, as Gary suggested that there is a potential racing between the loading of carrier.js and dsds_settings.js, so we should also take it into consideration in the patch. Would you mind let Gary handle this issue?
Attachment #8551204 - Flags: review?(arthur.chen)
Comment on attachment 8551641 [details] [review]
PR  https://github.com/mozilla-b2g/gaia/pull/27515

Looks good to me, thanks!
Attachment #8551641 - Flags: feedback?(arthur.chen) → feedback+
Of course, let's do a good work here! Now, this bug is yours Gary =)
Assignee: b.mcb → gchen
Flags: needinfo?(b.mcb)
Thanks, Manuel :)
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=Gaia::Settings]
Comment on attachment 8551641 [details] [review]
PR  https://github.com/mozilla-b2g/gaia/pull/27515

Hi Arthur,
   I've addressed your comment on my patch and I add an additional change for passing gaia-try.
   There is no 'navigator.mozMobileConnections' in gaia-try environment, so | _mobileConnections| will get undefined and cause test failed, so I add check on below code.
  https://github.com/mozilla-b2g/gaia/pull/27515/files#diff-5f3644e44168e13643a9f97cd2b39b53L33
  
   Could you help to take a look?
Attachment #8551641 - Flags: review?(arthur.chen)
Comment on attachment 8551641 [details] [review]
PR  https://github.com/mozilla-b2g/gaia/pull/27515

r=me with the nit addressed, thanks!
Attachment #8551641 - Flags: review?(arthur.chen) → review+
land in master:
https://github.com/mozilla-b2g/gaia/commit/5a6e46a5a675b00200d62127350f4152593e642c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this when you get a chance.
status-b2g-master: --- → fixed
Flags: needinfo?(gchen)
Target Milestone: --- → 2.2 S5 (6feb)
Comment on attachment 8551641 [details] [review]
PR  https://github.com/mozilla-b2g/gaia/pull/27515

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug #1094129 
[User impact] if declined: Can enter sim setting panel when user only insert sim card in slot #2.
[Testing completed]:
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=0552403b3c26
[Risk to taking this patch] (and alternatives if risky):low
[String changes made]:N/A
Flags: needinfo?(gchen)
Attachment #8551641 - Flags: approval-gaia-v2.2?

Comment 15

3 years ago
Created attachment 8557696 [details]
verify_v3.0.MP4

This issue has been verified successfully on Flame 3.0
STR:
1. Insert a SIM card into SIM 1 slot. 
2. Go to Settings -> Cellular & Data. 
3. Select SIM 1 and go to Network operator. 
4. Toggle "automatic selection" off. 
5. Select one of the operators. 
6. Power off device and switch SIM card to SIM 2 slot and power on device. 
7. Go to Settings -> Cellular & Data.
**Only SIM2 is available and SIM1 is grey in SIM setings page. 
8. Select SIM 2 and go to Network Operator.
**It could go to Nerwork Operator correctly.
See attachment:verify_v3.0.MP4
Rate:0/5

Flame 3.0 build:
Gaia-Rev        ab69ae06a7f2b54e60ab63b1b44c8d19d5d20d94
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c2359a6a6958
Build-ID        20150201010217
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.044915
FW-Date         Sun Feb  1 04:49:25 EST 2015
Bootloader      L1TC000118D0

Updated

3 years ago
QA Whiteboard: [COM=Gaia::Settings] → [COM=Gaia::Settings], [MGSEI-Triage+]
status-b2g-master: fixed → verified

Updated

3 years ago
Attachment #8551641 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/1a3d1c7f8cc10b3d9651e29f23000adac9273165
status-b2g-v2.2: affected → fixed

Comment 17

3 years ago
Created attachment 8558886 [details]
verify_v2.2.png

This issue has been verified successfully on Flame 2.2
STR:
1. Insert a SIM card into SIM 1 slot. 
2. Go to Settings -> Cellular & Data. 
3. Select SIM 1 and go to Network operator. 
4. Toggle "automatic selection" off. 
5. Select one of the operators. 
6. Power off device and switch SIM card to SIM 2 slot and power on device. 
7. Go to Settings -> Cellular & Data.
**Only SIM2 is available and SIM1 is grey in SIM setings page. 
8. Select SIM 2 and go to Network Operator.
**It could go to Nerwork Operator correctly.
See attachment:verify.png
Rate:0/5

Flame 2.2 build:
Build ID               20150203162505
Gaia Revision          3161b65189cb1d7d30f01e599d75e190434ad90b
Gaia Date              2015-02-03 14:27:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a4028c388cff
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.200315
Firmware Date          Tue Feb  3 20:03:26 EST 2015
Bootloader             L1TC000118D0

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Depends on: 1134321
You need to log in before you can comment on or make changes to this bug.