[Flame][Dialer]It can't enter corresponding settings page when you tap "Voicemail" and "Fixed Dialing Numbers".

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: echang, Assigned: eragonj)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1118182 +++

[1.Description]:
[Flame v2.2][Dialer]
When you tap "Voicemail" and "Fixed Dialing Numbers" at Call Settings page, the options you tapped is highlighted but it can't enter the corresponding settings page.
Found time:14:41
See attachment:logcat_1441.txt and video.MP4

[2.Testing Steps]: 
1. Insert a SIM card and launch Dialer app.
2. Long press "1" button.
**The "Voicemail number is unavailable" prompt will show up.
3. Tap "Settings" button.
**The Call Settings page shows up.
4. Tap "Voicemail" and "Fixed Dialing Numbers".

[3.Expected Result]: 
3. It will go to "Voicemail" and "Fixed Dialing Numbers" settings normally.

[4.Actual Result]: 
4. The options you tapped will be highlighted but it can't enter the corresponding settings page. 

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/55f3224d7513
Build-ID        20150104010206
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150104.043402
FW-Date         Sun Jan  4 04:34:12 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]:
Free Test
(Reporter)

Comment 1

4 years ago
Set 2.2? for regression.
Related https://bugzilla.mozilla.org/show_bug.cgi?id=1118182
Hi EJ, Thanks.
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Gaia::Settings]
Flags: needinfo?(ejchen)
Thanks Eric, I didn't notice that FDN is broken (this is another problem), and I'll give a fix here.
Flags: needinfo?(ejchen)
Assignee: nobody → ejchen
Status: NEW → ASSIGNED
Comment on attachment 8551649 [details] [review]
patch on master

Arthur, I wrote this patch based on our offline discussion. In order not to change the interface, we will update targetPanelId based on our hardware information (DSDS -> call_iccs, Single SIM -> call).

Please help me review this patch, thanks :)
Attachment #8551649 - Flags: review?(arthur.chen)

Comment 5

4 years ago
Triage: regression, blocking
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8551649 [details] [review]
patch on master

r=me with the comment addressed, thanks!
Attachment #8551649 - Flags: review?(arthur.chen) → review+
Thanks Arthur, related comments were addressed already and waiting for CI right now.
Thanks all, merged at gaia/master: https://github.com/mozilla-b2g/gaia/commit/684b8b3a27d73ec79694b4595fd4618196415f81
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8551649 [details] [review]
patch on master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: Users are not able to use fdn feature when navigating from sms to settings.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8551649 - Flags: approval-gaia-v2.2?

Comment 10

4 years ago
Posted video verify_v3.0.MP4
This issue has been verified successfully on Flame 3.0
STR:
1. Insert a SIM card and launch Dialer app.
2. Long press "1" button.
**The "Voicemail number is unavailable" prompt will show up.
3. Tap "Settings" button.
**The Call Settings page shows up.
4. Tap "Voicemail" and "Fixed Dialing Numbers".
**It will go to "Voicemail" and "Fixed Dialing Numbers" settings normally.
See attachment:verify_v3.0.MP4
Rate:0/5

Flame 3.0 build:
Build ID               20150204160237
Gaia Revision          b9607aef7debbde09a8db801ce4d021b8262e7f3
Gaia Date              2015-02-04 16:29:57
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3cda3997f45d
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.192122
Firmware Date          Wed Feb  4 19:21:34 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [COM=Gaia::Settings] → [COM=Gaia::Settings][MGSEI-Triage+]
Attachment #8551649 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Updated

4 years ago
Keywords: verifyme

Comment 12

4 years ago
Posted video verify_v2.2.MP4
This issue has been verified successfully on Flame 2.2, tap "Voicemail" and "Fixed Dialing Numbers" will go to "Voicemail" and "Fixed Dialing Numbers" settings normally.
STR:
1. Insert a SIM card and launch Dialer app.
2. Long press "1" button.
**The "Voicemail number is unavailable" prompt will show up.
3. Tap "Settings" button.
**The Call Settings page shows up.
4. Tap "Voicemail" and "Fixed Dialing Numbers".
**It will go to "Voicemail" and "Fixed Dialing Numbers" settings normally.
See attachment:verify_v2.2.MP4
Rate:0/5

Flame 2.2 build:
Build ID               20150208002500
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.035623
Firmware Date          Sun Feb  8 03:56:34 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED
Keywords: verifyme
See Also: → 1235533
You need to log in before you can comment on or make changes to this bug.