[Woodduck][wap][browser]MS download something automatically when user tap a sublink of webpage.

RESOLVED DUPLICATE of bug 804642

Status

Firefox OS
Gaia::Browser
P2
normal
RESOLVED DUPLICATE of bug 804642
4 years ago
3 years ago

People

(Reporter: sync-1, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
Created an attachment (id=1122591)
 verify_video
 
 DEFECT DESCRIPTION:
 
  MS download something automatically when user tap a sublink of webpage.
 
  REPRODUCING PROCEDURES:
 
  1.go to browser and launch "www.baidu.com"
 
  2.tap "极简版" in  the webpage--KO
 
 >MS auto download something which can't be opened.
 
 
  EXPECTED BEHAVIOUR:
 
 MS should open load sunblink normally.
(Reporter)

Comment 1

4 years ago
Created attachment 8551085 [details]
verify_video
(Reporter)

Comment 2

4 years ago
Created attachment 8551096 [details]
炫彩版与传统版无区别
(Reporter)

Comment 3

4 years ago
Created attachment 8551097 [details]
download something
(Reporter)

Comment 4

4 years ago
Created attachment 8551098 [details]
mtklog
(Reporter)

Comment 5

4 years ago
Created attachment 8551100 [details]
screenshot
The link of "极简版" point to a wml file. Desktop firefox also opens it as a download file. Desktop Chrome display this wml file as a xml.

I think the problem here should be m.baidu.com returns a non optimized page for ffos. 

Please see bug: Bug 804642 - (baidu.com) baidu.com UA sniffing serves non optimized content

Comment 7

4 years ago
Created attachment 8551554 [details]
logcat_0958.txt

I found "www.baidu.com" displayed as desktop view, and "m.baidu.com" displayed as mobile view. I can repro this issue on Flame 2.0/2.1/2.2 and Woodduck 2.0M by steps:
1. Launch Browser.
2. Go to "m.baidu.com".
3. Tap "极简版".
**MS auto download something which can't be opened.

I have uploaded the logcat and video of Flame v2.2
Found time:09:58
See attachment:logcat_0958.txt and video.MP4
Rate:5/5

Flame 2.0 build:
Gaia-Rev        736933b25ded904f0cb935a0d48f1f3cf91d33ad
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/6c9aefc84244
Build-ID        20150119000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.033618
FW-Date         Mon Jan 19 03:36:29 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 build:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452a023ae7b2
Build-ID        20150119001222
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.035259
FW-Date         Mon Jan 19 03:53:10 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/bccee1a13ba6
Build-ID        20150119002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.035831
FW-Date         Mon Jan 19 03:58:42 EST 2015
Bootloader      L1TC000118D0

Woodduck build:
Gaia-Rev        8b2e62a69dc6da9d064b6f2ea42b61fcc11b6685
Gecko-Rev       35614bb51c33caccaa2b83b3226109a80a7a46d2
Build-ID        20150120050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1421701500
FW-Date         Tue Jan 20 05:05:18 CST 2015

Comment 8

4 years ago
Created attachment 8551555 [details]
video.MP4

Comment 9

4 years ago
Hi reporter,
I used the "m.baidu.com" to verify this issue, could you help to check it? Thanks!
Flags: needinfo?(sync-1)
(Reporter)

Comment 10

4 years ago
(In reply to comment #1)
 > Comment from Mozilla:Hi reporter,
 > I used the "m.baidu.com" to verify this issue, could you help to check it?
 > Thanks!
 > 
 
 OK
(Reporter)

Comment 11

4 years ago
(In reply to comment #1)
 > Comment from Mozilla:Hi reporter,
 > I used the "m.baidu.com" to verify this issue, could you help to check it?
 > Thanks!
 > 
 
 Hi,
 
 Using the "m.baidu.com" is same as the "www.baidu.com".
 
 The issue appears whether using the "m.baidu.com" or using the "www.baidu.com".

Comment 12

4 years ago
(In reply to sync-1 from comment #11)
>  Hi,
>  
>  Using the "m.baidu.com" is same as the "www.baidu.com".
>  
>  The issue appears whether using the "m.baidu.com" or using the
> "www.baidu.com".

In my device, using the "www.baidu.com" will display as desktop view, and I can't find "极简版".

Comment 13

3 years ago
Hi Reporter,
This is Baidu website issue for recognizing UA of Firefox. We have contact Baidu per https://bugzilla.mozilla.org/show_bug.cgi?id=804642#c6. Please stay tune. Thanks!
Blocks: 1054172
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804642
(Reporter)

Comment 14

3 years ago
(In reply to comment #8)
 > Comment from Mozilla:Hi Reporter,
 > This is Baidu website issue for recognizing UA of Firefox. We have contact
 > Baidu per https://bugzilla.mozilla.org/show_bug.cgi?id=804642#c6. Please stay
 > tune. Thanks!
 > 
 
 ok,Thanks!
You need to log in before you can comment on or make changes to this bug.