[Ubuntu] Alt + up/down in searchbar doesn't select one-click search engines

RESOLVED WONTFIX

Status

()

Firefox
Search
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: petruta, Assigned: Neil Deakin)

Tracking

Trunk
All
Linux
Points:
2
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox35 unaffected, firefox36+ wontfix, firefox37+ wontfix, firefox38+ wontfix, firefox39 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Reproduced under Ubuntu 12.04 LTS 32-bit (all branches), the other platforms are not affected.

Steps to reproduce:
Go to search bar and start typing
Use Alt + up/down arrows to select the one-click search engines

Expected results:
The command should go through the one-click search engines list 

Actual results:
Alt + up/down command closes and opens the dropdown without any search engines to be selected from the list
[Tracking Requested - why for this release]: this bug makes the keyboard binding we re-added for 36 in bug 1110678 unusable on Linux.
status-firefox36: --- → affected
status-firefox37: --- → affected
status-firefox38: --- → affected
tracking-firefox36: --- → ?
tracking-firefox37: --- → ?
Flags: qe-verify+
Flags: firefox-backlog+
status-firefox35: --- → unaffected
tracking-firefox36: ? → +
tracking-firefox37: ? → +
tracking-firefox38: --- → +
Points: --- → 2
Florian, are you planning to work on this during the 36 cycle?
Flags: needinfo?(florian)
(In reply to Sylvestre Ledru [:sylvestre] from comment #2)
> Florian, are you planning to work on this during the 36 cycle?

I would prefer if someone else could do it. From a quick experiment, it seems that pressing only alt, or alt+any key closes the panel on keydown, which causes this.popupOpen to always be false at (http://hg.mozilla.org/mozilla-central/annotate/0467412f8413/browser/components/search/content/search.xml#l966), which is why we reopen it and it keeps blinking.

I don't know which code is responsible for closing the panel when alt is pressed. I initially thought it was http://hg.mozilla.org/mozilla-central/annotate/6bfc0e1c4b29/toolkit/content/widgets/autocomplete.xml#l489 but no, that's not what's closing the panel here.
Flags: needinfo?(florian)
Neil, might you be able to look into this?
Flags: needinfo?(enndeakin)
(Assignee)

Comment 5

3 years ago
When Alt is pressed on Ubuntu, it normally focuses the menubar, which is at the top of the screen, and closes any popups. That's what is happening on my system. Is this the behaviour you're seeing here?

If so, I recall that affected another popup somewhere, but don't remember the details. I'll look to see if there is a way to disable this.
Flags: needinfo?(enndeakin)
(In reply to Neil Deakin from comment #5)

> If so, I recall that affected another popup somewhere, but don't remember
> the details. I'll look to see if there is a way to disable this.

It affects the popup of the awesomebar too.
(Assignee)

Comment 7

3 years ago
After testing this some more, it's actually the HUD that is opened with alt. When I disable the shortcut for this (System Settings -> Keyboard -> Shortcuts), the popup does not close when I press alt.
(Assignee)

Comment 8

3 years ago
Created attachment 8559255 [details] [diff] [review]
noaltsearch

This following patch will disable the menubar from opening while the search popup is open.
Neil - I'm assigning this one to you as it looks like you're taking it.
Assignee: nobody → enndeakin
(Assignee)

Comment 10

3 years ago
Petruta, can you confirm that comment 7 is what is happening? Does the patch here help?
Neil, this bug is tracking 36+, can you get the patch ready to land on beta ASAP?
Flags: needinfo?(enndeakin)

Updated

3 years ago
Status: NEW → ASSIGNED
Iteration: --- → 38.2 - 9 Feb
(In reply to Neil Deakin from comment #7)
> After testing this some more, it's actually the HUD that is opened with alt.
> When I disable the shortcut for this (System Settings -> Keyboard ->
> Shortcuts), the popup does not close when I press alt.

Indeed, disabling this system keyboard shortcut makes the bug disappear on the search panel (interestingly removing the system shortcut doesn't fix the problem on the awesomebar, so there may be an additional issue there).

Unfortunately, attachment 8559255 [details] [diff] [review] doesn't seem to help.
(Assignee)

Comment 13

3 years ago
OK, so if it's HUD that is taking the focus, then I'm not sure if there is a way around it in certain cases. Even other applications don't disable this.
Flags: needinfo?(enndeakin)
ok, so, won't fix for 36.
status-firefox36: affected → wontfix

Updated

3 years ago
Iteration: 38.2 - 9 Feb → 38.3 - 23 Feb

Updated

3 years ago
Iteration: 38.3 - 23 Feb → 39.1 - 9 Mar
(Assignee)

Comment 15

3 years ago
I'm not sure what can be used to prevent this. I asked mconley and he wasn't sure, but perhaps Karl knows.

The issue here is that pressing Alt on Ubuntu brings up the HUD. When the search panel is open, it would be desirable to allow the Alt+Arrow shortcuts to work. If we can't, alternatively we can either use another shortcut on Linux or not have a shortcut.
Flags: needinfo?(karlt)
(In reply to Neil Deakin from comment #13)
> Even other applications don't disable this.

If the system is taking this key sequence before it gets to the application, and it sounds like it is, then we are limited in what we can do.  Even if we could grab the keyboard focus, I'm not sure that would be the right thing to do.  This is not a dropdown that the user explicitly opened, but merely one that happened to open as the user typed.  Grabbing the keyboard focus would prevent other system shortcuts, such as volume keys from having effect.

If Alt+Up/Down is already used on Unity, then I would suggest using a different shortcut.
The functionality is already available with plain Up/Down, it seems.
Flags: needinfo?(karlt)

Updated

3 years ago
Iteration: 39.1 - 9 Mar → 39.2 - 23 Mar
(Assignee)

Comment 17

3 years ago
OK, so I think we should either:

1. Do nothing and just close this bug, allowing those who don't have the system shortcut assigned to use this alt+cursor to navigate the search list.
2. Disable the shortcut on Linux.
3. Use a different shortcut on Linux.

Florian, do you have a preference here?
Flags: needinfo?(florian)
(In reply to Neil Deakin from comment #17)
> OK, so I think we should either:
> 
> 1. Do nothing and just close this bug, allowing those who don't have the
> system shortcut assigned to use this alt+cursor to navigate the search list.
> 2. Disable the shortcut on Linux.
> 3. Use a different shortcut on Linux.
> 
> Florian, do you have a preference here?

I think I would just go with 1; it's less work for us and avoids introducing inconsistencies in our code for specific OSes.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(florian)
Resolution: --- → WONTFIX
status-firefox37: affected → wontfix
status-firefox38: affected → wontfix
status-firefox39: --- → wontfix
You need to log in before you can comment on or make changes to this bug.