Closed Bug 1110678 Opened 5 years ago Closed 5 years ago

Re-implement Ctrl+up/down and Alt+up/down in the search field

Categories

(Firefox :: Search, defect)

36 Branch
x86
All
defect
Not set
Points:
5

Tracking

()

VERIFIED FIXED
Firefox 37
Iteration:
37.3 - 12 Jan
Tracking Status
firefox34 --- wontfix
firefox35 - wontfix
firefox36 + verified
firefox37 + verified

People

(Reporter: phlsa, Assigned: florian)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

After some discussions, here's what we can do to allow for advanced keyboard shortcuts in the search field with the new UI:

Ctrl+up/down does two things:
- it opens the suggestions dropdown if it isn't visible yet
- it cycles through the default search engines (actually sets the default) and reflects that change in the suggestions header

Alt+up/down:
- opens the dropdown
- cycles through the one-click buttons (just like tab would)

Both actions only apply if the cursor is in the search field.
(In reply to Philipp Sackl [:phlsa] please use needinfo from comment #0)
> After some discussions, here's what we can do to allow for advanced keyboard
> shortcuts in the search field with the new UI:
> 
> Ctrl+up/down does two things:
> - it opens the suggestions dropdown if it isn't visible yet
> - it cycles through the default search engines (actually sets the default)
> and reflects that change in the suggestions header

This needs some more details: especially, does ctrl+up/down cycles through all the engines, or only the engines that are visible one-offs?

Also, assuming we cycle through the one-offs, if you don't show the default in the one-offs, you have no way to go back to it using ctrl+up/down; unless you make the icons move around like in madhava's mockup, which adds quite a bit of complexity (both visual and technical).
Flags: needinfo?(philipp)
(In reply to Florian Quèze [:florian] [:flo] from comment #1)
> This needs some more details: especially, does ctrl+up/down cycles through
> all the engines, or only the engines that are visible one-offs?

Let's cycle through all installed search engines. For most people, those sets should be identical anyway. By cycling through all of them, we allow the »I don't want buttons« crowd to have greater control over their search experience while hardly degrading anything for anyone else.

> Also, assuming we cycle through the one-offs, if you don't show the default
> in the one-offs, you have no way to go back to it using ctrl+up/down; unless
> you make the icons move around like in madhava's mockup, which adds quite a
> bit of complexity (both visual and technical).

I put Madhava's mockup into slides and ran it back and forth a few times. It actually doesn't look problematic to me since there's very little jumping happening (just replacement). I'm also reluctant to hastily change something for all users (including the default) to slightly improve something that is a real edge case.
Flags: needinfo?(philipp)
Duplicate of this bug: 1106331
Bug 1108230 mentions that F4 was also a documented shortcut to open the list of providers. I think we can keep that behavior, just make it (re)open the new dropdown.
Duplicate of this bug: 1108230
Duplicate of this bug: 1108490
[Ctrl] + (mouse wheel) is like [Ctrl] + [up/down] in the old search bar. It is also in this bug?
Duplicate of this bug: 1111943
(In reply to Zéfling from comment #7)
> [Ctrl] + (mouse wheel) is like [Ctrl] + [up/down] in the old search bar. It
> is also in this bug?

Yes.
Attached patch Patch v1Splinter Review
Attachment #8539732 - Flags: review?(felipc)
[Tracking Requested - why for this release]: this addresses the most common complaint related to the new search UI.
Status: NEW → ASSIGNED
Points: --- → 5
Flags: qe-verify+
Flags: firefox-backlog+
Iteration: --- → 37.2
While it might address the most common complaint, we're way too late in 35 to take on what is essentially new feature work.  Not tracking for 35, try to get something into 36 before first Beta for maximum user shake down.
Attachment #8539732 - Flags: review?(felipc) → review+
Comment on attachment 8539732 [details] [diff] [review]
Patch v1

Approval Request Comment
[Feature/regressing bug #]: bug 1088660
[User impact if declined]: impossible to change the default search engine without opening the preferences window; breaks muscle memory for a vocal minority of our users
[Describe test coverage new/current, TBPL]: QA will verify
[Risks and why]: acceptable for aurora, probably a bit more than we are willing to take in beta at this point (we wanted to fix this for 35 when the bug was filed).
[String/UUID change made/needed]: none.
Attachment #8539732 - Flags: approval-mozilla-aurora?
Iteration: 37.2 → 37.3
https://hg.mozilla.org/mozilla-central/rev/893dbf1b59ee
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Attachment #8539732 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Note for whoever tries to do the aurora check-in here: the patch will appear bitrotted unless you check-in the (already aurora approved) follow-up patch in bug 1107278 first.
I was able to reproduce this issue on Firefox 37.0a1 (2014-12-12) using Windows 7 x64.

I verified this bug on latest Firefox 37.0a1 (2015-01-09) and on latest Firefox 36.0a2 (2015-01-09) using Windows 7 x64, Ubuntu 14.04 x86 and Mac OSX 10.9.5.


I have noticed some issues:

 1. Ctrl/Cmd + up/down command crosses through the default search engines but the suggestions are not changed according to selected engine 
	- This issue is intermittently
	- Reproduces across all platforms

 2. Alt + up/down command closes and opens the dropdown list without any search engines to be selected from the list
	- Reproduces only on Ubuntu 14.04 x86

Should I file another bug for these issues or reopen this one?
Flags: needinfo?(florian)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #18)

> Should I file another bug for these issues or reopen this one?

New bugs please (in general, please file new bugs for issues found against patches that have already been uplifted to aurora, or that we are unlikely to backout due to the issues found; otherwise tracking of what landed / got verified where gets very confusing if we keep the same bug).
Flags: needinfo?(florian)
Duplicate of this bug: 1111943
Depends on: 1121535
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #18)

> I have noticed some issues:
> 
>  1. Ctrl/Cmd + up/down command crosses through the default search engines
> but the suggestions are not changed according to selected engine 
> 	- This issue is intermittently
> 	- Reproduces across all platforms
> 
>  2. Alt + up/down command closes and opens the dropdown list without any
> search engines to be selected from the list
> 	- Reproduces only on Ubuntu 14.04 x86
> 
> Should I file another bug for these issues or reopen this one?

Have you filed these bugs?
Flags: needinfo?(vasilica.mihasca)
Logged bug 1123292 and bug 1123293 for the above issues. 

Another thing that I noticed is that Ctrl+ up/down arrows goes from the first to the last item and back, so doesn't pass from the last item to the first (unless going up again) - is this by design?

Marking this bug as verified as per above comments and issues logged.
Status: RESOLVED → VERIFIED
Flags: needinfo?(vasilica.mihasca)
(In reply to Petruta Rasa [QA] [:petruta] from comment #22)
> Logged bug 1123292 and bug 1123293 for the above issues.

Thanks!

> Another thing that I noticed is that Ctrl+ up/down arrows goes from the
> first to the last item and back, so doesn't pass from the last item to the
> first (unless going up again) - is this by design?

I think that's the behavior Firefox 33 had, so I would be inclined to not change it.
Depends on: 1124678
You need to log in before you can comment on or make changes to this bug.