Status

()

defect
RESOLVED DUPLICATE of bug 1125445
4 years ago
4 years ago

People

(Reporter: salos, Unassigned)

Tracking

(Blocks 1 bug, {regression})

35 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox35 affected, firefox36 affected, firefox37 affected, firefox38 affected, firefox-esr31 unaffected)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
Posted image chrome.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.99 Safari/537.36

Steps to reproduce:

open https://dev.alisgames.com:8081/hero/data-single_test/hero_test.html
click on video to skip, wait until game is loading


Actual results:

text are not draw correct (some text are not draw at all). Firefox 34 works fine. Chrome and Safari works fine


Expected results:

text must be drawn as on attached image (from chrome, in safari works too)
Reporter

Comment 1

4 years ago
forget to write, all texts are rendered into texture and then texture with whole text is drawn to screen. It seems that first batch is not drawn correct the second one seems to draw correct
Reporter

Comment 2

4 years ago
Posted image firefox.png
that is how it works in firefox
Reporter

Comment 3

4 years ago
porbably the cause is that I'm using alpha texture (i.e. texture that has only alpha channel
glTexImage2D(GL_TEXTURE_2D, 0, GL_ALPHA, (GLsizei)image.getWidth(), (GLsizei)image.getHeight(), 0, GL_ALPHA, GL_UNSIGNED_BYTE, image.getData());

Comment 4

4 years ago
Could you provide minimal testcase?
And could you try using mozregression tool to find regression? 
( http://mozilla.github.io/mozregression/ )

Updated

4 years ago
Flags: needinfo?(salos)

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 5

4 years ago
from mozregression

11:21.94 LOG: MainThread Bisector INFO Last good revision: 14665b1de5ee
11:21.94 LOG: MainThread Bisector INFO First bad revision: 5d6ec4dddf14

11:21.94 LOG: MainThread Bisector INFO Narrowed nightly regression window from [2014-09-30, 2014-10-02] (2 days) to [2014-10-01, 2014-10-02] (1 days) (~0 steps left)

creating more minimal test require for me quite a lot of time. If mozreggression info is not enough tell me.
Flags: needinfo?(salos)

Comment 7

4 years ago
Disable ANGLE helps. (however, another Bug 1123573 will raise)
user_pref("webgl.disable-angle", true);
user_pref("webgl.force-enabled", true);
Reporter

Comment 8

4 years ago
these changes

user_pref("webgl.disable-angle", true);
user_pref("webgl.force-enabled", true);

helps.

I found workaroud without changing prefs. I need to explicitly define when initialize webgl context.
alpha:true

e.g. 
var webGLContextAttributes = {alpha:true};
ctx = canvas.getContext("webgl", webGLContextAttributes) || canvas.getContext("experimental-webgl", webGLContextAttributes);

However this is default value
This might be a windows-specific regression, I can't reproduce it on linux on firefox 35.
Blocks: gecko-games
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122465

Updated

4 years ago
Flags: needinfo?(jgilbert)
You need to log in before you can comment on or make changes to this bug.