Closed Bug 1125445 Opened 5 years ago Closed 5 years ago

VertexTexture demo renders incorrectly with ANGLE

Categories

(Core :: Canvas: WebGL, defect, major)

35 Branch
All
Windows 8.1
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox35 ? affected
firefox36 + fixed
firefox37 + fixed
firefox38 + fixed
firefox-esr31 --- unaffected
b2g-v2.2 --- affected
b2g-master --- fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

()

Details

(Keywords: regression, site-compat)

Attachments

(2 files, 1 obsolete file)

http://floooh.github.io/oryol/VertexTexture.html

Works fine if you disable ANGLE, and fall back to native GL.
Man, past-me was obviously an idiot. :)
Attachment #8554956 - Flags: review?(dglastonbury)
Comment on attachment 8554956 [details] [diff] [review]
0002-Only-do-backbuffer-workaround-if-against-backbuffer.patch

Review of attachment 8554956 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/canvas/WebGLContext.h
@@ +1524,4 @@
>          const bool mNeedsChange;
>  
>          static bool NeedsChange(WebGLContext& webgl) {
> +            return !webgl.mBoundDrawFramebuffer &&

Can you right a quick comment to explain what the check is here?
Attachment #8554956 - Flags: review?(dglastonbury) → review+
r=kamidphish
Attachment #8554956 - Attachment is obsolete: true
Attachment #8554980 - Flags: review+
Severity: normal → major
Are there tests for this?
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> Are there tests for this?

There will be, but I'm not going to hold up landing this for tests.
I'll make some tests to prevent us from backsliding, though.
I should note that there are tests for this code, but I only tested the case where we're rendering into the webgl backbuffer.
Approval Request Comment
[Feature/regressing bug #]: Bug 1048108
[User impact if declined]: Bad rendering WebGL content that relies on intermediate techniques. (rendering to the alpha channel in a draw call against a framebuffer)
[Describe test coverage new/current, TreeHerder]: Planned.
[Risks and why]: No risk. It's a one-line correction of clear, but incorrect logic.
[String/UUID change made/needed]: none
Attachment #8555477 - Flags: review+
Attachment #8555477 - Flags: approval-mozilla-release?
Attachment #8555477 - Flags: approval-mozilla-beta?
Attachment #8555477 - Flags: approval-mozilla-b2g37?
Attachment #8555477 - Flags: approval-mozilla-aurora?
[Tracking Requested - why for this release]: recent regression since FF35
Blocks: 1048108
Keywords: regression
Version: unspecified → 35 Branch
(In reply to Jeff Gilbert [:jgilbert] from comment #6)
> I should note that there are tests for this code, but I only tested the case
> where we're rendering into the webgl backbuffer.

Can we add the test that would have caught this?
(In reply to Milan Sreckovic [:milan] from comment #12)
> (In reply to Jeff Gilbert [:jgilbert] from comment #6)
> > I should note that there are tests for this code, but I only tested the case
> > where we're rendering into the webgl backbuffer.
> 
> Can we add the test that would have caught this?

Yes, comment #5 has me committing to adding tests for this, but not holding up the roll-out of the regression fix on producing tests.
https://hg.mozilla.org/mozilla-central/rev/dfe54b1d8ac2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Duplicate of this bug: 1124453
Attachment #8555477 - Flags: approval-mozilla-beta?
Attachment #8555477 - Flags: approval-mozilla-beta+
Attachment #8555477 - Flags: approval-mozilla-aurora?
Attachment #8555477 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 1081497
Attachment #8555477 - Flags: approval-mozilla-b2g37?
This fix only worked for my Nvidia GTX 650, but did not resolve the issue on older hardware. See Bug 1109708.

On my older laptop and desktop with older ATI hardware in Nightly 38.0a1 (2015-01-29), the following duplicates of this bug only display a black window:

http://floooh.github.io/oryol/VertexTexture.html
http://codepen.io/anon/pen/XJMQwV
http://jsfiddle.net/f17Lz5ux/1316/
(In reply to Luke from comment #19)
> This fix only worked for my Nvidia GTX 650, but did not resolve the issue on
> older hardware. See Bug 1109708.
> 
> On my older laptop and desktop with older ATI hardware in Nightly 38.0a1
> (2015-01-29), the following duplicates of this bug only display a black
> window:
> 
> http://floooh.github.io/oryol/VertexTexture.html
> http://codepen.io/anon/pen/XJMQwV
> http://jsfiddle.net/f17Lz5ux/1316/

Ok, this is a different bug then. Can you open a new one, or link to an existing bug for this?
Duplicate of this bug: 1118284
Duplicate of this bug: 1115816
Comment on attachment 8555477 [details] [diff] [review]
alpha-read.diff (37 and older)

Clearing the uplift flags as we are working on the 36 release now.
Attachment #8555477 - Flags: approval-mozilla-release? → approval-mozilla-release-
Duplicate of this bug: 1089140
You need to log in before you can comment on or make changes to this bug.