Flame chart / flame graph toggle

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: brendan.d.gregg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Summary: when visualizing profiles, provide a toggle to switch between flame charts (time-ordered) and flame graphs (alphabet-ordered). This was mentioned in bug 1077444.

Details:

The time-ordered visualization solves many problems: it shows very slow code paths, and time-based patterns.

However, faster and changing code paths may be rendered as thin icicles, without enough horizontal space to draw the function names. Understanding this profile requires the user to zoom. This can be both time consuming, and the user can lose notion of the big picture.

For these cases, by switching the x-axis sort order from time-based to alphabetical for the stack (origin to leaf, which in the icicle plot is top-down), all thin icicles of the same code path are merged. This allows a quick visual appreciation for where time is spent, at the sacrifice of time-ordered patterns. The alphabetical sort is called a "flame graph" (http://www.slideshare.net/brendangregg/blazing-performance-with-flame-graphs/35).

Such flame graphs have been used to identify subtle performance differences, including for non-regression testing. This visualization also lends itself to the interpretation: the most important functions are the ones you can read (infrequent ones are so narrow the text is elided). Flame graphs can also be emailed as PNGs, shown in slides, printed in books, etc, retaining function names for the most frequent code paths.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Triaging. Filter on ADRENOCORTICOTROPIC (yes).
Priority: -- → P3
Duplicate of this bug: 1153492
See https://github.com/devtools-html/perf.html/issues/604 for tracking.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.