Closed Bug 1123532 Opened 5 years ago Closed 5 years ago

Recipient autocomplete: For multiple matches, select dropdown result other than first using right arrow key, confirm with Tab or Enter, and TB uses 1st result instead.

Categories

(Thunderbird :: Message Compose Window, defect)

31 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1043310

People

(Reporter: yuki, Unassigned)

Details

This is very similar to the bug 1107844. The only one difference is: how to select an auto complete menu item. The bug 1107844 has been fixed on Thunderbird 31.4.0 but this still happels for me.

Precondition: You have to prepare some cards into an address book to show multiple items in the auto complete popup for recipient fields.

Steps to reproduce:

 1. Type one or more characters into a recipient field
    to show the autocomplete popup with two ore more addresses.
    For example, you see three addresses "A", "B", and "C".
 2. Press the down arrow keys multiple times, to choose a non-first
    address item in the popup.
    For example, you choose the third item "C" from the popup.
    ,
 3. Press the right arrow key to determine the chosen item.
    Then the chosen address "C" appears in the input field.
 4. Press the TAB key or the ENTER key to focus to the next input field.

Expected result:
The address "C" (chosen by you) still there in.

Actual result:
The address "C" in the recipient field is automatically replaced with the address "A", which was the first result in the auto complete popup.
Oops...

> The bug 1107844 has been fixed on Thunderbird 31.4.0 but this still happels for me

 => The bug 1107844 has been fixed on Thunderbird 31.4.0 but this still happens for me

> Press the down arrow keys multiple times

 => Press the down arrow key multiple times

> The address "C" (chosen by you) still there in.

 => The address "C" (chosen by you) still there.
Confirmed exactly as described on Thunderbird 31.4.0
This is a little more obscure sequence of user key presses, but still it is another way for a user to send mail to the unintended recipient. 
You can also do:
1) Type some multiple match like "James"
2) Up-arrow, down-arrow, Pg-Up or Pg-Dn (or maybe any other special key that navigates the list) to not the first in the list.
3) Press Left-arrow or Home key (or Right-arrow as per the OP), the selected entry is displayed, with the cursor 1-char left of end or at the beginning of the field as expected.
4) Enter or Tab out of the field - the selected address is replaced by the first matched address.

Would be great to fix all this in the next 31.n.n!
You're in luck. Bug 1043310 fixed this, and that has landed for 31.5.0
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043310
You need to log in before you can comment on or make changes to this bug.