Closed Bug 1123669 Opened 5 years ago Closed 5 years ago

[FFOS][PDM] Video cannot be re-played in Video APP after playback ends and goes back to the beginning

Categories

(Core :: Audio/Video, defect)

37 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox38 --- fixed

People

(Reporter: bwu, Assigned: bwu)

References

Details

Attachments

(1 file, 1 obsolete file)

In http streaming case, this bug will not be found.
Blocks: 1123603
Assignee: nobody → bwu
The rootcause are mentioned in bug 1131467 comment 5 and audio decoder manager doesn't implement the override flush().
The rootcause is explained in comment 1. 
This patch is on top of Attachment #8563269 [details] [diff] in bug 1127654.
Attachment #8564844 - Flags: feedback?(ayang)
Comment on attachment 8564844 [details] [diff] [review]
Bug-1123669-Reset-mDrainComplete-flag-and-implement-.patch

Review of attachment 8564844 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8564844 - Flags: feedback?(ayang) → feedback+
Attachment #8564844 - Flags: review?(ajones)
Blocks: 1131467
Attachment #8564844 - Flags: review?(ajones) → review+
Carry r+ from ajones.
Attachment #8564844 - Attachment is obsolete: true
Attachment #8565395 - Flags: review+
(In reply to Blake Wu [:bwu][:blakewu] from comment #5)
> Tryserver:
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=6f1c325d64d8
Testing results look good!
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1219ad286c50
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Duplicate of this bug: 1131467
You need to log in before you can comment on or make changes to this bug.