nightly mac crashes on restart after updating

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
5 years ago
2 months ago

People

(Reporter: jonny, Unassigned)

Tracking

(Blocks 1 bug, {crash})

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150120030203

Steps to reproduce:

Go to Nightly > About Nightly > Check for Update


Actual results:

It updates and offers a button asking to restart Nightly.

On clicking the link the browser closes, then eventually, ~20-30s later the Mozilla Crash Reporter opens up telling me Nightly has crashed. Clicking Quit Nightly here, then manually opening Nightly works.


Expected results:

Nightly should just restart after updating.
Version: 36 Branch → Firefox 38
What's the crashreport ID for this crash? Do you see this often, or was it just this update?
Flags: needinfo?(jonnybarnes)
(In reply to :Gijs Kruitbosch from comment #1)
> What's the crashreport ID for this crash? Do you see this often, or was it
> just this update?

So in trying to answer this I've discovered `about:crashes` which is pretty cool.

Anyway the most recent crash is this: https://crash-stats.mozilla.com/report/index/c9b7056b-792d-42af-ab06-93bcf2150120

And no its not just this update, looking at about:crashes I've had 19 crashes this month, I think all from trying to restart nightly after installing an update.
Flags: needinfo?(jonnybarnes)
Good news: we're working on this (see the blocking/depending bugs). Bad news: not sure what to suggest in the meantime, as we don't yet know what's causing these crashes. :-(

Could be interesting to see if you can reproduce in safe mode ( https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode ), but that's about the best I can think of. :-(
Blocks: 1103833
Severity: normal → critical
Depends on: 1104317
Keywords: crash, crashreportid
Product: Firefox → Core
Version: Firefox 38 → Trunk
Just updated OSX now and it restarted without crashing :)
That meant to say updated "Nightly on OSX"
Updated nightly again today and it crashed :(
https://crash-stats.mozilla.com/report/index/b577bf36-c6e5-416a-8b7a-3d64a2150130
Does this normally crash on restarts (e.g. if you use something like https://addons.mozilla.org/en-US/firefox/addon/restartless-restart/ ) ? What about "normal" shutdown and then reopening Firefox?
Flags: needinfo?(jonnybarnes)
Nightly only ever crashes when updating to a new build. Normal quit-ing and re-opening has never resulted in a crash.

Nor does restarting with the restartless restart extension cause a crash.

(FWIW I have nightly setup to manually check for updates as oppose to automatically installing them)
Flags: needinfo?(jonnybarnes)
Restarting after update was successful today.
A reliable way to avoid this is to check for update and in the popup window simply wait a few minutes before clicking the "Restart Nightly" to complete update button.
Hi, 
I have tested this on Mac OS X 10.10 and I can't reproduce this with Nightly 46.0a1. The Nightly that you have installed on you computer from where did you downloaded?
Flags: needinfo?(jonny)
Crash Signature: [@ shutdownhang | libsystem_kernel.dylib@0x16136 ] [@ mozilla::(anonymous namespace)::RunWatchdog(void*) ]
Keywords: crashreportid
Component: Untriaged → Application Update
Product: Core → Toolkit
I’m not sure when I downloaded Nightly, but since then I’ve been updating it via the built-in updater.

Another note, after clikcing the update to {version} button I need to wait for the green update arrow to appear on the hamburger menu icon before clicking restart nightly to update, other wise it’ll crash.
Flags: needinfo?(jonny)
Hi Jonny,
Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem, based on the fact that you'll download the latest Nightly version 46.0a1 you need to wait 1 day for the new build to came up and make an update. 
Thank you for your time and trying to help us solving this problem.
Flags: needinfo?(jonny)
I can’t remember when it was, but I definitely downloaded the original .dmg file from https://nightly.mozilla.org, do you still want me to re-download?
Flags: needinfo?(jonny) → needinfo?(ovidiu.boca)
Just to make shore you can try, also please start with new profile. How to create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager
Flags: needinfo?(ovidiu.boca)
Maybe this can be marked resolved.

I can very reliably avoid crashes by clicking “Update to {version}” in the restart window, then waiting for the green update marker to appear on the hamburger menu icon before clicking “Restart to update Nightly” in the update window.
Hi Jonny,
I retested this on Mac OS X 10.10 with FF Nightly. I downloaded a build from 2016-05-01 and I updated to the last build 2016-05-12 and I couldn't reproduce it. i also create a profile where I set the Update preference to: "Check for updates, but let me choose whether to install them" after the build finished to download I was able to push the "Restart to update Nightly" button without any crashes. Please tell me if you use new profiles when you test this issue?
(In reply to ovidiu boca[:Ovidiu] from comment #17)
Jonny...

> Hi Jonny,
> I retested this on Mac OS X 10.10 with FF Nightly. I downloaded a build from
> 2016-05-01 and I updated to the last build 2016-05-12 and I couldn't
> reproduce it. i also create a profile where I set the Update preference to:
> "Check for updates, but let me choose whether to install them" after the
> build finished to download I was able to push the "Restart to update
> Nightly" button without any crashes. Please tell me if you use new profiles
> when you test this issue?
Flags: needinfo?(jonny)
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #18)
> (In reply to ovidiu boca[:Ovidiu] from comment #17)
> Jonny...
> 
> > Hi Jonny,
> > I retested this on Mac OS X 10.10 with FF Nightly. I downloaded a build from
> > 2016-05-01 and I updated to the last build 2016-05-12 and I couldn't
> > reproduce it. i also create a profile where I set the Update preference to:
> > "Check for updates, but let me choose whether to install them" after the
> > build finished to download I was able to push the "Restart to update
> > Nightly" button without any crashes. Please tell me if you use new profiles
> > when you test this issue?

Honestly I think this is just by MacBook being horrendously slow. I’m waiting for the new MBP to upgrade sometime later this year.

For example, when I click the update button it will install the update, and then the button changes to "restart nightly to...", what should happen then is a green arrow appear on the hamburger menu. It takes nearly a minute for that to appear on my laptop!
Flags: needinfo?(jonny)
(In reply to Jonny Barnes from comment #19)
> (In reply to Wayne Mery (:wsmwk, NI for questions) from comment #18)
> > (In reply to ovidiu boca[:Ovidiu] from comment #17)
> > Jonny...
> > 
> > > Hi Jonny,
> > > I retested this on Mac OS X 10.10 with FF Nightly. I downloaded a build from
> > > 2016-05-01 and I updated to the last build 2016-05-12 and I couldn't
> > > reproduce it. i also create a profile where I set the Update preference to:
> > > "Check for updates, but let me choose whether to install them" after the
> > > build finished to download I was able to push the "Restart to update
> > > Nightly" button without any crashes. Please tell me if you use new profiles
> > > when you test this issue?
> 
> Honestly I think this is just by MacBook being horrendously slow. I’m
> waiting for the new MBP to upgrade sometime later this year.
> 
> For example, when I click the update button it will install the update, and
> then the button changes to "restart nightly to...", what should happen then
> is a green arrow appear on the hamburger menu. It takes nearly a minute for
> that to appear on my laptop!

I'm probably in the same situation, but even if the computer is slow and this imply slow updates, it shouldn't lead to a browser crash.
(In reply to Clément Lefèvre from comment #20)
> (In reply to Jonny Barnes from comment #19)
> > (In reply to Wayne Mery (:wsmwk, NI for questions) from comment #18)
> > > (In reply to ovidiu boca[:Ovidiu] from comment #17)
> > > Jonny...
> > > 
> > > > Hi Jonny,
> > > > I retested this on Mac OS X 10.10 with FF Nightly. I downloaded a build from
> > > > 2016-05-01 and I updated to the last build 2016-05-12 and I couldn't
> > > > reproduce it. i also create a profile where I set the Update preference to:
> > > > "Check for updates, but let me choose whether to install them" after the
> > > > build finished to download I was able to push the "Restart to update
> > > > Nightly" button without any crashes. Please tell me if you use new profiles
> > > > when you test this issue?
> > 
> > Honestly I think this is just by MacBook being horrendously slow. I’m
> > waiting for the new MBP to upgrade sometime later this year.
> > 
> > For example, when I click the update button it will install the update, and
> > then the button changes to "restart nightly to...", what should happen then
> > is a green arrow appear on the hamburger menu. It takes nearly a minute for
> > that to appear on my laptop!
> 
> I'm probably in the same situation, but even if the computer is slow and
> this imply slow updates, it shouldn't lead to a browser crash.

I only get the crash reporter if I click the restart button before the green arrow appears on the hamburger menu, fwiw.
I've been having the same problem for a long time (at least half a year). After the green arrow shows up I click on "Restart nightly to update". Then Nightly actually updates and restarts. All I see of the crash is the bar at the bottom of the window telling me that Nightly crashed and asking whether I would like to send the crash report. This happens every time I update Nightly.
Is it expected that the update process runs into the shutdown hang system like this? I would have expected it to be a separate process, or at least not subject to the same hang detection code...
Flags: needinfo?(mhowell)
I used today's update to try something. I didn't 'restart' Nightly, by clicking on the 'restart nightly to update'-thing but instead, I quit Nightly and opened it again. That did not result in a crash!

So it might have something to do with the restart process?
Yes, the updater is a separate process. There are times when that process is running in the background and the browser has a thread blocked on it exiting, but the restart button shouldn't appear until after that's done.

The updater shouldn't be able to cause this in the normal process; if there are fallbacks happening, the most likely reason is broken permissions in the app bundle, so downloading a fresh copy might help.
Flags: needinfo?(mhowell)
Johnny, is this still happening for you with the latest nightly?
Flags: needinfo?(jonny)
As I’ve said before, I get the about window open, click the check for update button, then click upate to <version>, and then when it turns into to restart to update.

It often crashes if I click it straight away, however, if I wait for the green update ready icon to appear on the hamburger menu in the main browser window chrome and then  click the restart to update button, it restarts succesfully.
Flags: needinfo?(jonny)
(In reply to Jonny Barnes from comment #27)
> As I’ve said before, I get the about window open, click the check for update
> button, then click upate to <version>, and then when it turns into to
> restart to update.
> 
> It often crashes if I click it straight away, however, if I wait for the
> green update ready icon to appear on the hamburger menu in the main browser
> window chrome and then  click the restart to update button, it restarts
> succesfully.

I would have expected the button turning into 'restart to update' and the notification icon to be cued off the same internal notification. :mhowell, are they not? If indeed not, is there anything in the discrepancy that might explain the different behaviour the reporter is describing?
Flags: needinfo?(mhowell)
It's not the same notification, there's a separate one that's pretty much just used for prompts, but they're both triggered from the same place inside the update service; the only way to get one and not the other is if applying the update fails, which doesn't seem to be what's happening (it wouldn't just decide not to fail anymore after a few seconds pass).

Also, I tried to reproduce the crash using a few different unusual combinations of prefs and couldn't do it. I remain at a loss. :(
Flags: needinfo?(mhowell)
Just to be clear what’s happening, if I click to restart on the first screenshot firefox crashes, that doesn’t happen when clicking on the second screenshot.

Screenshot 1: http://imgur.com/a/m9ftz
Screenshot 2: http://imgur.com/a/XDcqE
Blocks: 1192778
There‘s been a new update flow recently, (last two? weeks), where I now get an updater window with a progress bar. Not seen a crash since that regardless of when I click restart to update :)

Maybe this can be closed now?
Bug 1397562 disabled update staging which is why it is no longer crashing for you.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Depends on: 1397562
Resolution: --- → WORKSFORME
Jonny, could you check if this still crashes for you with staging enabled since we will likely be enabling staging in the near future? To enable staging type about:config in the url bar, press return, click the button to accept the warning if one is displayed, type app.update.staging.enabled in the Search box that is displayed on the page, and toggle the value from false to true. The next time an update is downloaded after this it will be staged so you can check if it still crashes. Thanks!
Flags: needinfo?(jonny)
Flags: needinfo?(jonny)
You need to log in before you can comment on or make changes to this bug.