Closed Bug 1124097 Opened 5 years ago Closed 5 years ago

[Flame][Built-in&System Keyboard]Keyboard does not pup up automatically after you Add subject for message.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1119013
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: yulan.zhu, Unassigned)

Details

(Keywords: regression)

Attachments

(2 files)

Attached file logcat_1513.txt
[1.Description]:
[Flame][v2.2][Built-in&System Keyboard]Keyboard does not pup up automatically and you can't find the cursor anywhere after you Add subject for message.
Found time:15:13
Attachment:video.mp4 &logcat_1513.txt

[2.Testing Steps]: 
1.Open Messages app.
2.Tap Compose icon.
3.Hidden keyboard.
4.Tap menu icon.
5.Select Add subject.


[3.Expected Result]: 
5.Keyboard will pup up automatically and the cursor is located in the subject box.

[4.Actual Result]: 
5.Keyboard does not pup up automatically and you can't find the cursor anywhere.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f05d0a2d2378
Build-ID        20150120001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150120.035022
FW-Date         Tue Jan 20 03:50:33 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5d7497ce4cc7
Build-ID        20150120002507
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150120.035540
FW-Date         Tue Jan 20 03:55:51 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video video.mp4
This is regression.
Now, the cursor cannot automatically focus on subject field after user taps "Add subject" button.

Add regression tag.
Keywords: regression
Set 2.2? for regression, breaking existing functionality.

(In reply to William Hsu [:whsu] from comment #2)
> This is regression.
> Now, the cursor cannot automatically focus on subject field after user taps
> "Add subject" button.
> 
> Add regression tag.
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Gaia::Keyboard]
The Messages app is responsible of programmically re-focus the input box should the behavior is desired.
Component: Gaia::Keyboard → Gaia::SMS
triage: regression, breaks basic function
blocking-b2g: 2.2? → 2.2+
Dupe of bug 1119013
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119013
blocking-b2g: 2.2+ → ---
You need to log in before you can comment on or make changes to this bug.