Closed Bug 1124346 Opened 5 years ago Closed 5 years ago

[Windows Management][Edge Swipe] Tapping near the edge of the screen will cause the picture(s) to blink / flash when in the Gallery or Music App.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jmitchell, Assigned: alive)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files)

Description:
With Edge-Swipe Navigation enabled, tapping or pressing near the edge of the screen will cause the pictures on the screen to flash / blink black and then back to normal. This occurs with the Album Art of the Music App and the pictures in the Gallery app. This can occur with the main music page (showing multiple album arts) or a specific album cover when playing a single song. This can also occur on the main gallery page but is a much lower repro when on a specific gallery picture preview/full view page. 


Repro Steps:
1) Update a Flame to 20150121010204
2) Launch Music App and Gallery App
3) Tap near the edge of the screen and / or edge swipe transition between the two

Actual:
Pictures will blink

Expected:
Pictures will not blink

Environmental Variables:
Device: Flame 3.0
Build ID: 20150121010204
Gaia: 5e98dc164b17fd6decb48a9eaddef0e55b82e249
Gecko: 540077a30866
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 6/8
See attached: logcat, Video: http://youtu.be/_Rg6_7z7JpQ
----------------------------------------------------------------------

This issue does NOT repro on Flame 2.2 (v18d), 2.2 (v18d-1), or 2.1 (v18d-1)

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150121002607
Gaia: e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko: 75a462a58d7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150120002507
Gaia: f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko: 5d7497ce4cc7
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (KK - Nightly - Full Flash)
Build ID: 20150120001202
Gaia: 77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko: f05d0a2d2378
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
regression of a core feature, bad UX.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150120001341
Gaia: 90e1a2525d3cded5945cfaee277ac8d6075beb8c
Gecko: f0d42391b5fd
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150120011239
Gaia: a47ec54a7040d6f689c3eabd2f23bb510c78c0cd
Gecko: fc9006e38f20
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue DOES NOT reproduce 
Gaia: 90e1a2525d3cded5945cfaee277ac8d6075beb8c
Gecko: fc9006e38f20

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: a47ec54a7040d6f689c3eabd2f23bb510c78c0cd
Gecko: f0d42391b5fd

https://github.com/mozilla-b2g/gaia/compare/90e1a2525d3cded5945cfaee277ac8d6075beb8c...a47ec54a7040d6f689c3eabd2f23bb510c78c0cd

Caused by Bug 1117633
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Alive, can you take a look at this please? This might have been caused by the landing for bug 1117633
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Sure, thanks.
Assignee: nobody → alive
Flags: needinfo?(alive)
I believe this is side effect of "setActive(false)" while sheet transition starts.
I am going to remove the setVisible function call and use events to notify nfcManager, what do you think?
Flags: needinfo?(etienne)
We should definitely file a gecko bug first & reference it in code :/
Flags: needinfo?(etienne)
Triage: regression, blocking.
blocking-b2g: 3.0? → 3.0+
(In reply to Etienne Segonzac (:etienne) from comment #6)
> We should definitely file a gecko bug first & reference it in code :/

Filing but not sure how to well describe it..
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #8)
> (In reply to Etienne Segonzac (:etienne) from comment #6)
> > We should definitely file a gecko bug first & reference it in code :/
> 
> Filing but not sure how to well describe it..

https://bugzilla.mozilla.org/show_bug.cgi?id=1125792
Comment on attachment 8554499 [details] [review]
[PullReq] alivedise:bugzilla/1124346/set-active-cause-flicker to mozilla-b2g:master

I am not sure if I have to remove setNFCFocus call in setActive but leave it as is.
Attachment #8554499 - Flags: review?(etienne)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #11)
> Comment on attachment 8554499 [details] [review]
> [PullReq] alivedise:bugzilla/1124346/set-active-cause-flicker to
> mozilla-b2g:master
> 
> I am not sure if I have to remove setNFCFocus call in setActive but leave it
> as is.

Well, per https://bugzilla.mozilla.org/show_bug.cgi?id=1125023 we should just remove setNFCFocus in setActive...
Comment on attachment 8554499 [details] [review]
[PullReq] alivedise:bugzilla/1124346/set-active-cause-flicker to mozilla-b2g:master

thanks!
Attachment #8554499 - Flags: review?(etienne) → review+
Comment on attachment 8554499 [details] [review]
[PullReq] alivedise:bugzilla/1124346/set-active-cause-flicker to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Regression from bug 1117633
[User impact] if declined:
Nfc will not work
[Testing completed]: Y
[Risk to taking this patch] (and alternatives if risky): this is regression of bug 1117633 so if it gets uplifted we need this patch as well
[String changes made]: NaN
Attachment #8554499 - Flags: approval-gaia-v2.2?
Attachment #8554499 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Attached video Verify_video.mp4
The problem is verified not happen on latest Flame 2.2 & 3.0 build.

Repro Steps:
1) Update a Flame to Latest build
2) Launch Music App and Gallery App
3) Tap near the edge of the screen and / or edge swipe transition between the two

Actual Result:
3) Pictures will not blink


Fail rate:0/10
See attachment:Verify_video.MP4

Flame 2.2 version:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0
Flame 3.0 version:
Flame3.0:
Build ID               20150225010244
Gaia Revision          f6bfd854fe4746f21bc006eac145365e85f98808
Gaia Date              2015-02-24 21:10:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a8b3b67715a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.043702
Firmware Date          Wed Feb 25 04:37:14 EST 2015
Bootloader             L1TC00011880
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.