setNFCFocus(false) is called when ShrinkingUI pops up

RESOLVED DUPLICATE of bug 1124346

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1124346
4 years ago
3 years ago

People

(Reporter: allstars, Assigned: alive)

Tracking

unspecified
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

STR:
1. Enable NFC
2. Launch Gallery app, and select a photo
3. Tap another NFC device, then Shrinking-UI pops up

At this moment I observed that setNFCFocus(false) is called on the Browser Element of the the Gallery app, which should be wrong since Gallery app is visible to user and user is going to share the phote by NFC.
(Reporter)

Updated

4 years ago
Flags: needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)
Fixed by bug 1124346; reopen if still happens
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1124346
(Reporter)

Updated

3 years ago
No longer depends on: 1117633
[REOPENED for v2.2]
Hi Alive,

Bug 1124346 is fixed on master only and it's "status-b2g-v2.2: 	unaffected" which means we won't have the patch in 2.2.
I think we can either uplift bug 1124346 to 2.2 or have a separate patch for 2.2 on this bug.
Please kindly advise which approach is better.
Status: RESOLVED → REOPENED
blocking-b2g: --- → 2.2?
Flags: needinfo?(alive)
Resolution: DUPLICATE → ---
(Reporter)

Updated

3 years ago
Depends on: 1117633
We should uplift this and 1117633 at the same time.
Flags: needinfo?(alive)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #4)
> We should uplift this and 1117633 at the same time.

Correct: 1124346 and 1117633

Comment 6

3 years ago
Triage: mark as blocker since it blocks feature 2.2 bugs
blocking-b2g: 2.2? → 2.2+
FYR the feature-b2g: 2.2 originated from bug 1082440 comment 17.

Comment 8

3 years ago
qawanted to check if the issue is fixed in 2.2 by bug 1124346 and bug 1117633
Keywords: qawanted
Is more information available about how this issue should be tested? Is "setNFCFocus(false)" something we should be looking for in a logcat, or is there a description of a visual representation we can look for?
Please test v2.2/master and close this bug if it's fixed.
Flags: needinfo?(allstars.chh)
works in master and v2.2
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(allstars.chh)
Resolution: --- → DUPLICATE
Duplicate of bug: 1124346
(Reporter)

Updated

3 years ago
Blocks: 1129841
However I found the regression that setFocusApp(false) won't be called when the app is in background.

Filed a follow-up bug Bug 1129841.
QA Whiteboard: [MGSEI-Triage+]
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.