WebGL context alpha:false affects all framebuffers

RESOLVED DUPLICATE of bug 1125445

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 1125445
3 years ago
3 years ago

People

(Reporter: arthur, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8552732 [details]
alphacontext.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

1. Create WebGL context with alpha:false argument.
2. Create an RGBA texture and a framebuffer.
3. Render something into the texture writing to both color and alpha.
4. Read the texture.


Actual results:

Alpha channel is not written.


Expected results:

Both color and alpha must be written. Context argument should only affect main framebuffer blending with the page.

Test page: http://geom.io/pc33/testAlphaWrite.html
You should see 2 gradients (left is read from RGB, right is from A).
Works fine on Chrome/IE and even on Firefox 33.1.1, but broken in new (35).

Comment 1

3 years ago
Confirmed, see Blend4Web Cartoon Interior demo:
https://www.blend4web.com/tutorials/examples/cartoon_interior/cartoon_interior.html

Comment 2

3 years ago
Update: Cartoon Interiod demo has been already fixed (alpha:true workaround), check demos from bug 1124187
Sounds like your bug Jeff.
Flags: needinfo?(jgilbert)
Whiteboard: [gfx-noted]

Comment 4

3 years ago
This issue badly breaks Cesium (http://cesiumjs.org/) as well.

Compare any of our demos against Chrome or IE and you'll see that anything with translucency ends up either having a solid color or turns white.  For example: http://cesiumjs.org/Cesium/Apps/Sandcastle/index.html?src=Geometry%20and%20Appearances.html&label=Showcases

What are the changes that this gets fixed and pushed out with a 35.02 update?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1125445
You need to log in before you can comment on or make changes to this bug.