Closed Bug 1124487 Opened 5 years ago Closed 5 years ago

Firefox crash in OOM | unknown | mozalloc_abort(char const* const) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | mozilla::WMFAudioMFTManager::Output(__int64, nsRefPtr<mozilla::MediaData>&)

Categories

(Core :: Audio/Video, defect, P1, critical)

x86
Windows Vista
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marcia, Assigned: marcia)

References

(Blocks 1 open bug, )

Details

(Keywords: crash, reproducible)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-f8462866-8f20-47f0-8b35-be7f82150122.
=============================================================

Seen while running Mozilla/5.0 (Windows NT 6.0; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150121030203 CSet: 540077a30866

e10s is set to on during this test.

STR:
1. Start playing https://www.youtube.com/watch?v=dYk9G21TwpQ and leave the machine idle.
2. Return to the machine after some time.
3. Windows error is present mentioned that plugin container has crashed and to close the program or report the problem

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	plugin-container.exe
  Application Version:	38.0.0.5499
  Application Timestamp:	54bfb02e
  Fault Module Name:	xul.dll
  Fault Module Version:	38.0.0.5499
  Fault Module Timestamp:	54bfaf34
  Exception Code:	c0000005
  Exception Offset:	003a53a8
  OS Version:	6.0.6002.2.2.0.256.1
  Locale ID:	1033
  Additional Information 1:	9620
  Additional Information 2:	af88269dcdf44a894499ad423bd64a45
  Additional Information 3:	d0dd
  Additional Information 4:	606f58db9b08e48c3f1fe4782e87620d

Frame 	Module 	Signature 	Source
0 	mozalloc.dll 	mozalloc_abort(char const* const) 	memory/mozalloc/mozalloc_abort.cpp
1 	mozalloc.dll 	mozalloc_handle_oom(unsigned int) 	memory/mozalloc/mozalloc_oom.cpp
2 	mozalloc.dll 	moz_xmalloc 	memory/mozalloc/mozalloc.cpp
3 	xul.dll 	mozilla::WMFAudioMFTManager::Output(__int64, nsRefPtr<mozilla::MediaData>&) 	dom/media/fmp4/wmf/WMFAudioMFTManager.cpp
4 	xul.dll 	mozilla::WMFMediaDataDecoder::ProcessOutput() 	dom/media/fmp4/wmf/WMFMediaDataDecoder.cpp
5 	xul.dll 	mozilla::WMFMediaDataDecoder::ProcessDecode(mp4_demuxer::MP4Sample*) 	dom/media/fmp4/wmf/WMFMediaDataDecoder.cpp
6 	xul.dll 	nsRunnableMethodImpl<void ( mozilla::DataStorage::*)(char const*), char const*, 1>::Run() 	xpcom/glue/nsThreadUtils.h
7 	xul.dll 	mozilla::MediaTaskQueue::Runner::Run() 	dom/media/MediaTaskQueue.cpp
8 	xul.dll 	nsThreadPool::Run() 	xpcom/threads/nsThreadPool.cpp
9 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
10 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
11 	xul.dll 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
12 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
13 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
14 	xul.dll 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp
15 	nss3.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c
16 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c
17 	msvcr120.dll 	_callthreadstartex 	f:\dd\vctools\crt\crtw32\startup\threadex.c:376
18 	msvcr120.dll 	msvcr120.dll@0x2c000 	
19 	kernel32.dll 	BaseThreadInitThunk 	
20 	ntdll.dll 	__RtlUserThreadStart 	
21 	ntdll.dll 	_RtlUserThreadStart
Blocks: MSE
Whiteboard: [MemShrink]
reproducible on the machine in the Mt. View QA lab.
Keywords: reproducible
does this happen without e10s activated?
Flags: needinfo?(mozillamarcia.knous)
Will try this again next week. Yesterday we had a network outage and today I don't have that machine to test.
(In reply to Jean-Yves Avenard [:jya] from comment #2)
> does this happen without e10s activated?

Yes, it definitely does with the Vista machine - the signature is a bit different when I crashed today -> https://crash-stats.mozilla.com/report/index/7acc822d-a452-423f-8a54-092132150126
Flags: needinfo?(mozillamarcia.knous)
Priority: -- → P1
The only place allocating memory here is the new AudioData, so could make it fallible there as well and return an error when OOM
Flags: needinfo?(cpearce)
Sounds reasonable to me. Failiablize all the mallocs!
Flags: needinfo?(cpearce)
Assignee: nobody → jyavenard
Marcia, can you reproduce the crash in a debug build? so we can check which part fails to allocate data?
Flags: needinfo?(mozillamarcia.knous)
likely fixed by bug 1127122
Attached file debug.txt
Here is a log when the video is running in a debug nightly build. Eventually I get an app crash dialog and the browser stops.
Flags: needinfo?(mozillamarcia.knous)
I don't think this needs the MemShrink tag. Looks like it's in hand anyway.
Whiteboard: [MemShrink]
Assignee: jyavenard → mozillamarcia.knous
Since we have moved over to testing aurora, I have not seen this crash on the same Vista machine. Also the video used for testing has been removed from you tube, so I cannot retest with the exact same video. 

Resolving this as WFM for now, it it is seen again I can reopen it.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Attached image debugger screen shot
I got an OOM crash after over 100 hours of playing back YouTube :) Posting this up in case this stack trace helps with further bulletproofing.
You need to log in before you can comment on or make changes to this bug.