[Flame][Settings]There are reduplicative years in year list of Age Verification page.

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: liuyong, Assigned: ferjm)

Tracking

({regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

105.50 KB, text/plain
Details
5.36 MB, video/mp4
Details
v1
46 bytes, text/x-github-pull-request
alive
: review+
Details | Review
Posted file logcat_1554.txt
[1.Description]:
[Flame][v2.2][Settings]There are reduplicative years in age list of Age Verification page after user back to Age Verifycation list from Create Password page. 
Found time:15:54
Attachment:logcat_1554.txt &video.mp4

[2.Testing Steps]: 
1.Enter Settings -> Firefox accounts.
2.Click 'Create account or sign in'.
3.Enter email address and then tap next.
4.Select "2002 or earlier" and then tap Next..
5.Tap Back.
6.Open age list and check.

[3.Expected Result]: 
6.There is no reduplicative years in year list.

[4.Actual Result]: 
6.There are reduplicative years in year list.

[5.Reproduction build]: 
Flame 2.2:
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Build-ID        20150122002808
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150122.041326
FW-Date         Thu Jan 22 04:13:37 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Posted video video.mp4
Set 2.2? for regression.
QA Whiteboard: [COM=Gaia::Settings]
Keywords: regression
We have tested regression on Flame 2.2:

Last Working Environmental Variables:

Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/b9f40d0310d5
Build-ID        20150105030453
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.mozilla.20150211.134931
FW-Date         Wed Feb 11 13:53:22 CST 2015
Bootloader      L1TC000118D0

First Broken Environmental Variables:

Gaia-Rev        4ceeff19086b2a2955f044ad923dcfa63a293de3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/912036eeb024
Build-ID        20150105033341
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.mozilla.20150211.134931
FW-Date         Wed Feb 11 13:53:22 CST 2015
Bootloader      L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro

Gaia-Rev        4ceeff19086b2a2955f044ad923dcfa63a293de3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/b9f40d0310d5
Build-ID        20150105030453
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150210.041059
FW-Date         Tue Feb 10 04:11:10 EST 2015
Bootloader      L1TC000118D0

First Broken Gecko & Last Working Gaia - issue does NOT repro

Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/912036eeb024
Build-ID        20150105033341
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150210.041059
FW-Date         Tue Feb 10 04:11:10 EST 2015
Bootloader      L1TC000118D0
Forgot to flip that, set 2.2? for regression
blocking-b2g: --- → 2.2?
Component: Gaia::Settings → FxA
Triage is blocking based on the fact that this is regression.
blocking-b2g: 2.2? → 2.2+
Chris, is this something that you can help? Thank you.
Flags: needinfo?(ckarlof)
I found that, every time, after I pressed 'next' and pressed 'previous' to go to this page, all options are duplicated again.
Flags: needinfo?(ckarlof)
Jared, are you familiar with this implementation? Can you spend a little time to repro, debug, and scope out the work needed to fix it?
Flags: needinfo?(6a68)
I don't know what the underlying bug might be, but looking at changes within the regression window[1], I wonder if the bug was introduced by the fix for bug 1116986. Fernando, mind taking a look?
Flags: needinfo?(6a68) → needinfo?(ferjmoreno)
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
Posted file v1
Attachment #8576724 - Flags: review?(alive)
Comment on attachment 8576724 [details] [review]
v1

LGTM
Attachment #8576724 - Flags: review?(alive) → review+
Thanks Alive!
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/8aeb0130db6db129128be892ab3c226e044283c4
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this when you get a chance.
Flags: needinfo?(ferjmoreno)
Target Milestone: --- → 2.2 S8 (20mar)
Comment on attachment 8576724 [details] [review]
v1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Firefox Accounts. Bug 1116986
[User impact] if declined: Bad UX. The user will see duplicated entries in the age selection form.
[Testing completed]: Manual tests. Unit test added.
[Risk to taking this patch] (and alternatives if risky): Very low. The change is isolated and only affects the FxA COPPA screen.
[String changes made]: None.
Flags: needinfo?(ferjmoreno)
Attachment #8576724 - Flags: approval-gaia-v2.2?
Attachment #8576724 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The years do not repeat when going back to the age verification prompt.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150323010204
Gaia: 9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gecko: e730012260a4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150323002504
Gaia: 7f367fc98ffdd183f21d2cdfe20556ab877ece34
Gecko: 3ea0eaeda353
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::Settings] → [QAnalyst-Triage?][COM=Gaia::Settings]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Gaia::Settings] → [QAnalyst-Triage+][COM=Gaia::Settings]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.